Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение значения по столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение значения по столбцам (Формулы/Formulas)
Нахождение значения по столбцам
Belfegor4ik Дата: Воскресенье, 10.05.2020, 14:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Никак не могу найти решение одной своей проблемы. Есть план работы по дням и необходимо к нему сделать расчет стоимости изделия. Необходимо чтоб сравнивались данные в ячейке с диапазоном и при совпадении выводилась цена изделия по совпадению. Если конкретно то =Если(С3='Склад'!А1:А53 (значение из диапазона например З.Кристалл 4мм);цена за М2 этого материала F52; "")
К сообщению приложен файл: 5280987.xls(109.5 Kb)
 
Ответить
СообщениеДобрый день! Никак не могу найти решение одной своей проблемы. Есть план работы по дням и необходимо к нему сделать расчет стоимости изделия. Необходимо чтоб сравнивались данные в ячейке с диапазоном и при совпадении выводилась цена изделия по совпадению. Если конкретно то =Если(С3='Склад'!А1:А53 (значение из диапазона например З.Кристалл 4мм);цена за М2 этого материала F52; "")

Автор - Belfegor4ik
Дата добавления - 10.05.2020 в 14:11
jakim Дата: Воскресенье, 10.05.2020, 15:39 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 942
Репутация: 247 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(VLOOKUP(C3;Склад!$A$9:$B$53;2;0);"")
 
Ответить
Сообщение
Формула

Код
=IFERROR(VLOOKUP(C3;Склад!$A$9:$B$53;2;0);"")

Автор - jakim
Дата добавления - 10.05.2020 в 15:39
bigor Дата: Воскресенье, 10.05.2020, 15:50 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 32 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте

Чуть допилив вашу
Код
=MIN(IF(C3=Склад.$A$9:$A$52;Склад.$B$9:$B$52;""))

массивная
Или обычная
Код
=INDEX(Склад.$A$9:$B$53;MATCH(C3;Склад.$A$9:$A$53;0);2)
 
Ответить
СообщениеЗдравствуйте

Чуть допилив вашу
Код
=MIN(IF(C3=Склад.$A$9:$A$52;Склад.$B$9:$B$52;""))

массивная
Или обычная
Код
=INDEX(Склад.$A$9:$B$53;MATCH(C3;Склад.$A$9:$A$53;0);2)

Автор - bigor
Дата добавления - 10.05.2020 в 15:50
Che79 Дата: Воскресенье, 10.05.2020, 17:16 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1450
Репутация: 263 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте
Как вариант
Код
=ЕСЛИ(C3="";"";ПРОСМОТР(;-ПОИСК(C3;Склад!$A$9:$A$53);Склад!$B$9:$B$53))
Важно! Значения в аргументе просматриваемый_вектор в ПРОСМОТРе должны быть расположены в порядке возрастания!


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте
Как вариант
Код
=ЕСЛИ(C3="";"";ПРОСМОТР(;-ПОИСК(C3;Склад!$A$9:$A$53);Склад!$B$9:$B$53))
Важно! Значения в аргументе просматриваемый_вектор в ПРОСМОТРе должны быть расположены в порядке возрастания!

Автор - Che79
Дата добавления - 10.05.2020 в 17:16
AlexM Дата: Воскресенье, 10.05.2020, 22:11 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4161
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММЕСЛИ(Склад!A$9:A$53;C3;Склад!B$9:B$53)

Формат ячеек 0;;



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 10.05.2020, 22:12
 
Ответить
Сообщение
Код
=СУММЕСЛИ(Склад!A$9:A$53;C3;Склад!B$9:B$53)

Формат ячеек 0;;

Автор - AlexM
Дата добавления - 10.05.2020 в 22:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение значения по столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!