Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Второе, третье и т.д. найденные значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Второе, третье и т.д. найденные значения (Формулы/Formulas)
Второе, третье и т.д. найденные значения
Tavlar Дата: Четверг, 14.05.2020, 07:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
есть формула массива
Код
=ИНДЕКС(Таблица2[Номер];НАИМЕНЬШИЙ(ПОИСКПОЗ(Губкинский!$G$7&Губкинский!$E$10;Таблица2[Оборудование]&Таблица2[Локация];0);H10))

Т.е. находится первое значение по заданным двум условиям.
Как в следующей ячейке вывести следующие значения (второе, третье и т.д.)


Сообщение отредактировал Tavlar - Четверг, 14.05.2020, 08:02
 
Ответить
СообщениеЗдравствуйте.
есть формула массива
Код
=ИНДЕКС(Таблица2[Номер];НАИМЕНЬШИЙ(ПОИСКПОЗ(Губкинский!$G$7&Губкинский!$E$10;Таблица2[Оборудование]&Таблица2[Локация];0);H10))

Т.е. находится первое значение по заданным двум условиям.
Как в следующей ячейке вывести следующие значения (второе, третье и т.д.)

Автор - Tavlar
Дата добавления - 14.05.2020 в 07:50
AlexM Дата: Четверг, 14.05.2020, 09:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4161
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2003
Tavlar, из справки по функции
НАИМЕНЬШИЙ(массив;k)
Массив — массив или диапазон числовых данных, для которого определяется k-ое наименьшее значение.
k — позиция (начиная с наименьшей) в массиве или интервале ячеек данных.

В вашей формуле Н10 и есть k. Меняете значение этого аргумента и получаете второе, третье и т.д.

Точнее при наличии примера.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 14.05.2020, 09:03
 
Ответить
СообщениеTavlar, из справки по функции
НАИМЕНЬШИЙ(массив;k)
Массив — массив или диапазон числовых данных, для которого определяется k-ое наименьшее значение.
k — позиция (начиная с наименьшей) в массиве или интервале ячеек данных.

В вашей формуле Н10 и есть k. Меняете значение этого аргумента и получаете второе, третье и т.д.

Точнее при наличии примера.

Автор - AlexM
Дата добавления - 14.05.2020 в 09:02
Tavlar Дата: Четверг, 14.05.2020, 09:29 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
вот пример
К сообщению приложен файл: 0492634.xls(455.5 Kb)
 
Ответить
Сообщениевот пример

Автор - Tavlar
Дата добавления - 14.05.2020 в 09:29
Nic70y Дата: Четверг, 14.05.2020, 09:54 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6142
Репутация: 1356 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(Данные!H:H;НАИМЕНЬШИЙ(ЕСЛИ($G$7&ВПР("яя";$E$1:$E10;1)=Данные!$G$14:$G$751&Данные!$J$14:$J$751;СТРОКА(Данные!$G$14:$G$751));СТРОКА()-ПОИСКПОЗ("яя";$E$1:$E10)+1))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(Данные!H:H;НАИМЕНЬШИЙ(ЕСЛИ($G$7&ВПР("яя";$E$1:$E10;1)=Данные!$G$14:$G$751&Данные!$J$14:$J$751;СТРОКА(Данные!$G$14:$G$751));СТРОКА()-ПОИСКПОЗ("яя";$E$1:$E10)+1))

Автор - Nic70y
Дата добавления - 14.05.2020 в 09:54
Tavlar Дата: Четверг, 14.05.2020, 11:16 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо, все четко работает.
Но хотелось бы разобраться для себя.
Объясните, пожалуйста, принцип действия данной формулы
Код
ВПР("яя";$E$1:$E10;1)
 
Ответить
СообщениеСпасибо, все четко работает.
Но хотелось бы разобраться для себя.
Объясните, пожалуйста, принцип действия данной формулы
Код
ВПР("яя";$E$1:$E10;1)

Автор - Tavlar
Дата добавления - 14.05.2020 в 11:16
Nic70y Дата: Четверг, 14.05.2020, 11:22 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6142
Репутация: 1356 ±
Замечаний: 0% ±

ru13;10;03
яя - "большой текст"
ищем неточным поиском и соот. находим значение последней заполненной текстом ячейки


Яндекс Деньги 41001841029809
 
Ответить
Сообщениеяя - "большой текст"
ищем неточным поиском и соот. находим значение последней заполненной текстом ячейки

Автор - Nic70y
Дата добавления - 14.05.2020 в 11:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Второе, третье и т.д. найденные значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!