Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Авто-й расчет на основании нескольких исходных данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто-й расчет на основании нескольких исходных данных (Формулы/Formulas)
Авто-й расчет на основании нескольких исходных данных
nikitaekb196 Дата: Четверг, 14.05.2020, 14:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Задача
Автоматически указывать скидку на товар (согласно коллекции и линейке товара) при выборе из выпадающего списка Поставщиков.
На сегодня получилось следующие Скидка проставляется, но только по параметру "линейка", при этом необходимо каждый раз при замене Поставщика изменять формулу.
К сообщению приложен файл: 4932904.xlsx(12.3 Kb)
 
Ответить
СообщениеЗадача
Автоматически указывать скидку на товар (согласно коллекции и линейке товара) при выборе из выпадающего списка Поставщиков.
На сегодня получилось следующие Скидка проставляется, но только по параметру "линейка", при этом необходимо каждый раз при замене Поставщика изменять формулу.

Автор - nikitaekb196
Дата добавления - 14.05.2020 в 14:25
Pelena Дата: Четверг, 14.05.2020, 14:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15759
Репутация: 3436 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Код
=СУММПРОИЗВ('Скидки Поставщиков'!$C$2:$D$3*('Скидки Поставщиков'!$A$2:$A$3=D4)*('Скидки Поставщиков'!$B$2:$B$3=E4)*('Скидки Поставщиков'!$C$1:$D$1=$F$2))
К сообщению приложен файл: 0561873.xlsx(12.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Код
=СУММПРОИЗВ('Скидки Поставщиков'!$C$2:$D$3*('Скидки Поставщиков'!$A$2:$A$3=D4)*('Скидки Поставщиков'!$B$2:$B$3=E4)*('Скидки Поставщиков'!$C$1:$D$1=$F$2))

Автор - Pelena
Дата добавления - 14.05.2020 в 14:44
nikitaekb196 Дата: Четверг, 14.05.2020, 14:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, добрый день!
Спасибо Вам огромное (потратил на поиск ответов кучу времени), очень выручили!
 
Ответить
СообщениеPelena, добрый день!
Спасибо Вам огромное (потратил на поиск ответов кучу времени), очень выручили!

Автор - nikitaekb196
Дата добавления - 14.05.2020 в 14:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто-й расчет на основании нескольких исходных данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!