Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование соседних значений из одного списка в другой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование соседних значений из одного списка в другой (Формулы/Formulas)
Копирование соседних значений из одного списка в другой
vladisi Дата: Пятница, 15.05.2020, 20:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте!

Есть большой список переменных вида (название + цифра) около 1000 позиций. А также есть маленький список из 40 позиций (только название), которые частично одинаковые с большим списком.

Нужно вывести значения из большого списка для одинаковых переменных из маленького списка. Например, в первом списке есть "development = 0.5", проверить, есть ли переменная "development" в маленьком списке и если есть, то написать рядом с ней значение 0.5. Если значение отсутствует, то оставить ячейку пустой.

Заранее спасибо за помощь!
К сообщению приложен файл: _____--.xlsx(12.2 Kb)
 
Ответить
СообщениеЗдравствуйте!

Есть большой список переменных вида (название + цифра) около 1000 позиций. А также есть маленький список из 40 позиций (только название), которые частично одинаковые с большим списком.

Нужно вывести значения из большого списка для одинаковых переменных из маленького списка. Например, в первом списке есть "development = 0.5", проверить, есть ли переменная "development" в маленьком списке и если есть, то написать рядом с ней значение 0.5. Если значение отсутствует, то оставить ячейку пустой.

Заранее спасибо за помощь!

Автор - vladisi
Дата добавления - 15.05.2020 в 20:36
Pelena Дата: Пятница, 15.05.2020, 21:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16790
Репутация: 3622 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(E2;$A$2:$B$139;2;0);"")
К сообщению приложен файл: 9418176.xlsx(12.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(E2;$A$2:$B$139;2;0);"")

Автор - Pelena
Дата добавления - 15.05.2020 в 21:08
vladisi Дата: Суббота, 16.05.2020, 20:03 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, спасибо большое!
 
Ответить
СообщениеPelena, спасибо большое!

Автор - vladisi
Дата добавления - 16.05.2020 в 20:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование соседних значений из одного списка в другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!