Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сумма если одно или оба условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма если одно или оба условия (Формулы/Formulas)
сумма если одно или оба условия
vosduh Дата: Суббота, 16.05.2020, 19:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Прошу помочь с формулой. В примере подробно описал проблему.
К сообщению приложен файл: _____.xlsx(10.7 Kb)
 
Ответить
СообщениеПрошу помочь с формулой. В примере подробно описал проблему.

Автор - vosduh
Дата добавления - 16.05.2020 в 19:42
Pelena Дата: Суббота, 16.05.2020, 20:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16805
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Если дат всего две, то можно так
Код
=СУММПРОИЗВ((B2:F2+B3:F3>0)*B1:F1)

если дат много, то формула массива
Код
=СУММ(B1:F1*(МУМНОЖ(ТРАНСП(СТРОКА($B$2:$F$3))^0;--B2:F3)>0))
К сообщению приложен файл: -3-.xlsx(12.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Если дат всего две, то можно так
Код
=СУММПРОИЗВ((B2:F2+B3:F3>0)*B1:F1)

если дат много, то формула массива
Код
=СУММ(B1:F1*(МУМНОЖ(ТРАНСП(СТРОКА($B$2:$F$3))^0;--B2:F3)>0))

Автор - Pelena
Дата добавления - 16.05.2020 в 20:31
vosduh Дата: Суббота, 16.05.2020, 20:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena,
Спасибо. Да дат 2, но приятно за вторую формулу(заинтересованное участие). Всё работает, спасибо.
 
Ответить
СообщениеPelena,
Спасибо. Да дат 2, но приятно за вторую формулу(заинтересованное участие). Всё работает, спасибо.

Автор - vosduh
Дата добавления - 16.05.2020 в 20:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма если одно или оба условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!