Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить тип раздела в зависимости от уровня нумерации - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить тип раздела в зависимости от уровня нумерации (Формулы/Formulas)
Определить тип раздела в зависимости от уровня нумерации
yda Дата: Среда, 20.05.2020, 13:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Есть монгоуровневая нумерация в одном столбце 1, 1.1, 1.2.1, 1.2.3.4 и т.д.
В зависимости от уровня необходимо в соседнем столбце прописать тип "Результат", "Значение результат", "КТ", "Мероприятия КТ"

Если в ячейке стоит значение "2" - в соседней ячейке проставить "Результат"
Если в ячейке стоит значение "5" - в соседней ячейке проставить "Результат"
Если в ячейке стоит "4.2" - в соседней ячейке проставить "Характеристика результата"
Если в ячейке стоит "3.2" - в соседней ячейке проставить "Характеристика результата"
Если в ячейке стоит "2.2.1" - в соседней ячейке проставить "КТ"
Если в ячейке стоит "1.2.1.4" - в соседней ячейке проставить "Мероприятие КТ"
и т.д. в зависимости от уровня

Как это сделать?


Сообщение отредактировал yda - Среда, 20.05.2020, 13:25
 
Ответить
СообщениеЕсть монгоуровневая нумерация в одном столбце 1, 1.1, 1.2.1, 1.2.3.4 и т.д.
В зависимости от уровня необходимо в соседнем столбце прописать тип "Результат", "Значение результат", "КТ", "Мероприятия КТ"

Если в ячейке стоит значение "2" - в соседней ячейке проставить "Результат"
Если в ячейке стоит значение "5" - в соседней ячейке проставить "Результат"
Если в ячейке стоит "4.2" - в соседней ячейке проставить "Характеристика результата"
Если в ячейке стоит "3.2" - в соседней ячейке проставить "Характеристика результата"
Если в ячейке стоит "2.2.1" - в соседней ячейке проставить "КТ"
Если в ячейке стоит "1.2.1.4" - в соседней ячейке проставить "Мероприятие КТ"
и т.д. в зависимости от уровня

Как это сделать?

Автор - yda
Дата добавления - 20.05.2020 в 13:05
Паштет Дата: Среда, 20.05.2020, 14:08 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 123
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Для указанных четырех уровней можно так:
Код
=ЕСЛИ((ДЛСТР($A1)-ДЛСТР(ПОДСТАВИТЬ($A1;".";"")))/ДЛСТР(".")=0;"Результат";ЕСЛИ((ДЛСТР($A1)-ДЛСТР(ПОДСТАВИТЬ($A1;".";"")))/ДЛСТР(".")=1;"Характеристика результата";ЕСЛИ((ДЛСТР($A1)-ДЛСТР(ПОДСТАВИТЬ($A1;".";"")))/ДЛСТР(".")=2;"КТ";"Мероприятия КТ")))
 
Ответить
СообщениеДля указанных четырех уровней можно так:
Код
=ЕСЛИ((ДЛСТР($A1)-ДЛСТР(ПОДСТАВИТЬ($A1;".";"")))/ДЛСТР(".")=0;"Результат";ЕСЛИ((ДЛСТР($A1)-ДЛСТР(ПОДСТАВИТЬ($A1;".";"")))/ДЛСТР(".")=1;"Характеристика результата";ЕСЛИ((ДЛСТР($A1)-ДЛСТР(ПОДСТАВИТЬ($A1;".";"")))/ДЛСТР(".")=2;"КТ";"Мероприятия КТ")))

Автор - Паштет
Дата добавления - 20.05.2020 в 14:08
yda Дата: Среда, 20.05.2020, 14:18 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Паштет, все работает, формула огонь))) Мне до этого уровня пока далеко. Спасибо.
 
Ответить
СообщениеПаштет, все работает, формула огонь))) Мне до этого уровня пока далеко. Спасибо.

Автор - yda
Дата добавления - 20.05.2020 в 14:18
bmv98rus Дата: Четверг, 21.05.2020, 13:03 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3248
Репутация: 559 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=LOOKUP(LEN(A1)-LEN(SUBSTITUTE(A1;".";));{0;1;2;3};{"Результат";"Характеристика результата";"КТ";"Мероприятия КТ"})

или
Код
=VLOOKUP(LEN(A1)-LEN(SUBSTITUTE(A1;".";));{0\"Результат";1\"Характеристика результата";2\"КТ";3\"Мероприятия КТ"};2;)

или
Код
=CHOOSE(1+LEN(A1)-LEN(SUBSTITUTE(A1;".";));"Результат";"Характеристика результата";"КТ";"Мероприятия КТ")


А тема скорее : Определить тип раздела в зависимости от уровня нумерации.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 21.05.2020, 13:06
 
Ответить
Сообщение
Код
=LOOKUP(LEN(A1)-LEN(SUBSTITUTE(A1;".";));{0;1;2;3};{"Результат";"Характеристика результата";"КТ";"Мероприятия КТ"})

или
Код
=VLOOKUP(LEN(A1)-LEN(SUBSTITUTE(A1;".";));{0\"Результат";1\"Характеристика результата";2\"КТ";3\"Мероприятия КТ"};2;)

или
Код
=CHOOSE(1+LEN(A1)-LEN(SUBSTITUTE(A1;".";));"Результат";"Характеристика результата";"КТ";"Мероприятия КТ")


А тема скорее : Определить тип раздела в зависимости от уровня нумерации.

Автор - bmv98rus
Дата добавления - 21.05.2020 в 13:03
yda Дата: Четверг, 21.05.2020, 15:12 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
bmv98rus, спасибо)
 
Ответить
Сообщениеbmv98rus, спасибо)

Автор - yda
Дата добавления - 21.05.2020 в 15:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить тип раздела в зависимости от уровня нумерации (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!