Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для проставления код"В" в праздничные дни года - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для проставления код"В" в праздничные дни года (Формулы/Formulas)
Формула для проставления код"В" в праздничные дни года
tvyur Дата: Понедельник, 25.05.2020, 09:49 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток! Уважаемые гуру экселя, помогите пожалуйста, откорректировать формулу, чтоб , если в графике день недели совпадает с праздничным, то у каждого работника в этот день проставлялся код "В".
К сообщению приложен файл: 0979188.xlsx(60.5 Kb)


tvyur
 
Ответить
СообщениеДоброго времени суток! Уважаемые гуру экселя, помогите пожалуйста, откорректировать формулу, чтоб , если в графике день недели совпадает с праздничным, то у каждого работника в этот день проставлялся код "В".

Автор - tvyur
Дата добавления - 25.05.2020 в 09:49
Che79 Дата: Понедельник, 25.05.2020, 10:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1648
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
tvyur, здравствуйте. Не сильно вникал в суть, но может так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ДЕНЬНЕД(F$14;2)>5;F$14=праздники!$A$1:$A$12);"В";$D15*8);"")
формула массива (CSE)


Делай нормально и будет нормально!
 
Ответить
Сообщениеtvyur, здравствуйте. Не сильно вникал в суть, но может так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ДЕНЬНЕД(F$14;2)>5;F$14=праздники!$A$1:$A$12);"В";$D15*8);"")
формула массива (CSE)

Автор - Che79
Дата добавления - 25.05.2020 в 10:30
tvyur Дата: Понедельник, 25.05.2020, 11:33 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, спасибо за отклик. Я вставляю формулу, а ячейка как была пустая, так и осталась. А что такое "формула массива CSE?" Мне надо нажать на эти буквы?


tvyur
 
Ответить
СообщениеChe79, спасибо за отклик. Я вставляю формулу, а ячейка как была пустая, так и осталась. А что такое "формула массива CSE?" Мне надо нажать на эти буквы?

Автор - tvyur
Дата добавления - 25.05.2020 в 11:33
Che79 Дата: Понедельник, 25.05.2020, 11:42 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1648
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
tvyur, вставляете формулу и вместо обычного Enter жмете сочетание клавиш Ctrl+Shift+Enter. Если все корректно сделаете вокруг введенной формулы появятся фигурные скобки. См. файл
К сообщению приложен файл: 0979188_1.xlsx(64.0 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеtvyur, вставляете формулу и вместо обычного Enter жмете сочетание клавиш Ctrl+Shift+Enter. Если все корректно сделаете вокруг введенной формулы появятся фигурные скобки. См. файл

Автор - Che79
Дата добавления - 25.05.2020 в 11:42
jakim Дата: Понедельник, 25.05.2020, 11:43 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 999
Репутация: 272 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IF(COUNTIF(праздники!$A$1:$A$12;F$14+1)>=1;7;IF(COUNTIF(праздники!$A$1:$A$12;F$14)>=1;"В";IF(OR(WEEKDAY(F$14;2)=6;WEEKDAY(F$14;2)=7);"В";8)))
К сообщению приложен файл: 5069161.xlsx(60.1 Kb)
 
Ответить
Сообщение
Формула

Код
=IF(COUNTIF(праздники!$A$1:$A$12;F$14+1)>=1;7;IF(COUNTIF(праздники!$A$1:$A$12;F$14)>=1;"В";IF(OR(WEEKDAY(F$14;2)=6;WEEKDAY(F$14;2)=7);"В";8)))

Автор - jakim
Дата добавления - 25.05.2020 в 11:43
tvyur Дата: Понедельник, 25.05.2020, 16:03 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, jakim, Спасибо большое, формулы работают. Всё получилось. hands hands hands


tvyur
 
Ответить
СообщениеChe79, jakim, Спасибо большое, формулы работают. Всё получилось. hands hands hands

Автор - tvyur
Дата добавления - 25.05.2020 в 16:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для проставления код"В" в праздничные дни года (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!