Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить данные в столбцах и результаты вынести в отдельный - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить данные в столбцах и результаты вынести в отдельный (Формулы/Formulas)
Сравнить данные в столбцах и результаты вынести в отдельный
СергейМ Дата: Вторник, 26.05.2020, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, уважаемые гуру экселя!
Помогите решить задачку в экселе.

Если значение из столбца 1 равно значению из столбца 3, то значение в столбце 2 равно значению в столбце 4
Если полученное значение в столбце 2: меньше 50 , то +10; если от 51 до 99, то +15; если от 2500 до 4499, то -100; если больше 4500, то - 200
Значение в столбце 2 округлить до целого
К сообщению приложен файл: 7268695.xlsx(15.0 Kb)


Сообщение отредактировал СергейМ - Вторник, 26.05.2020, 12:53
 
Ответить
СообщениеДобрый день, уважаемые гуру экселя!
Помогите решить задачку в экселе.

Если значение из столбца 1 равно значению из столбца 3, то значение в столбце 2 равно значению в столбце 4
Если полученное значение в столбце 2: меньше 50 , то +10; если от 51 до 99, то +15; если от 2500 до 4499, то -100; если больше 4500, то - 200
Значение в столбце 2 округлить до целого

Автор - СергейМ
Дата добавления - 26.05.2020 в 12:52
Nic70y Дата: Вторник, 26.05.2020, 13:33 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6590
Репутация: 1450 ±
Замечаний: 0% ±

ru13;10;03
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ()
Если значение из столбца 1 равно значению из столбца 3
а если не равно?
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ()
меньше 50 , то +10; если от 51
выпали числа от [50 до 51[
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ()
до 99, то +15; если от 2500
тоже выпали


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ()
Если значение из столбца 1 равно значению из столбца 3
а если не равно?
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ()
меньше 50 , то +10; если от 51
выпали числа от [50 до 51[
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ()
до 99, то +15; если от 2500
тоже выпали

Автор - Nic70y
Дата добавления - 26.05.2020 в 13:33
СергейМ Дата: Вторник, 26.05.2020, 13:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ( писал(а)):
Если значение из столбца 1 равно значению из столбца 3
а если не равно?

это мало вероятно, но на всякий случай, пусть нечего не делает. оставит ячейку пустой

меньше 50 , то +10; если от 51
выпали числа от [50 до 51[

да верно. не заметил. >50 и <=50

Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ( писал(а)):
до 99, то +15; если от 2500
тоже выпали

в интервале <=99 до >2500 оставить значение без изменений
 
Ответить
Сообщение
Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ( писал(а)):
Если значение из столбца 1 равно значению из столбца 3
а если не равно?

это мало вероятно, но на всякий случай, пусть нечего не делает. оставит ячейку пустой

меньше 50 , то +10; если от 51
выпали числа от [50 до 51[

да верно. не заметил. >50 и <=50

Цитата СергейМ, 26.05.2020 в 12:52, в сообщении № 1 ( писал(а)):
до 99, то +15; если от 2500
тоже выпали

в интервале <=99 до >2500 оставить значение без изменений

Автор - СергейМ
Дата добавления - 26.05.2020 в 13:46
Nic70y Дата: Вторник, 26.05.2020, 13:58 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6590
Репутация: 1450 ±
Замечаний: 0% ±

ru13;10;03
как-то так
Код
=ЕСЛИ(B16=D16;ОКРУГЛ(ЕСЛИ(--E16<=50;10;ЕСЛИ(--E16<99;15;ЕСЛИ(--E16>=4500;-200;ЕСЛИ(--E16>=2500;-100))))+E16;);"")
Код

=ЕСЛИОШИБКА(ОКРУГЛ(ЕСЛИ(--ВПР(B16;D:E;2;)<=50;10;ЕСЛИ(--ВПР(B16;D:E;2;)<99;15;ЕСЛИ(--ВПР(B16;D:E;2;)>=4500;-200;ЕСЛИ(--ВПР(B16;D:E;2;)>=2500;-100))))+ВПР(B16;D:E;2;););"")
К сообщению приложен файл: 18.xlsx(16.1 Kb)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Вторник, 26.05.2020, 14:09
 
Ответить
Сообщениекак-то так
Код
=ЕСЛИ(B16=D16;ОКРУГЛ(ЕСЛИ(--E16<=50;10;ЕСЛИ(--E16<99;15;ЕСЛИ(--E16>=4500;-200;ЕСЛИ(--E16>=2500;-100))))+E16;);"")
Код

=ЕСЛИОШИБКА(ОКРУГЛ(ЕСЛИ(--ВПР(B16;D:E;2;)<=50;10;ЕСЛИ(--ВПР(B16;D:E;2;)<99;15;ЕСЛИ(--ВПР(B16;D:E;2;)>=4500;-200;ЕСЛИ(--ВПР(B16;D:E;2;)>=2500;-100))))+ВПР(B16;D:E;2;););"")

Автор - Nic70y
Дата добавления - 26.05.2020 в 13:58
СергейМ Дата: Вторник, 26.05.2020, 14:19 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо! Все работает!


Сообщение отредактировал СергейМ - Вторник, 26.05.2020, 14:22
 
Ответить
СообщениеСпасибо! Все работает!

Автор - СергейМ
Дата добавления - 26.05.2020 в 14:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить данные в столбцах и результаты вынести в отдельный (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!