Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск уникальных значений по запросу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск уникальных значений по запросу (Формулы/Formulas)
Поиск уникальных значений по запросу
AZaytsev Дата: Среда, 27.05.2020, 11:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Есть задача по ИНН организаций (в массиве более 4000 ИНН) найти те, которым соответствует 2 и более уникальных значения в другом столбце.
То есть ищем организации, которым соответствует 2 и более субъектов РФ (см. пример)

Как это осуществить? Спасибо
К сообщению приложен файл: 2509252.xlsx(9.9 Kb)


alexeyzaytsev.ru

Сообщение отредактировал AZaytsev - Среда, 27.05.2020, 11:51
 
Ответить
СообщениеДобрый день!

Есть задача по ИНН организаций (в массиве более 4000 ИНН) найти те, которым соответствует 2 и более уникальных значения в другом столбце.
То есть ищем организации, которым соответствует 2 и более субъектов РФ (см. пример)

Как это осуществить? Спасибо

Автор - AZaytsev
Дата добавления - 27.05.2020 в 11:48
Nic70y Дата: Среда, 27.05.2020, 12:01 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6601
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
Вы бы показали результат, который хотите получить.
Код
=ЕСЛИ(СЧЁТЕСЛИМН(B$2:B$4999;B2;D$2:D$4999;D2)=СЧЁТЕСЛИ(D$2:D$4999;D2);"";"есть другие")
К сообщению приложен файл: 2102786.xlsx(10.4 Kb)


Яндекс Деньги 41001841029809
 
Ответить
СообщениеВы бы показали результат, который хотите получить.
Код
=ЕСЛИ(СЧЁТЕСЛИМН(B$2:B$4999;B2;D$2:D$4999;D2)=СЧЁТЕСЛИ(D$2:D$4999;D2);"";"есть другие")

Автор - Nic70y
Дата добавления - 27.05.2020 в 12:01
AlexM Дата: Среда, 27.05.2020, 12:11 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Под конкретный пример можно так
Код
=ТЕКСТ(СЧЁТЕСЛИ(D$2:D$14;D2)-1;"2\ или более;;")
AZaytsev, покажите как вы хотели видеть результат.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПод конкретный пример можно так
Код
=ТЕКСТ(СЧЁТЕСЛИ(D$2:D$14;D2)-1;"2\ или более;;")
AZaytsev, покажите как вы хотели видеть результат.

Автор - AlexM
Дата добавления - 27.05.2020 в 12:11
AZaytsev Дата: Четверг, 28.05.2020, 11:57 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Коллеги, спасибо большое!
Именно так я и надеялся выделить нужные юрлица.


alexeyzaytsev.ru
 
Ответить
СообщениеКоллеги, спасибо большое!
Именно так я и надеялся выделить нужные юрлица.

Автор - AZaytsev
Дата добавления - 28.05.2020 в 11:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск уникальных значений по запросу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!