Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выбор варианта в зависимости от попадания числа в диапазон - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор варианта в зависимости от попадания числа в диапазон (Формулы/Formulas)
выбор варианта в зависимости от попадания числа в диапазон
MAXIMUS_GREEK Дата: Среда, 27.05.2020, 19:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята нужна ваша экспертная помощь, мне нужно использовать функцию Если вот каким образом (или может есть другой способ). Есть три диапазона от 0 до 50, от 50 до 100 и от 100 до 200, так вот мне надо как то написать формулу которая бы выполняла действие при условии что Если значение в ячейке от 0 до 50 то надо умножит значение ячейки на цифру из одного места, если от 50 до 100 то из второго места и если от 100 до 200 то из третьего места (места эти могут быть как на этой же странице так и на других листах), не понимаю как это можно сделать в одной формуле, не хватает знаний помогите пожалуйста. %)
 
Ответить
СообщениеРебята нужна ваша экспертная помощь, мне нужно использовать функцию Если вот каким образом (или может есть другой способ). Есть три диапазона от 0 до 50, от 50 до 100 и от 100 до 200, так вот мне надо как то написать формулу которая бы выполняла действие при условии что Если значение в ячейке от 0 до 50 то надо умножит значение ячейки на цифру из одного места, если от 50 до 100 то из второго места и если от 100 до 200 то из третьего места (места эти могут быть как на этой же странице так и на других листах), не понимаю как это можно сделать в одной формуле, не хватает знаний помогите пожалуйста. %)

Автор - MAXIMUS_GREEK
Дата добавления - 27.05.2020 в 19:09
Pelena Дата: Среда, 27.05.2020, 19:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Название темы должно отражать суть задачи, а не способ решения. Придумайте более конкретное. Тем более, что ЕСЛИ() здесь не лучший вариант.
И файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНазвание темы должно отражать суть задачи, а не способ решения. Придумайте более конкретное. Тем более, что ЕСЛИ() здесь не лучший вариант.
И файл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 27.05.2020 в 19:14
gling Дата: Среда, 27.05.2020, 20:58 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
И Вам здравствовать!
Цитата MAXIMUS_GREEK, 27.05.2020 в 19:09, в сообщении № 1 ()
Функция Если и выбор сложного условия!!!
Ежели хотите функцией если, то так и пишите как у Вам в сообщении
Код
=ЕСЛИ(И(A1>=0;A1<50);A1*(одно место);ЕСЛИ(И(A1>=50;A1<100);A1*(второе место);ЕСЛИ(И(A1>=100;A1<200);A1*(трете место);0)))
или
Код
=A1*ЕСЛИ(И(A1>=0;A1<50);(одно место);ЕСЛИ(И(A1>=50;A1<100);(второе место);ЕСЛИ(И(A1>=100;A1<200);(трете место);0)))
Цитата MAXIMUS_GREEK, 27.05.2020 в 19:09, в сообщении № 1 ()
может есть другой способ
Есть.


ЯД-41001506838083
 
Ответить
СообщениеИ Вам здравствовать!
Цитата MAXIMUS_GREEK, 27.05.2020 в 19:09, в сообщении № 1 ()
Функция Если и выбор сложного условия!!!
Ежели хотите функцией если, то так и пишите как у Вам в сообщении
Код
=ЕСЛИ(И(A1>=0;A1<50);A1*(одно место);ЕСЛИ(И(A1>=50;A1<100);A1*(второе место);ЕСЛИ(И(A1>=100;A1<200);A1*(трете место);0)))
или
Код
=A1*ЕСЛИ(И(A1>=0;A1<50);(одно место);ЕСЛИ(И(A1>=50;A1<100);(второе место);ЕСЛИ(И(A1>=100;A1<200);(трете место);0)))
Цитата MAXIMUS_GREEK, 27.05.2020 в 19:09, в сообщении № 1 ()
может есть другой способ
Есть.

Автор - gling
Дата добавления - 27.05.2020 в 20:58
MAXIMUS_GREEK Дата: Среда, 27.05.2020, 21:21 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Излишнее цитирование удалено администрацией
Большое спасибо но почему то не получается формулу применить постоянно ошибка в синтаксисе какая-то выходит.


Сообщение отредактировал Pelena - Среда, 27.05.2020, 21:24
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией
Большое спасибо но почему то не получается формулу применить постоянно ошибка в синтаксисе какая-то выходит.

Автор - MAXIMUS_GREEK
Дата добавления - 27.05.2020 в 21:21
MAXIMUS_GREEK Дата: Среда, 27.05.2020, 21:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Название темы должно отражать суть задачи, а не способ решения. Придумайте более конкретное. Тем более, что ЕСЛИ() здесь не лучший вариант.
И файл с примером помог бы в понимании проблемы

извините как смог сформулировал, прилагаю пример чтобы было понятно что я имел ввиду
К сообщению приложен файл: 9219637.xlsx(10.0 Kb)
 
Ответить
Сообщение
Название темы должно отражать суть задачи, а не способ решения. Придумайте более конкретное. Тем более, что ЕСЛИ() здесь не лучший вариант.
И файл с примером помог бы в понимании проблемы

извините как смог сформулировал, прилагаю пример чтобы было понятно что я имел ввиду

Автор - MAXIMUS_GREEK
Дата добавления - 27.05.2020 в 21:22
Che79 Дата: Среда, 27.05.2020, 23:44 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
MAXIMUS_GREEK, здравствуйте. Как вариант - формула массива , вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(C5*ВЫБОР(ПОИСКПОЗ(1=1;(C5<={50;100;200}););A2;B2;C2);)
К сообщению приложен файл: 9219637_1.xlsx(10.1 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 27.05.2020, 23:56
 
Ответить
СообщениеMAXIMUS_GREEK, здравствуйте. Как вариант - формула массива , вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(C5*ВЫБОР(ПОИСКПОЗ(1=1;(C5<={50;100;200}););A2;B2;C2);)

Автор - Che79
Дата добавления - 27.05.2020 в 23:44
gling Дата: Четверг, 28.05.2020, 00:39 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
формула массива
А зачем, она и без массивного ввода прекрасно работает.
Цитата
но почему то не получается формулу применить

Не понятно от 0 до 50 включительно или исключительно, регулируйте самостоятельно, это регулируется наличием = в сравнении.
Код
=C5*ЕСЛИ(И(C5>=0;C5<50);A2;ЕСЛИ(И(C5>=50;C5<100);B2;ЕСЛИ(И(C5>=100;C5<200);C2;0)))
и ещё на базе варианта Che79,
Код
=ЕСЛИОШИБКА(C5*ВЫБОР(ПОИСКПОЗ(C5;{200;100;50};-1);C2;B2;A2);)


ЯД-41001506838083

Сообщение отредактировал gling - Четверг, 28.05.2020, 02:05
 
Ответить
Сообщение
формула массива
А зачем, она и без массивного ввода прекрасно работает.
Цитата
но почему то не получается формулу применить

Не понятно от 0 до 50 включительно или исключительно, регулируйте самостоятельно, это регулируется наличием = в сравнении.
Код
=C5*ЕСЛИ(И(C5>=0;C5<50);A2;ЕСЛИ(И(C5>=50;C5<100);B2;ЕСЛИ(И(C5>=100;C5<200);C2;0)))
и ещё на базе варианта Che79,
Код
=ЕСЛИОШИБКА(C5*ВЫБОР(ПОИСКПОЗ(C5;{200;100;50};-1);C2;B2;A2);)

Автор - gling
Дата добавления - 28.05.2020 в 00:39
Che79 Дата: Четверг, 28.05.2020, 00:51 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
[offtop]
она и без массивного ввода прекрасно работает
точно, это я перемудрил


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop]
она и без массивного ввода прекрасно работает
точно, это я перемудрил

Автор - Che79
Дата добавления - 28.05.2020 в 00:51
MAXIMUS_GREEK Дата: Четверг, 28.05.2020, 09:12 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
итата
но почему то не получается формулу применить

я вот что имел ввиду когда писал что формулу не могу применить, при переносе в excel выходит вот такое сообщение %) прилагаю скрин
К сообщению приложен файл: 7211745.jpg(27.8 Kb)
 
Ответить
Сообщение
итата
но почему то не получается формулу применить

я вот что имел ввиду когда писал что формулу не могу применить, при переносе в excel выходит вот такое сообщение %) прилагаю скрин

Автор - MAXIMUS_GREEK
Дата добавления - 28.05.2020 в 09:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор варианта в зависимости от попадания числа в диапазон (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!