Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/преобразование float в dec - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » преобразование float в dec (Формулы/Formulas)
преобразование float в dec
сергей24567 Дата: Четверг, 28.05.2020, 09:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте, возможно ли в excel написать формулу или иную процедуру для преобразования числа float в десятичный вид?
Если да, то как?
 
Ответить
СообщениеЗдравствуйте, возможно ли в excel написать формулу или иную процедуру для преобразования числа float в десятичный вид?
Если да, то как?

Автор - сергей24567
Дата добавления - 28.05.2020 в 09:01
Pelena Дата: Четверг, 28.05.2020, 15:17 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17439
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Поменять формат не вариант?
Если имеете в виду неточность вычислений чисел с плавающей запятой, то обычно использую функцию ОКРУГЛ().
Приведите пример, что есть и что надо.


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПоменять формат не вариант?
Если имеете в виду неточность вычислений чисел с плавающей запятой, то обычно использую функцию ОКРУГЛ().
Приведите пример, что есть и что надо.

Автор - Pelena
Дата добавления - 28.05.2020 в 15:17
сергей24567 Дата: Четверг, 28.05.2020, 15:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
есть некие числа типа 0x3FCCCCCD 0x3F800000 0x40B9999A 0x40A00000

надо в десятичный вид перевести.
много таких файлов, ручками муторно.
К сообщению приложен файл: 7592913.xlsx(8.9 Kb)
 
Ответить
Сообщениеесть некие числа типа 0x3FCCCCCD 0x3F800000 0x40B9999A 0x40A00000

надо в десятичный вид перевести.
много таких файлов, ручками муторно.

Автор - сергей24567
Дата добавления - 28.05.2020 в 15:53
krosav4ig Дата: Пятница, 29.05.2020, 01:36 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2324
Репутация: 977 ±
Замечаний: 0% ±

Excel 2007,2010,2013
функция Hex2Sng отсюда

или формула (выдает неверный результат для малых чисел)

Код
=(-1)^БИТ.СДВИГП(ШЕСТН.В.ДЕС(ПСТР(A3;3;8));31)*(БИТ.ИЛИ(БИТ.И(ШЕСТН.В.ДЕС(ПСТР(A3;3;8));8388607);8388608)*2^(БИТ.И(БИТ.СДВИГП(ШЕСТН.В.ДЕС(ПСТР(A3;3;8));23);255)-127-23))
К сообщению приложен файл: 7592913.xlsm(25.3 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениефункция Hex2Sng отсюда

или формула (выдает неверный результат для малых чисел)

Код
=(-1)^БИТ.СДВИГП(ШЕСТН.В.ДЕС(ПСТР(A3;3;8));31)*(БИТ.ИЛИ(БИТ.И(ШЕСТН.В.ДЕС(ПСТР(A3;3;8));8388607);8388608)*2^(БИТ.И(БИТ.СДВИГП(ШЕСТН.В.ДЕС(ПСТР(A3;3;8));23);255)-127-23))

Автор - krosav4ig
Дата добавления - 29.05.2020 в 01:36
сергей24567 Дата: Пятница, 29.05.2020, 08:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо.
на будущее пригодится.
Свою проблему обошёл по другому, числа у меня встречаются на 80% одинаковые, преобразовал ручками, вывел в таблицу и сделал через =ВПР(), а остальные 20% руками.
 
Ответить
СообщениеСпасибо.
на будущее пригодится.
Свою проблему обошёл по другому, числа у меня встречаются на 80% одинаковые, преобразовал ручками, вывел в таблицу и сделал через =ВПР(), а остальные 20% руками.

Автор - сергей24567
Дата добавления - 29.05.2020 в 08:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » преобразование float в dec (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!