Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование сумм отгрузки при сравнение по датам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование сумм отгрузки при сравнение по датам (Формулы/Formulas)
Суммирование сумм отгрузки при сравнение по датам
paradoxuk Дата: Четверг, 28.05.2020, 14:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день прошу помочь с формулой для суммирования, никак не получается придумать, либо не дает итог
Хочу сделать сводную таблицу, нужно сравнить даты по месяцам отгрузка в сводке и у клиентов и вывести сумму отгрузок в месяц
К сообщению приложен файл: 9390810.xlsx(13.1 Kb)
 
Ответить
СообщениеДобрый день прошу помочь с формулой для суммирования, никак не получается придумать, либо не дает итог
Хочу сделать сводную таблицу, нужно сравнить даты по месяцам отгрузка в сводке и у клиентов и вывести сумму отгрузок в месяц

Автор - paradoxuk
Дата добавления - 28.05.2020 в 14:24
Pelena Дата: Четверг, 28.05.2020, 14:41 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16771
Репутация: 3620 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ((МЕСЯЦ($B2)=МЕСЯЦ(ДВССЫЛ("'"&C$1&"'!$B$1:$B$1000")))*ДВССЫЛ("'"&C$1&"'!$E$1:$E$1000"))
К сообщению приложен файл: 7493712.xlsx(15.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ((МЕСЯЦ($B2)=МЕСЯЦ(ДВССЫЛ("'"&C$1&"'!$B$1:$B$1000")))*ДВССЫЛ("'"&C$1&"'!$E$1:$E$1000"))

Автор - Pelena
Дата добавления - 28.05.2020 в 14:41
китин Дата: Четверг, 28.05.2020, 14:50 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6316
Репутация: 969 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
del
[p.s.]не успел :(
а выложу раз сделал
Код
=СУММПРОИЗВ(ДВССЫЛ("'"&C$1&"'!"&"$E$1:$E$20")*(МЕСЯЦ(ДВССЫЛ("'"&C$1&"'!"&"$B$1:$B$20"))=МЕСЯЦ(Лист3!$B2)))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 28.05.2020, 14:52
 
Ответить
Сообщениеdel
[p.s.]не успел :(
а выложу раз сделал
Код
=СУММПРОИЗВ(ДВССЫЛ("'"&C$1&"'!"&"$E$1:$E$20")*(МЕСЯЦ(ДВССЫЛ("'"&C$1&"'!"&"$B$1:$B$20"))=МЕСЯЦ(Лист3!$B2)))

Автор - китин
Дата добавления - 28.05.2020 в 14:50
paradoxuk Дата: Четверг, 28.05.2020, 17:40 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо Pelena, китин, а чтобы еще и год фильтровал, это надо еще один массив добавлять
а то дублирует по месяцу в разных годах
 
Ответить
СообщениеСпасибо Pelena, китин, а чтобы еще и год фильтровал, это надо еще один массив добавлять
а то дублирует по месяцу в разных годах

Автор - paradoxuk
Дата добавления - 28.05.2020 в 17:40
Pelena Дата: Четверг, 28.05.2020, 17:52 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16771
Репутация: 3620 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ((ТЕКСТ($B2;"ММГГ")=ТЕКСТ(ДВССЫЛ("'"&C$1&"'!$B$1:$B$1000");"ММГГ"))*ДВССЫЛ("'"&C$1&"'!$E$1:$E$1000"))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((ТЕКСТ($B2;"ММГГ")=ТЕКСТ(ДВССЫЛ("'"&C$1&"'!$B$1:$B$1000");"ММГГ"))*ДВССЫЛ("'"&C$1&"'!$E$1:$E$1000"))

Автор - Pelena
Дата добавления - 28.05.2020 в 17:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование сумм отгрузки при сравнение по датам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!