Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сцепить значения их нескольких таблиц в одной формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сцепить значения их нескольких таблиц в одной формуле (Формулы/Formulas)
Как сцепить значения их нескольких таблиц в одной формуле
Nikonka89 Дата: Пятница, 29.05.2020, 14:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Добрый день.
помогите, пожалуйста, с формулой. Пример во вложении. Те столбцы, которые выделила цветом - протягивала формулы.
столбец зеленым цветом - итог, который нужно получить.
Как можно упростить эту систему: я получается сначала делаю на двух листах сцепку, а потом ВПР. Как это сделать одной формулой ?
К сообщению приложен файл: 3055712.xlsx(12.5 Kb)
 
Ответить
СообщениеДобрый день.
помогите, пожалуйста, с формулой. Пример во вложении. Те столбцы, которые выделила цветом - протягивала формулы.
столбец зеленым цветом - итог, который нужно получить.
Как можно упростить эту систему: я получается сначала делаю на двух листах сцепку, а потом ВПР. Как это сделать одной формулой ?

Автор - Nikonka89
Дата добавления - 29.05.2020 в 14:22
Hugo Дата: Пятница, 29.05.2020, 14:27 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3137
Репутация: 670 ±
Замечаний: 0% ±

2010, теперь уже с PQ
Код
=ВПР(C2&E2&F2;Эталон!A:F;4;0)
:)
А если не сцеплять в Эталоне - то думаю проще свою UDF написать/использовать.


excel@nxt.ru
webmoney: R418926282008 Z422237915069


Сообщение отредактировал Hugo - Пятница, 29.05.2020, 14:38
 
Ответить
Сообщение
Код
=ВПР(C2&E2&F2;Эталон!A:F;4;0)
:)
А если не сцеплять в Эталоне - то думаю проще свою UDF написать/использовать.

Автор - Hugo
Дата добавления - 29.05.2020 в 14:27
Nikonka89 Дата: Понедельник, 01.06.2020, 09:13 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
мне и надо формулу, чтобы не сцеплять ни в эталоне, ни на другом листе. Все эти действия объединить как-то в одной формуле
 
Ответить
Сообщениемне и надо формулу, чтобы не сцеплять ни в эталоне, ни на другом листе. Все эти действия объединить как-то в одной формуле

Автор - Nikonka89
Дата добавления - 01.06.2020 в 09:13
AlexM Дата: Понедельник, 01.06.2020, 09:34 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=ВПР(C2&E2&F2;ЕСЛИ({1;0};Эталон!C$2:C$99&Эталон!B$2:B$99&Эталон!F$2:F$99;Эталон!D$2:D$99);2;0)
К сообщению приложен файл: 3055712_01.xlsx(12.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 01.06.2020, 09:35
 
Ответить
СообщениеФормула массива
Код
=ВПР(C2&E2&F2;ЕСЛИ({1;0};Эталон!C$2:C$99&Эталон!B$2:B$99&Эталон!F$2:F$99;Эталон!D$2:D$99);2;0)

Автор - AlexM
Дата добавления - 01.06.2020 в 09:34
Nikonka89 Дата: Вторник, 02.06.2020, 09:13 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Спасибо! получилось!)
 
Ответить
СообщениеСпасибо! получилось!)

Автор - Nikonka89
Дата добавления - 02.06.2020 в 09:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сцепить значения их нескольких таблиц в одной формуле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!