Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возвращение значения из левой ячейки от найденного в строке. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возвращение значения из левой ячейки от найденного в строке. (Формулы/Formulas)
Возвращение значения из левой ячейки от найденного в строке.
petroTatti Дата: Понедельник, 01.06.2020, 02:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте!
Помогите пожалуйста, никак не могу решить эту задачу. Есть таблица в которой нужно найти текст в строке, и при нахождении оного нужно взять значение (число) из ячейки слева от найденного текста. Самое сложное, что этот текст (и числовое значение слева от него) может находится в разных столбцах.
Более понятно будет из файла. Там желтым выделено то, что должно получиться(я туда вписал результат без формул соответственно).
Заранее признателен за помощь!
К сообщению приложен файл: ___.xls(34.5 Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите пожалуйста, никак не могу решить эту задачу. Есть таблица в которой нужно найти текст в строке, и при нахождении оного нужно взять значение (число) из ячейки слева от найденного текста. Самое сложное, что этот текст (и числовое значение слева от него) может находится в разных столбцах.
Более понятно будет из файла. Там желтым выделено то, что должно получиться(я туда вписал результат без формул соответственно).
Заранее признателен за помощь!

Автор - petroTatti
Дата добавления - 01.06.2020 в 02:20
ShAM Дата: Понедельник, 01.06.2020, 04:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 223 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(ЕСЛИ($B2:$I2=Q$1;СУММ($B2:$I2)))

Формула массива, вводим одновременным нажатием Ctrl/Shift/Enter.
Или простая:
Код
=СУММПРОИЗВ(($B2:$I2=N$1)*СУММ($B2:$I2))

Нули убираем через Параметры.
К сообщению приложен файл: PetroTatti.xls(36.5 Kb)
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИ($B2:$I2=Q$1;СУММ($B2:$I2)))

Формула массива, вводим одновременным нажатием Ctrl/Shift/Enter.
Или простая:
Код
=СУММПРОИЗВ(($B2:$I2=N$1)*СУММ($B2:$I2))

Нули убираем через Параметры.

Автор - ShAM
Дата добавления - 01.06.2020 в 04:52
AlexM Дата: Понедельник, 01.06.2020, 09:21 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=СУММ(ЕСЛИ($C2:$I2=N$1;$B2:$H2))
К сообщению приложен файл: petroTatti_01.xls(36.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива
Код
=СУММ(ЕСЛИ($C2:$I2=N$1;$B2:$H2))

Автор - AlexM
Дата добавления - 01.06.2020 в 09:21
petroTatti Дата: Понедельник, 01.06.2020, 11:08 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо огромное за ответы! hands
Только я не совсем верно поставил вопрос. Точнее сказать, забыл указать, что там есть еще и прочие переменные, поэтому и нужно чтоб вытаскивалось значение из предыдущей от совпадения ячейки. Моя таблица-пример составлена была упрощенно.
Исправляюсь и надеюсь на понимание. Прикрепляю таблицу с более верным наполнением.
Еще раз, приношу извинения, за не точность формулирования задачи. Как говорится: "Хочешь услышать правильный ответ - поставь правильно вопрос."
Во вложении более верный пример таблицы
К сообщению приложен файл: 0544061.xls(26.0 Kb)
 
Ответить
СообщениеСпасибо огромное за ответы! hands
Только я не совсем верно поставил вопрос. Точнее сказать, забыл указать, что там есть еще и прочие переменные, поэтому и нужно чтоб вытаскивалось значение из предыдущей от совпадения ячейки. Моя таблица-пример составлена была упрощенно.
Исправляюсь и надеюсь на понимание. Прикрепляю таблицу с более верным наполнением.
Еще раз, приношу извинения, за не точность формулирования задачи. Как говорится: "Хочешь услышать правильный ответ - поставь правильно вопрос."
Во вложении более верный пример таблицы

Автор - petroTatti
Дата добавления - 01.06.2020 в 11:08
AlexM Дата: Понедельник, 01.06.2020, 11:16 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Странно почему мой вариант не подошел?
К сообщению приложен файл: 0544061_01.xls(27.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеСтранно почему мой вариант не подошел?

Автор - AlexM
Дата добавления - 01.06.2020 в 11:16
petroTatti Дата: Понедельник, 01.06.2020, 17:02 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Странно почему мой вариант не подошел?

Спасибо ОГРОМЕННОЕ!!!
Все сработало!
Действительно непонятно, почему не сработало ранее, видимо что-то в своей таблице не так написал в данных (исходная значительно массивнее)
С меня + репутации и большое уважение за отзывчивость!
Вопрос решен!
Тему можно закрывать!
Всем крепкого здоровья и успехов во всем!
 
Ответить
Сообщение
Странно почему мой вариант не подошел?

Спасибо ОГРОМЕННОЕ!!!
Все сработало!
Действительно непонятно, почему не сработало ранее, видимо что-то в своей таблице не так написал в данных (исходная значительно массивнее)
С меня + репутации и большое уважение за отзывчивость!
Вопрос решен!
Тему можно закрывать!
Всем крепкого здоровья и успехов во всем!

Автор - petroTatti
Дата добавления - 01.06.2020 в 17:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возвращение значения из левой ячейки от найденного в строке. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!