Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перевод отрицательных чисел в неотрицательные! - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перевод отрицательных чисел в неотрицательные! (Формулы/Formulas)
Перевод отрицательных чисел в неотрицательные!
VKL Дата: Понедельник, 08.06.2020, 19:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Попытаюсь объяснить, дело в том что формула в принципе проста, но требуется чтоб всегда вычитание было от большего числа чтоб в ячейке с решением не было минуса, в дальнейших расчетах происходит неправильное решение.
пример: 5-2=3 или 2-5=-3 в ячейках 5 и 2 могут меняться на разные числа.
К сообщению приложен файл: 0717178.xlsx(8.9 Kb)


Сообщение отредактировал VKL - Вторник, 09.06.2020, 08:24
 
Ответить
СообщениеДобрый день!
Попытаюсь объяснить, дело в том что формула в принципе проста, но требуется чтоб всегда вычитание было от большего числа чтоб в ячейке с решением не было минуса, в дальнейших расчетах происходит неправильное решение.
пример: 5-2=3 или 2-5=-3 в ячейках 5 и 2 могут меняться на разные числа.

Автор - VKL
Дата добавления - 08.06.2020 в 19:04
Che79 Дата: Понедельник, 08.06.2020, 20:05 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1497
Репутация: 281 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Добрый и Вам. Тема сообщения должна отражать суть задачи, а не способ или определения для ее решения. Переименуйте, например, в "Перевод отрицательных чисел в неотрицательные". По Вашему вопросу - так нужно?
Код
=ABS(A2-B2)
Код
=ЕСЛИ(A2>=B2;A2-B2;B2-A2)
И еще нужна формула
А это, согласно правилам форума, в новую тему. Хотя, дождитесь модераторов, может и в этой теме помогут.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 08.06.2020, 20:10
 
Ответить
СообщениеДобрый и Вам. Тема сообщения должна отражать суть задачи, а не способ или определения для ее решения. Переименуйте, например, в "Перевод отрицательных чисел в неотрицательные". По Вашему вопросу - так нужно?
Код
=ABS(A2-B2)
Код
=ЕСЛИ(A2>=B2;A2-B2;B2-A2)
И еще нужна формула
А это, согласно правилам форума, в новую тему. Хотя, дождитесь модераторов, может и в этой теме помогут.

Автор - Che79
Дата добавления - 08.06.2020 в 20:05
VKL Дата: Понедельник, 08.06.2020, 20:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый и Вам. Тема сообщения должна отражать суть задачи, а не способ или определения для ее решения. Переименуйте, например, в "Перевод отрицательных чисел в неотрицательные". По Вашему вопросу - так нужно?

Да спасибо! А чем эти формулы отличаются, вроде результат дает одинаковый?
В принципе вопрос решен, если не ответят по второму вопросу, создам тему.
 
Ответить
Сообщение
Добрый и Вам. Тема сообщения должна отражать суть задачи, а не способ или определения для ее решения. Переименуйте, например, в "Перевод отрицательных чисел в неотрицательные". По Вашему вопросу - так нужно?

Да спасибо! А чем эти формулы отличаются, вроде результат дает одинаковый?
В принципе вопрос решен, если не ответят по второму вопросу, создам тему.

Автор - VKL
Дата добавления - 08.06.2020 в 20:58
Che79 Дата: Понедельник, 08.06.2020, 21:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1497
Репутация: 281 ±
Замечаний: 0% ±

2013 Win, 365 Mac
чем эти формулы отличаются
Первая возвращает модуль разности, вторая в зависимости от условия разность двух чисел.


Делай нормально и будет нормально!
 
Ответить
Сообщение
чем эти формулы отличаются
Первая возвращает модуль разности, вторая в зависимости от условия разность двух чисел.

Автор - Che79
Дата добавления - 08.06.2020 в 21:08
прохожий2019 Дата: Понедельник, 08.06.2020, 21:30 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 134
Репутация: 29 ±
Замечаний: 0% ±

365 Semi-Annual Channel
до кучи
Код
=МАКС(A2;B2)-МИН(A2;B2)
 
Ответить
Сообщениедо кучи
Код
=МАКС(A2;B2)-МИН(A2;B2)

Автор - прохожий2019
Дата добавления - 08.06.2020 в 21:30
VKL Дата: Вторник, 09.06.2020, 08:25 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем спасибо, тему можно закрывать.
 
Ответить
СообщениеВсем спасибо, тему можно закрывать.

Автор - VKL
Дата добавления - 09.06.2020 в 08:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перевод отрицательных чисел в неотрицательные! (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!