Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма последних 5 ячеек(строк) в постоянно дополняемой табл. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма последних 5 ячеек(строк) в постоянно дополняемой табл. (Формулы/Formulas)
Сумма последних 5 ячеек(строк) в постоянно дополняемой табл.
андрей804 Дата: Понедельник, 08.06.2020, 23:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! Ищу решение. Есть таблица(массив 1), сейчас в ней 8 строк, строки постоянно добавляются, и через неделю строк может быть и 15 и 25. Необходимо чтобы считалась сумма значений последних 5 строк(красная строка). При использовании автосуммы и добавлении строк(строки прирастают снизу), автосумма автоматически будет растягивать диапазон на каждую добавленную строку. А мне надо сумму значений 5 последних строк. Как решить?
К сообщению приложен файл: 1964985.xlsx(13.2 Kb)


ищу, уже почти нашел
 
Ответить
СообщениеВсем привет! Ищу решение. Есть таблица(массив 1), сейчас в ней 8 строк, строки постоянно добавляются, и через неделю строк может быть и 15 и 25. Необходимо чтобы считалась сумма значений последних 5 строк(красная строка). При использовании автосуммы и добавлении строк(строки прирастают снизу), автосумма автоматически будет растягивать диапазон на каждую добавленную строку. А мне надо сумму значений 5 последних строк. Как решить?

Автор - андрей804
Дата добавления - 08.06.2020 в 23:19
андрей804 Дата: Понедельник, 08.06.2020, 23:45 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Еще вопрос, возможно ли решение, что сумма считается в фиксированном диапазоне(диапазон не растягивается при добавлении строк), но не последних 5 строк, а строк с -3(3 назад) по -8(8 строк назад)
К сообщению приложен файл: 2290921.xlsx(13.3 Kb)


ищу, уже почти нашел
 
Ответить
СообщениеЕще вопрос, возможно ли решение, что сумма считается в фиксированном диапазоне(диапазон не растягивается при добавлении строк), но не последних 5 строк, а строк с -3(3 назад) по -8(8 строк назад)

Автор - андрей804
Дата добавления - 08.06.2020 в 23:45
прохожий2019 Дата: Понедельник, 08.06.2020, 23:49 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 134
Репутация: 29 ±
Замечаний: 0% ±

365 Semi-Annual Channel
Код
=СУММ(ИНДЕКС(B$3:B10;СЧЁТ(B$3:B10)-4):ИНДЕКС(B$3:B10;СЧЁТ(B$3:B10)))
К сообщению приложен файл: 6941178.xlsx(14.4 Kb)
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(B$3:B10;СЧЁТ(B$3:B10)-4):ИНДЕКС(B$3:B10;СЧЁТ(B$3:B10)))

Автор - прохожий2019
Дата добавления - 08.06.2020 в 23:49
AlexM Дата: Вторник, 09.06.2020, 10:22 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4225
Репутация: 1042 ±
Замечаний: 0% ±

Excel 2003
По первому вопросу
Код
=СУММ(ИНДЕКС(F:F;СТРОКА()-5):ИНДЕКС(F:F;СТРОКА()-1))
К сообщению приложен файл: 1964985_01.xlsx(13.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПо первому вопросу
Код
=СУММ(ИНДЕКС(F:F;СТРОКА()-5):ИНДЕКС(F:F;СТРОКА()-1))

Автор - AlexM
Дата добавления - 09.06.2020 в 10:22
андрей804 Дата: Вторник, 09.06.2020, 22:07 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ребята, спасибо - все работает!!! hands hands


ищу, уже почти нашел
 
Ответить
СообщениеРебята, спасибо - все работает!!! hands hands

Автор - андрей804
Дата добавления - 09.06.2020 в 22:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма последних 5 ячеек(строк) в постоянно дополняемой табл. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!