Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет клиентов у каждого сотрудника - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет клиентов у каждого сотрудника (Формулы/Formulas)
Подсчет клиентов у каждого сотрудника
Aanton Дата: Пятница, 12.06.2020, 22:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый вечер!
Помогите пожалуйста написать формулу подсчета клиентов у каждого сотрудника. Пересмотрел много тем и сайтов, но ничего подходящего не нашел. killed
Заранее благодарю не равнодушных!!!
К сообщению приложен файл: 11.xlsx(9.7 Kb)


Сообщение отредактировал Aanton - Пятница, 12.06.2020, 22:49
 
Ответить
СообщениеДобрый вечер!
Помогите пожалуйста написать формулу подсчета клиентов у каждого сотрудника. Пересмотрел много тем и сайтов, но ничего подходящего не нашел. killed
Заранее благодарю не равнодушных!!!

Автор - Aanton
Дата добавления - 12.06.2020 в 22:49
Che79 Дата: Пятница, 12.06.2020, 23:18 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1611
Репутация: 299 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Aanton, здравствуйте. Если изменить формат Вашей таблицы на плоскую (см Лист 2), то это классическая задача для сводной таблицы. Последнюю строчку для Сидорова удалил сознательно, если каждого клиента из нее оформить отдельной строкой и обновить сводную, то получите искомое значение клиентов.
К сообщению приложен файл: 11-1.xlsx(14.5 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеAanton, здравствуйте. Если изменить формат Вашей таблицы на плоскую (см Лист 2), то это классическая задача для сводной таблицы. Последнюю строчку для Сидорова удалил сознательно, если каждого клиента из нее оформить отдельной строкой и обновить сводную, то получите искомое значение клиентов.

Автор - Che79
Дата добавления - 12.06.2020 в 23:18
Aanton Дата: Пятница, 12.06.2020, 23:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Che79, в одной ячейке столбца клиентов может быть несколько человек указано.
Поскольку дополнительных данных в каждой строке может быть много, то создавать отдельную ячейку каждому клиенту нельзя.
Есть еще мысли как победить? %)
 
Ответить
СообщениеChe79, в одной ячейке столбца клиентов может быть несколько человек указано.
Поскольку дополнительных данных в каждой строке может быть много, то создавать отдельную ячейку каждому клиенту нельзя.
Есть еще мысли как победить? %)

Автор - Aanton
Дата добавления - 12.06.2020 в 23:29
Pelena Дата: Пятница, 12.06.2020, 23:40 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16511
Репутация: 3567 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если клиенты всегда разделяются запятыми, можно так
Код
=СУММПРОИЗВ((B2:B11=F2)*(ДЛСТР(A2:A11)-ДЛСТР(ПОДСТАВИТЬ(A2:A11;",";))+1))
К сообщению приложен файл: 11-1-.xlsx(10.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли клиенты всегда разделяются запятыми, можно так
Код
=СУММПРОИЗВ((B2:B11=F2)*(ДЛСТР(A2:A11)-ДЛСТР(ПОДСТАВИТЬ(A2:A11;",";))+1))

Автор - Pelena
Дата добавления - 12.06.2020 в 23:40
Aanton Дата: Пятница, 12.06.2020, 23:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Огромное Спасибо!
То, что нужно. hands hands hands
 
Ответить
СообщениеPelena, Огромное Спасибо!
То, что нужно. hands hands hands

Автор - Aanton
Дата добавления - 12.06.2020 в 23:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет клиентов у каждого сотрудника (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!