Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по интервалам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по интервалам (Формулы/Formulas)
Поиск значения по интервалам
beal Дата: Среда, 17.06.2020, 15:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
пытаюсь, пока безуспешно, решить следующую задачу:
Дано 3 поля с диапазонами номеров телефонов: в первом поле указано начала диапазона номеров, во втором конец диапазона, в третьем регион, к которому принадлежит диапазон

Необходимо сопоставить регион звонка реальным абонентским номерам, если номер не попадает ни в один из диапазонов, то вывести ошибку определения региона.
Приложил пример файла.

все решения, которые находил работают некорректно, к сожалению...
К сообщению приложен файл: 4875046.xlsx(8.9 Kb)


Сообщение отредактировал beal - Среда, 17.06.2020, 15:03
 
Ответить
СообщениеДобрый день!
пытаюсь, пока безуспешно, решить следующую задачу:
Дано 3 поля с диапазонами номеров телефонов: в первом поле указано начала диапазона номеров, во втором конец диапазона, в третьем регион, к которому принадлежит диапазон

Необходимо сопоставить регион звонка реальным абонентским номерам, если номер не попадает ни в один из диапазонов, то вывести ошибку определения региона.
Приложил пример файла.

все решения, которые находил работают некорректно, к сожалению...

Автор - beal
Дата добавления - 17.06.2020 в 15:02
Nic70y Дата: Среда, 17.06.2020, 15:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6605
Репутация: 1453 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(C:C;СУММПРОИЗВ((A$4:A$11<=G4)*($B$4:$B$11>=G4)*СТРОКА(B$4:$B$11)))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(C:C;СУММПРОИЗВ((A$4:A$11<=G4)*($B$4:$B$11>=G4)*СТРОКА(B$4:$B$11)))

Автор - Nic70y
Дата добавления - 17.06.2020 в 15:11
AlexM Дата: Среда, 17.06.2020, 15:31 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Кросс
Код
=ПРОСМОТР(2;1/(ЛЕВБ(G4;5)=ЛЕВБ(B$4:B$11;5));C$4:C$11)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 17.06.2020, 15:38
 
Ответить
СообщениеКросс
Код
=ПРОСМОТР(2;1/(ЛЕВБ(G4;5)=ЛЕВБ(B$4:B$11;5));C$4:C$11)

Автор - AlexM
Дата добавления - 17.06.2020 в 15:31
beal Дата: Четверг, 18.06.2020, 10:27 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ИНДЕКС(C:C;СУММПРОИЗВ((A$4:A$11<=G4)*($B$4:$B$11>=G4)*СТРОКА(B$4:$B$11)))


Спасибо!
 
Ответить
Сообщение
=ИНДЕКС(C:C;СУММПРОИЗВ((A$4:A$11<=G4)*($B$4:$B$11>=G4)*СТРОКА(B$4:$B$11)))


Спасибо!

Автор - beal
Дата добавления - 18.06.2020 в 10:27
beal Дата: Четверг, 18.06.2020, 10:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ПРОСМОТР(2;1/(ЛЕВБ(G4;5)=ЛЕВБ(B$4:B$11;5));C$4:C$11)

На больших объемах, к сожалению, работает некорректно
 
Ответить
Сообщение
=ПРОСМОТР(2;1/(ЛЕВБ(G4;5)=ЛЕВБ(B$4:B$11;5));C$4:C$11)

На больших объемах, к сожалению, работает некорректно

Автор - beal
Дата добавления - 18.06.2020 в 10:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по интервалам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!