Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать средние значения в массиве чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать средние значения в массиве чисел (Формулы/Formulas)
Выбрать средние значения в массиве чисел
l-lisa Дата: Среда, 24.06.2020, 22:35 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 278
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Помогите пожалуйста, отметить средние значения в списке приложенном в файле, для каждого отдельного бренда нужно вывести серединные значения из списка, то есть отсечь нули, отрицательные значения если есть и крайние значения(самые маленькие и самые большие) и тогда получатся искомые медианные значения.
Процентелем не получается вывести верный список, а по-другому я не знаю как
К сообщению приложен файл: 8518822.xlsx(246.6 Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите пожалуйста, отметить средние значения в списке приложенном в файле, для каждого отдельного бренда нужно вывести серединные значения из списка, то есть отсечь нули, отрицательные значения если есть и крайние значения(самые маленькие и самые большие) и тогда получатся искомые медианные значения.
Процентелем не получается вывести верный список, а по-другому я не знаю как

Автор - l-lisa
Дата добавления - 24.06.2020 в 22:35
Pelena Дата: Среда, 24.06.2020, 23:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Может, так подойдёт?
Код
=ЕСЛИОШИБКА(МЕДИАНА(ЕСЛИ(($B$2:$B$15440=E2)*($A$2:$A$15440>0);$A$2:$A$15440));"-")
К сообщению приложен файл: 3967759.xlsx(241.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Может, так подойдёт?
Код
=ЕСЛИОШИБКА(МЕДИАНА(ЕСЛИ(($B$2:$B$15440=E2)*($A$2:$A$15440>0);$A$2:$A$15440));"-")

Автор - Pelena
Дата добавления - 24.06.2020 в 23:14
l-lisa Дата: Четверг, 25.06.2020, 08:10 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 278
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Может, так подойдёт?

Спасибо, но к сожалению нет, Вы нашли именно медиану для каждого бренда, а мне нужны несколько значений для каждого бренда, то есть нужно отсечь краевые и останутся те числа, которые рядом с медианным значением
Может быть формула квартиль подойдёт, но у меня не получается написать правильной формулы(


Сообщение отредактировал l-lisa - Четверг, 25.06.2020, 08:14
 
Ответить
Сообщение
Здравствуйте.
Может, так подойдёт?

Спасибо, но к сожалению нет, Вы нашли именно медиану для каждого бренда, а мне нужны несколько значений для каждого бренда, то есть нужно отсечь краевые и останутся те числа, которые рядом с медианным значением
Может быть формула квартиль подойдёт, но у меня не получается написать правильной формулы(

Автор - l-lisa
Дата добавления - 25.06.2020 в 08:10
Светлый Дата: Четверг, 25.06.2020, 08:49 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1499
Репутация: 389 ±
Замечаний: 0% ±

Excel 2010, 2013
Здравствуйте!
Если сверху и снизу отсечь 10%, так подошло бы?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте!
Если сверху и снизу отсечь 10%, так подошло бы?

Автор - Светлый
Дата добавления - 25.06.2020 в 08:49
l-lisa Дата: Четверг, 25.06.2020, 08:53 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 278
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 25.06.2020 в 08:49, в сообщении № 4 ()
Здравствуйте!
Если сверху и снизу отсечь 10%, так подошло бы?
я пробовала, но остаются отрицательные значения, не совсем подходит
 
Ответить
Сообщение
Цитата Светлый, 25.06.2020 в 08:49, в сообщении № 4 ()
Здравствуйте!
Если сверху и снизу отсечь 10%, так подошло бы?
я пробовала, но остаются отрицательные значения, не совсем подходит

Автор - l-lisa
Дата добавления - 25.06.2020 в 08:53
l-lisa Дата: Четверг, 25.06.2020, 08:54 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 278
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 25.06.2020 в 08:49, в сообщении № 4 ()
Здравствуйте!
Если сверху и снизу отсечь 10%, так подошло бы?
я пробовала, но остаются отрицательные значения, не совсем подходит
 
Ответить
Сообщение
Цитата Светлый, 25.06.2020 в 08:49, в сообщении № 4 ()
Здравствуйте!
Если сверху и снизу отсечь 10%, так подошло бы?
я пробовала, но остаются отрицательные значения, не совсем подходит

Автор - l-lisa
Дата добавления - 25.06.2020 в 08:54
Светлый Дата: Четверг, 25.06.2020, 09:31 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1499
Репутация: 389 ±
Замечаний: 0% ±

Excel 2010, 2013
По 10% без учёта <=0.
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ABS((МАКС(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440))+МИН(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440)))/2-A2)<(МАКС(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440))-МИН(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440)))*2/5


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 25.06.2020, 11:15
 
Ответить
СообщениеПо 10% без учёта <=0.
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ABS((МАКС(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440))+МИН(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440)))/2-A2)<(МАКС(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440))-МИН(ЕСЛИ((B2=$B$2:$B$15440)*($A$2:$A$15440>0);$A$2:$A$15440)))*2/5

Автор - Светлый
Дата добавления - 25.06.2020 в 09:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать средние значения в массиве чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!