Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое обновление данных в ИНДЕКС - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое обновление данных в ИНДЕКС (Формулы/Formulas)
Автоматическое обновление данных в ИНДЕКС
semenizer87 Дата: Понедельник, 29.06.2020, 19:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 365
Добрый день, форумчане! Возник вопрос по поводу наличия какой-нибудь штуки для автоматического обновления списка уникальных значений, отобранного по конкретному условию. Есть вот такая форму массива данных
Код
=ИНДЕКС(Лист1!$A$2:$A$84;НАИМЕНЬШИЙ(ЕСЛИ($A$1=Лист1!$B$2:$B$84;СТРОКА(Лист1!$A$2:$A$84)-1;"");СТРОКА()-1))

где $A$1 есть условие. При внесении изменений в данную ячейку никаких изменений на листе не происходит ровно до тех пор пока не прокликаешь Shift Ctrl Enter по каждой ячейке. Существует ли какое-нибудь решение для автоматизации сего процесса?
 
Ответить
СообщениеДобрый день, форумчане! Возник вопрос по поводу наличия какой-нибудь штуки для автоматического обновления списка уникальных значений, отобранного по конкретному условию. Есть вот такая форму массива данных
Код
=ИНДЕКС(Лист1!$A$2:$A$84;НАИМЕНЬШИЙ(ЕСЛИ($A$1=Лист1!$B$2:$B$84;СТРОКА(Лист1!$A$2:$A$84)-1;"");СТРОКА()-1))

где $A$1 есть условие. При внесении изменений в данную ячейку никаких изменений на листе не происходит ровно до тех пор пока не прокликаешь Shift Ctrl Enter по каждой ячейке. Существует ли какое-нибудь решение для автоматизации сего процесса?

Автор - semenizer87
Дата добавления - 29.06.2020 в 19:59
Pelena Дата: Понедельник, 29.06.2020, 21:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16511
Репутация: 3567 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
semenizer87, оформите формулу тегами с помощью копки fx в режиме правки поста.
по каждой ячейке
зачем по каждой? Достаточно по первой и потом формулу протянуть вниз


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеsemenizer87, оформите формулу тегами с помощью копки fx в режиме правки поста.
по каждой ячейке
зачем по каждой? Достаточно по первой и потом формулу протянуть вниз

Автор - Pelena
Дата добавления - 29.06.2020 в 21:08
semenizer87 Дата: Понедельник, 29.06.2020, 23:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 365
Pelena, в таком случае копируется первое уникальное значение.
 
Ответить
СообщениеPelena, в таком случае копируется первое уникальное значение.

Автор - semenizer87
Дата добавления - 29.06.2020 в 23:35
Pelena Дата: Вторник, 30.06.2020, 08:46 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16511
Репутация: 3567 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Видимо, выключены автовычисления. Проверьте на вкладке Главная -- Параметры вычислений


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВидимо, выключены автовычисления. Проверьте на вкладке Главная -- Параметры вычислений

Автор - Pelena
Дата добавления - 30.06.2020 в 08:46
semenizer87 Дата: Вторник, 30.06.2020, 10:27 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 365
Pelena, точняк! Все работает теперь) Спасибо!
 
Ответить
СообщениеPelena, точняк! Все работает теперь) Спасибо!

Автор - semenizer87
Дата добавления - 30.06.2020 в 10:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое обновление данных в ИНДЕКС (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!