Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти максимум для отдельного значения и даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти максимум для отдельного значения и даты (Формулы/Formulas)
Найти максимум для отдельного значения и даты
l-lisa Дата: Вторник, 30.06.2020, 18:31 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 268
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, подскажите как написать формулу поиска наибольшего значения во втором столбце, для отдельно взятой карточки, с учётом даты и если есть для одной и той же карточки несколько максимальных значений, ставить 1 напротив той, где дата самая "свежая"
К сообщению приложен файл: 3256698.xlsx(10.6 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите как написать формулу поиска наибольшего значения во втором столбце, для отдельно взятой карточки, с учётом даты и если есть для одной и той же карточки несколько максимальных значений, ставить 1 напротив той, где дата самая "свежая"

Автор - l-lisa
Дата добавления - 30.06.2020 в 18:31
Pelena Дата: Вторник, 30.06.2020, 19:41 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16052
Репутация: 3489 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИ((АГРЕГАТ(14;6;$C$2:$C$30/(АГРЕГАТ(14;6;$B$2:$B$30/($A$2:$A$30=A2);1)=$B$2:$B$30)/($A$2:$A$30=A2);1)=C2)*(АГРЕГАТ(14;6;$B$2:$B$30/($A$2:$A$30=A2);1)=B2);1;"")

только не совпало немного с Вашим результатом
К сообщению приложен файл: 2821063.xlsx(12.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ((АГРЕГАТ(14;6;$C$2:$C$30/(АГРЕГАТ(14;6;$B$2:$B$30/($A$2:$A$30=A2);1)=$B$2:$B$30)/($A$2:$A$30=A2);1)=C2)*(АГРЕГАТ(14;6;$B$2:$B$30/($A$2:$A$30=A2);1)=B2);1;"")

только не совпало немного с Вашим результатом

Автор - Pelena
Дата добавления - 30.06.2020 в 19:41
l-lisa Дата: Вторник, 30.06.2020, 19:47 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 268
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Pelena, спасибо Вам огромное)
 
Ответить
СообщениеPelena, спасибо Вам огромное)

Автор - l-lisa
Дата добавления - 30.06.2020 в 19:47
Pelena Дата: Вторник, 30.06.2020, 21:39 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16052
Репутация: 3489 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ещё вариант сводной таблицей PowerPivot
К сообщению приложен файл: 3673112.xlsx(97.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант сводной таблицей PowerPivot

Автор - Pelena
Дата добавления - 30.06.2020 в 21:39
AlexM Дата: Вторник, 30.06.2020, 23:40 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4231
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
Код
=ЕСЛИ(B2+C2%%%=МАКС((A2=A$2:A$30)*(B$2:B$30+C$2:C$30%%%));1;"")
Формула массива



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 30.06.2020, 23:41
 
Ответить
Сообщение
Код
=ЕСЛИ(B2+C2%%%=МАКС((A2=A$2:A$30)*(B$2:B$30+C$2:C$30%%%));1;"")
Формула массива

Автор - AlexM
Дата добавления - 30.06.2020 в 23:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти максимум для отдельного значения и даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!