Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет уникальных значений при фильтрации столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет уникальных значений при фильтрации столбца (Формулы/Formulas)
Счет уникальных значений при фильтрации столбца
Goodzel Дата: Четверг, 02.07.2020, 12:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, уважаемые знатоки и гуру!
Помогите, пожалуйста, доработать формулу
У меня считаются неповторяющиеся даты в ячейке А2, но мне надо фильтровать этот столбец по разным диапазонам и считать уже в отфильтрованном диапазоне, как мне верно правильно доработать формулу?
Буду бесконечно благодарна, восхищаюсь вашими знаниями!
К сообщению приложен файл: __.xlsx(12.5 Kb)
 
Ответить
СообщениеДобрый день, уважаемые знатоки и гуру!
Помогите, пожалуйста, доработать формулу
У меня считаются неповторяющиеся даты в ячейке А2, но мне надо фильтровать этот столбец по разным диапазонам и считать уже в отфильтрованном диапазоне, как мне верно правильно доработать формулу?
Буду бесконечно благодарна, восхищаюсь вашими знаниями!

Автор - Goodzel
Дата добавления - 02.07.2020 в 12:39
Pelena Дата: Четверг, 02.07.2020, 13:33 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Вариант
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;СМЕЩ(A2;СТРОКА(A3:A240)-2;))*(1/СЧЁТЕСЛИ(A3:A240;A3:A240)))
К сообщению приложен файл: -2-.xlsx(13.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;СМЕЩ(A2;СТРОКА(A3:A240)-2;))*(1/СЧЁТЕСЛИ(A3:A240;A3:A240)))

Автор - Pelena
Дата добавления - 02.07.2020 в 13:33
Goodzel Дата: Четверг, 02.07.2020, 14:27 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, спасибо, но у меня там пустые тоже могут быть, когда не вся таблица заполнена, а в этом случае выдает ошибку
 
Ответить
СообщениеPelena, спасибо, но у меня там пустые тоже могут быть, когда не вся таблица заполнена, а в этом случае выдает ошибку

Автор - Goodzel
Дата добавления - 02.07.2020 в 14:27
Pelena Дата: Четверг, 02.07.2020, 15:08 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
О чём ещё Вы умолчали?
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;СМЕЩ(A2;СТРОКА(A3:A240)-2;))*ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(A3:A240;A3:A240);0))
К сообщению приложен файл: 8918372.xlsx(13.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеО чём ещё Вы умолчали?
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;СМЕЩ(A2;СТРОКА(A3:A240)-2;))*ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(A3:A240;A3:A240);0))

Автор - Pelena
Дата добавления - 02.07.2020 в 15:08
Goodzel Дата: Четверг, 02.07.2020, 20:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, благодарю, работает, магия!! )
но почему то когда я фильтрую соседние столбцы, в столбце с датами получается нецелое значение, что я делаю не так?
 
Ответить
СообщениеPelena, благодарю, работает, магия!! )
но почему то когда я фильтрую соседние столбцы, в столбце с датами получается нецелое значение, что я делаю не так?

Автор - Goodzel
Дата добавления - 02.07.2020 в 20:12
Pelena Дата: Четверг, 02.07.2020, 20:22 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В Вашем примере нет других столбцов


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ Вашем примере нет других столбцов

Автор - Pelena
Дата добавления - 02.07.2020 в 20:22
Goodzel Дата: Пятница, 03.07.2020, 08:41 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, не хотела нагружать файл лишним, даже в голову не пришло, что это может повлиять на результат, простите(
Во вложении добавила ФИО столбец и тогда получается нецелое значение у дат
К сообщению приложен файл: 5799970.xlsx(14.7 Kb)
 
Ответить
СообщениеPelena, не хотела нагружать файл лишним, даже в голову не пришло, что это может повлиять на результат, простите(
Во вложении добавила ФИО столбец и тогда получается нецелое значение у дат

Автор - Goodzel
Дата добавления - 03.07.2020 в 08:41
Pelena Дата: Пятница, 03.07.2020, 09:50 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так нужно?
К сообщению приложен файл: 8020045.xlsx(15.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак нужно?

Автор - Pelena
Дата добавления - 03.07.2020 в 09:50
Goodzel Дата: Пятница, 03.07.2020, 13:04 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Вы - гений!!! Благодарю, то что нужно
 
Ответить
СообщениеPelena, Вы - гений!!! Благодарю, то что нужно

Автор - Goodzel
Дата добавления - 03.07.2020 в 13:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет уникальных значений при фильтрации столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!