Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование данных пропуская пустые - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование данных пропуская пустые
Копирование данных пропуская пустые
Mahp_dn Дата: Воскресенье, 05.07.2020, 20:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

10
Добрый день! Тема наверное объезженная, но все равно попрошу помощи.
Задача- табель, по дням недели и фамилии, надо вставить в графу "наработка" пропуская пустые строки (см. файл во вложении) по насильно и в зависимости от дня недели. Можно по примеру понедельника, далее будет понятно как сделать.
Спасибо большое всем за ранее!
К сообщению приложен файл: 7162031.xlsx(9.8 Kb)


Очень позитивный человек
 
Ответить
СообщениеДобрый день! Тема наверное объезженная, но все равно попрошу помощи.
Задача- табель, по дням недели и фамилии, надо вставить в графу "наработка" пропуская пустые строки (см. файл во вложении) по насильно и в зависимости от дня недели. Можно по примеру понедельника, далее будет понятно как сделать.
Спасибо большое всем за ранее!

Автор - Mahp_dn
Дата добавления - 05.07.2020 в 20:09
gling Дата: Воскресенье, 05.07.2020, 20:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2200
Репутация: 546 ±
Замечаний: 0% ±

2010
Здравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$G$16;НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$16>0;СТРОКА($C$3:$C$16);"");СТРОКА(I1));ПОИСКПОЗ(I$2;$A$2:$G$2;));"")
К сообщению приложен файл: 8139857.xlsx(11.9 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 05.07.2020, 20:33
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$G$16;НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$16>0;СТРОКА($C$3:$C$16);"");СТРОКА(I1));ПОИСКПОЗ(I$2;$A$2:$G$2;));"")

Автор - gling
Дата добавления - 05.07.2020 в 20:12
Mahp_dn Дата: Понедельник, 06.07.2020, 17:57 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

10
Спасибо большое! А если залезть еще в дебри, то вместо массива в индексе возможно использовать формулу динамического диапазона. Например пришли новые люди и массив данных увеличивается. Пытаюсь через двссыл( и формула слепить последнюю строку со столицам) не подучается:)


Очень позитивный человек
 
Ответить
СообщениеСпасибо большое! А если залезть еще в дебри, то вместо массива в индексе возможно использовать формулу динамического диапазона. Например пришли новые люди и массив данных увеличивается. Пытаюсь через двссыл( и формула слепить последнюю строку со столицам) не подучается:)

Автор - Mahp_dn
Дата добавления - 06.07.2020 в 17:57
Mahp_dn Дата: Понедельник, 06.07.2020, 18:00 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

10
И как быть если вместо пустых строк формулы?


Очень позитивный человек
 
Ответить
СообщениеИ как быть если вместо пустых строк формулы?

Автор - Mahp_dn
Дата добавления - 06.07.2020 в 18:00
gling Дата: Понедельник, 06.07.2020, 21:14 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2200
Репутация: 546 ±
Замечаний: 0% ±

2010
не подучается:
покажите что слепили.
место массива в индексе
Можно и именованный диапазон, можно вместо 16 написать 160 или 1600
если вместо пустых строк формулы
А вы пробовали прописать там формулы и что то не та посчиталось? Покажите.


ЯД-41001506838083
 
Ответить
Сообщение
не подучается:
покажите что слепили.
место массива в индексе
Можно и именованный диапазон, можно вместо 16 написать 160 или 1600
если вместо пустых строк формулы
А вы пробовали прописать там формулы и что то не та посчиталось? Покажите.

Автор - gling
Дата добавления - 06.07.2020 в 21:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование данных пропуская пустые
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!