Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечение данных на текущий день. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение данных на текущий день. (Формулы/Formulas)
Извлечение данных на текущий день.
Shtein Дата: Понедельник, 13.07.2020, 13:11 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет. Помогите, пожалуйста, с решением такой задачи.
Есть перечень товаров в столбце А. Нужно, чтобы формула в столбец В подтягивала данные из столбцов С-К (которые с течением времени будут добавляться) на сегодняшний день. Например, сегодня 13 июля, в ячейку В должны подтягиваться данные со столбца F. А завтра формула должна подтягивать данные ст.G.
Сейчас это выглядит так: каждый день заходишь и вручную в ст.В проставляешь ссылку на нужный столбец.
Я пытался также решить вопрос с формулами СЕГОДНЯ и ГПР, но ничего не получилось ((

Не могли бы посоветовать, как можно решить задачку?
К сообщению приложен файл: 4842093.xlsx(10.4 Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеВсем привет. Помогите, пожалуйста, с решением такой задачи.
Есть перечень товаров в столбце А. Нужно, чтобы формула в столбец В подтягивала данные из столбцов С-К (которые с течением времени будут добавляться) на сегодняшний день. Например, сегодня 13 июля, в ячейку В должны подтягиваться данные со столбца F. А завтра формула должна подтягивать данные ст.G.
Сейчас это выглядит так: каждый день заходишь и вручную в ст.В проставляешь ссылку на нужный столбец.
Я пытался также решить вопрос с формулами СЕГОДНЯ и ГПР, но ничего не получилось ((

Не могли бы посоветовать, как можно решить задачку?

Автор - Shtein
Дата добавления - 13.07.2020 в 13:11
Russel Дата: Понедельник, 13.07.2020, 13:13 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1361
Репутация: 306 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Код
=СУММПРОИЗВ(($C$1:$K$1=СЕГОДНЯ())*C2:K2)
К сообщению приложен файл: 9312308.xlsx(10.9 Kb)


QIWI 9173973973
 
Ответить
СообщениеДобрый день!
Код
=СУММПРОИЗВ(($C$1:$K$1=СЕГОДНЯ())*C2:K2)

Автор - Russel
Дата добавления - 13.07.2020 в 13:13
китин Дата: Понедельник, 13.07.2020, 13:31 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6313
Репутация: 968 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго
Код
=ПРОСМОТР(2;1/($C$1:$K$1=СЕГОДНЯ());$C2:$K2)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго
Код
=ПРОСМОТР(2;1/($C$1:$K$1=СЕГОДНЯ());$C2:$K2)

Автор - китин
Дата добавления - 13.07.2020 в 13:31
Che79 Дата: Понедельник, 13.07.2020, 13:33 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1637
Репутация: 302 ±
Замечаний: 0% ±

2013 Win, 365 Mac
На всякий пожарный, вариант с накопительным итогом ОТ начальной ДО текущей даты включительно с запасом по диапазонам
Код
=СУММ(C2:ИНДЕКС(C2:XFD2;ПОИСКПОЗ(СЕГОДНЯ();$C$1:$XFD$1;)))
К сообщению приложен файл: 4842093_1.xlsx(13.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеНа всякий пожарный, вариант с накопительным итогом ОТ начальной ДО текущей даты включительно с запасом по диапазонам
Код
=СУММ(C2:ИНДЕКС(C2:XFD2;ПОИСКПОЗ(СЕГОДНЯ();$C$1:$XFD$1;)))

Автор - Che79
Дата добавления - 13.07.2020 в 13:33
Shtein Дата: Понедельник, 13.07.2020, 13:40 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо всем огромное, то что нужно!

hands


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеСпасибо всем огромное, то что нужно!

hands

Автор - Shtein
Дата добавления - 13.07.2020 в 13:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение данных на текущий день. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!