Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование модулей, ABS, ПРОМЕЖУТОЧНЫЕ.ИТОГИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование модулей, ABS, ПРОМЕЖУТОЧНЫЕ.ИТОГИ (Формулы/Formulas)
Суммирование модулей, ABS, ПРОМЕЖУТОЧНЫЕ.ИТОГИ
mrjons Дата: Вторник, 14.07.2020, 16:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
В приложенном файле нужно найти сумму модулей чисел в столбце "Объект" при условии, что строки "Корректировка на характеристику Х, %" могут быть скрыты вручную (применение каких-либо фильтров исключено).
Например, необходимо скрыть строчку "Корректировка на характеристику 3, %", тогда значение "11" должно исключаться из расчета. Скрываться могут и несколько таких строк.
Для реализации этого я знаю только функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ, но она не позволяет суммировать модули чисел, то бишь хотел применить такой синтаксис:
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;ABS(B3);ABS(B5);ABS(B7);ABS(B9);ABS(B11);ABS(B13))
, но выдает ошибку.
Прошу помощи, заранее благодарю.
К сообщению приложен файл: _Microsoft_Exce.xls(27.0 Kb)
 
Ответить
СообщениеДобрый день.
В приложенном файле нужно найти сумму модулей чисел в столбце "Объект" при условии, что строки "Корректировка на характеристику Х, %" могут быть скрыты вручную (применение каких-либо фильтров исключено).
Например, необходимо скрыть строчку "Корректировка на характеристику 3, %", тогда значение "11" должно исключаться из расчета. Скрываться могут и несколько таких строк.
Для реализации этого я знаю только функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ, но она не позволяет суммировать модули чисел, то бишь хотел применить такой синтаксис:
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;ABS(B3);ABS(B5);ABS(B7);ABS(B9);ABS(B11);ABS(B13))
, но выдает ошибку.
Прошу помощи, заранее благодарю.

Автор - mrjons
Дата добавления - 14.07.2020 в 16:33
Pelena Дата: Вторник, 14.07.2020, 18:23 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Как вариант, формула массива
Код
=СУММ(--ЕСЛИОШИБКА(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$13)-1;;)));0))
К сообщению приложен файл: 4830174.xls(27.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как вариант, формула массива
Код
=СУММ(--ЕСЛИОШИБКА(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$13)-1;;)));0))

Автор - Pelena
Дата добавления - 14.07.2020 в 18:23
Che79 Дата: Вторник, 14.07.2020, 20:35 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1595
Репутация: 297 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Ну, с допом в 365 на Mac'е каждый сможет, но пусть тоже будет :D
К сообщению приложен файл: 3905889.png(120.1 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеНу, с допом в 365 на Mac'е каждый сможет, но пусть тоже будет :D

Автор - Che79
Дата добавления - 14.07.2020 в 20:35
mrjons Дата: Среда, 15.07.2020, 09:13 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, есть способ обойтись без массива?
Che79, извините, не понял ваш вариант
 
Ответить
СообщениеPelena, есть способ обойтись без массива?
Che79, извините, не понял ваш вариант

Автор - mrjons
Дата добавления - 15.07.2020 в 09:13
Pelena Дата: Среда, 15.07.2020, 09:32 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
есть способ обойтись без массива?
попробуйте так
Код
=СУММПРОИЗВ(Ч(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$13)-1;;)))))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
есть способ обойтись без массива?
попробуйте так
Код
=СУММПРОИЗВ(Ч(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$13)-1;;)))))

Автор - Pelena
Дата добавления - 15.07.2020 в 09:32
Che79 Дата: Среда, 15.07.2020, 10:12 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1595
Репутация: 297 ±
Замечаний: 0% ±

2013 Win, 365 Mac
без массива
так тоже работает
Код
=СУММПРОИЗВ(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ(B1;СТРОКА(B2:B14)-1;))))

не понял ваш вариант
Ожидаемо. Он в версии Excel на основе нового движка. У Вас, судя по профилю, 2007
К сообщению приложен файл: 156734.xlsx(9.7 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
без массива
так тоже работает
Код
=СУММПРОИЗВ(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ(B1;СТРОКА(B2:B14)-1;))))

не понял ваш вариант
Ожидаемо. Он в версии Excel на основе нового движка. У Вас, судя по профилю, 2007

Автор - Che79
Дата добавления - 15.07.2020 в 10:12
mrjons Дата: Среда, 15.07.2020, 14:13 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, Che79, спасибо, оба варианта работают
Я применил один из этих способов в своем рабочем файле, но структура таблица немного другая (см. приложенный файл), добавились несколько строк с промежуточными результатами, которые не нужно учитывать при суммировании модулей. Для облегчения восприятия зеленным цветом выделил строки, по которым нужно суммировать модули. Красным - не нужно суммировать.
При применении ваших вариантов в функции =СТРОКА не могу разделить диапазон на две части: по первой и второй группе корректировок.
Есть способ решить проблему?
К сообщению приложен файл: 7180161.xls(28.5 Kb)
 
Ответить
СообщениеPelena, Che79, спасибо, оба варианта работают
Я применил один из этих способов в своем рабочем файле, но структура таблица немного другая (см. приложенный файл), добавились несколько строк с промежуточными результатами, которые не нужно учитывать при суммировании модулей. Для облегчения восприятия зеленным цветом выделил строки, по которым нужно суммировать модули. Красным - не нужно суммировать.
При применении ваших вариантов в функции =СТРОКА не могу разделить диапазон на две части: по первой и второй группе корректировок.
Есть способ решить проблему?

Автор - mrjons
Дата добавления - 15.07.2020 в 14:13
Pelena Дата: Среда, 15.07.2020, 14:20 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Полученный результат разделите на 2


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПолученный результат разделите на 2

Автор - Pelena
Дата добавления - 15.07.2020 в 14:20
mrjons Дата: Среда, 15.07.2020, 14:27 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, не совсем понял, можно для тупых, какой результат? Вы имеете ввиду добавить строку с промежуточным результатом по первой группе корректировок, также добавить для второй группы и сложить оба результата?
 
Ответить
СообщениеPelena, не совсем понял, можно для тупых, какой результат? Вы имеете ввиду добавить строку с промежуточным результатом по первой группе корректировок, также добавить для второй группы и сложить оба результата?

Автор - mrjons
Дата добавления - 15.07.2020 в 14:27
Pelena Дата: Среда, 15.07.2020, 14:31 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если у Вас посчитаны два промежуточных результата и вы посчитаете общий по столбцу, то получится, что все числа учитываются дважды. Поэтому и предложила конечный результат разделить на 2


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли у Вас посчитаны два промежуточных результата и вы посчитаете общий по столбцу, то получится, что все числа учитываются дважды. Поэтому и предложила конечный результат разделить на 2

Автор - Pelena
Дата добавления - 15.07.2020 в 14:31
mrjons Дата: Среда, 15.07.2020, 15:01 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, промежуточные результаты не касаются суммирования модулей (выделены красным), это не суммы модулей, а произведение корректировок и сумма корректировок, их нельзя складывать и как-то учитывать.
Промежуточные результаты я добавил специально, потому что варианты решения, предложенные выше, не подходят как раз из-за этих промежуточных результатов
 
Ответить
СообщениеPelena, промежуточные результаты не касаются суммирования модулей (выделены красным), это не суммы модулей, а произведение корректировок и сумма корректировок, их нельзя складывать и как-то учитывать.
Промежуточные результаты я добавил специально, потому что варианты решения, предложенные выше, не подходят как раз из-за этих промежуточных результатов

Автор - mrjons
Дата добавления - 15.07.2020 в 15:01
Pelena Дата: Среда, 15.07.2020, 16:53 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Да, это я невнимательно посмотрела.
Как вариант, если можно привязаться к слову Корректировка
Код
=СУММПРОИЗВ(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$17)-1;;)))*(ЛЕВСИМВ($A$2:$A$17;13)="Корректировка"))
К сообщению приложен файл: 9791244.xls(28.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДа, это я невнимательно посмотрела.
Как вариант, если можно привязаться к слову Корректировка
Код
=СУММПРОИЗВ(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$17)-1;;)))*(ЛЕВСИМВ($A$2:$A$17;13)="Корректировка"))

Автор - Pelena
Дата добавления - 15.07.2020 в 16:53
mrjons Дата: Среда, 15.07.2020, 17:22 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, т.е. в расчет идут только строки, в которых написано "Корректировка"? И привязаться можно к любому слову, изменив название строки? Могу привязать к "%"?
 
Ответить
СообщениеPelena, т.е. в расчет идут только строки, в которых написано "Корректировка"? И привязаться можно к любому слову, изменив название строки? Могу привязать к "%"?

Автор - mrjons
Дата добавления - 15.07.2020 в 17:22
Che79 Дата: Среда, 15.07.2020, 17:38 | Сообщение № 14
Группа: Друзья
Ранг: Старожил
Сообщений: 1595
Репутация: 297 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Могу привязать к "%"?
можете, но тогда с бубном и танцами впридачу, иначе будут суммироваться и красные строки тоже.
Код
=СУММПРОИЗВ(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$17)-1;;)))*(ПРАВБ($A$2:$A$17)="%")*(ПРАВБ($A$2:$A$17;5)<>"пе, %"))
К сообщению приложен файл: 9791244-1.xls(29.5 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Могу привязать к "%"?
можете, но тогда с бубном и танцами впридачу, иначе будут суммироваться и красные строки тоже.
Код
=СУММПРОИЗВ(ABS(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;СМЕЩ($B$1;СТРОКА($B$2:$B$17)-1;;)))*(ПРАВБ($A$2:$A$17)="%")*(ПРАВБ($A$2:$A$17;5)<>"пе, %"))

Автор - Che79
Дата добавления - 15.07.2020 в 17:38
mrjons Дата: Среда, 15.07.2020, 17:54 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, ох ё, проще удалить "%" в красных строках и привязаться как показала Pelena,
В любом случае спасибо боги экселя
 
Ответить
СообщениеChe79, ох ё, проще удалить "%" в красных строках и привязаться как показала Pelena,
В любом случае спасибо боги экселя

Автор - mrjons
Дата добавления - 15.07.2020 в 17:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование модулей, ABS, ПРОМЕЖУТОЧНЫЕ.ИТОГИ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!