Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка строк по параметру и компиляция из них таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка строк по параметру и компиляция из них таблицы (Формулы/Formulas)
Выборка строк по параметру и компиляция из них таблицы
ldbaikal2020 Дата: Пятница, 17.07.2020, 19:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте!
В приложенном файле есть 3 листа. Необходимо чтобы на листе "Санузлы с формулой" получилась такая же таблица как на листе "Санузлы", где в таблицу собраны строки с параметром: "Санузел", "Санузел МГН", "Санузел и душ" из строк таблицы на листе "Все помещения".
К сообщению приложен файл: __.xlsx(43.7 Kb)


Сообщение отредактировал ldbaikal2020 - Пятница, 17.07.2020, 22:09
 
Ответить
СообщениеЗдравствуйте!
В приложенном файле есть 3 листа. Необходимо чтобы на листе "Санузлы с формулой" получилась такая же таблица как на листе "Санузлы", где в таблицу собраны строки с параметром: "Санузел", "Санузел МГН", "Санузел и душ" из строк таблицы на листе "Все помещения".

Автор - ldbaikal2020
Дата добавления - 17.07.2020 в 19:48
Michael_S Дата: Суббота, 18.07.2020, 01:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1959
Репутация: 366 ±
Замечаний: 0% ±

Excel2016
ldbaikal2020, и вам доброго здоровья!
По какому критерию располагаются данные в таблице? (если я правильно понял - то формулами будет сложновато, макрос нужен)
Что делать с повторяющуюся значениями?
 
Ответить
Сообщениеldbaikal2020, и вам доброго здоровья!
По какому критерию располагаются данные в таблице? (если я правильно понял - то формулами будет сложновато, макрос нужен)
Что делать с повторяющуюся значениями?

Автор - Michael_S
Дата добавления - 18.07.2020 в 01:23
ldbaikal2020 Дата: Суббота, 18.07.2020, 09:44 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Данные в таблице располагаются по критерию:

Если находит строку с параметром: "Санузел", "Санузел МГН", "Санузел и душ" то выводятся все данные из этой строки исходной таблицы и так далее пока не провериться вся таблица и не выведутся строки с параметром: "Санузел", "Санузел МГН", "Санузел и душ". Повторяющиеся значения - это только выбранный параметр, а все строки с этими параметром разные, поэтому должна получится таблица у которой один столбец будет с повторяющимся параметром, но сами строки будет с разными данными.


Сообщение отредактировал ldbaikal2020 - Суббота, 18.07.2020, 09:46
 
Ответить
СообщениеДанные в таблице располагаются по критерию:

Если находит строку с параметром: "Санузел", "Санузел МГН", "Санузел и душ" то выводятся все данные из этой строки исходной таблицы и так далее пока не провериться вся таблица и не выведутся строки с параметром: "Санузел", "Санузел МГН", "Санузел и душ". Повторяющиеся значения - это только выбранный параметр, а все строки с этими параметром разные, поэтому должна получится таблица у которой один столбец будет с повторяющимся параметром, но сами строки будет с разными данными.

Автор - ldbaikal2020
Дата добавления - 18.07.2020 в 09:44
Pelena Дата: Суббота, 18.07.2020, 10:07 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В первой колонке
Код
=ЕСЛИОШИБКА(ИНДЕКС('Все помещ-я'!$A$2:$A$601;АГРЕГАТ(15;6;'Все помещ-я'!$A$2:$A$601/($B$1:$D$1='Все помещ-я'!$G$2:$G$601);СТРОКА(A1)));"")

дальше ВПР()
К сообщению приложен файл: -3-.xlsx(48.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ первой колонке
Код
=ЕСЛИОШИБКА(ИНДЕКС('Все помещ-я'!$A$2:$A$601;АГРЕГАТ(15;6;'Все помещ-я'!$A$2:$A$601/($B$1:$D$1='Все помещ-я'!$G$2:$G$601);СТРОКА(A1)));"")

дальше ВПР()

Автор - Pelena
Дата добавления - 18.07.2020 в 10:07
ldbaikal2020 Дата: Суббота, 18.07.2020, 10:25 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Огромное СПАСИБО!!!!!!!!!!
 
Ответить
СообщениеОгромное СПАСИБО!!!!!!!!!!

Автор - ldbaikal2020
Дата добавления - 18.07.2020 в 10:25
ldbaikal2020 Дата: Суббота, 18.07.2020, 10:40 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
А как добавить в параметры: "Санузел", "Санузел МГН", "Санузел и душ" ещё параметр, например: "Мужской санузел"
 
Ответить
СообщениеА как добавить в параметры: "Санузел", "Санузел МГН", "Санузел и душ" ещё параметр, например: "Мужской санузел"

Автор - ldbaikal2020
Дата добавления - 18.07.2020 в 10:40
Pelena Дата: Суббота, 18.07.2020, 10:46 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16256
Репутация: 3520 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Добавьте в верхнюю строку и увеличьте диапазон в формуле


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДобавьте в верхнюю строку и увеличьте диапазон в формуле

Автор - Pelena
Дата добавления - 18.07.2020 в 10:46
ldbaikal2020 Дата: Суббота, 18.07.2020, 11:07 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Ещё раз - БОЛЬШОЕ СПАСИБО!!!!!!
 
Ответить
СообщениеЕщё раз - БОЛЬШОЕ СПАСИБО!!!!!!

Автор - ldbaikal2020
Дата добавления - 18.07.2020 в 11:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка строк по параметру и компиляция из них таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!