Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Одно имя - несколько областей. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Одно имя - несколько областей. (Формулы/Formulas)
Одно имя - несколько областей.
and708 Дата: Среда, 22.07.2020, 13:28 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Всем добрый день. Известно, что в Excel допустима такая ситуация, когда с помощью диспетчера имен можно присвоить одно имя разным диапазонам ячеек. К этим именам применимы разные функции, например:
Код
=СЧЁТ(ди1)

но к сожалению, к двнным именам невозможно применение функции СЧЁТЕСЛИ.
конечно же, можно использовать сумму разных СЧЁТЕСЛИ, например:

Код
=СЧЁТЕСЛИ(B2;7)+СЧЁТЕСЛИ(C3;7)+...+СЧЁТЕСЛИ(J10:7)


но это очень неудобно и тогда вообще непонятно, есть ли смысл присваивать этому даипазону разрозненному отдельное имя. может быть, проблему можно решить как-то по-другому, но чтобы остались главные условия: одна функция и наличие внутри этой функции нашего имени - и чтобы результат этой фунцкции был бы конкретным и понятным. Например, функция

Код
=СЧЁТЕСЛИ(ди1;B2)


приведет к результату "#ЗНАЧ#". Подскажите пожалуйста может есть какой-то разумный аналог (чтобы не суммировать СЧЁТЕСЛИ для каждой области, а воспользоваться одной функцией и этим именем. Спасибо за помощь и понимание. и простите что-то не пойму как отформатировать более правильно функции, я старался.
К сообщению приложен файл: ___.xlsx(9.7 Kb)


Сообщение отредактировал and708 - Среда, 22.07.2020, 13:31
 
Ответить
СообщениеВсем добрый день. Известно, что в Excel допустима такая ситуация, когда с помощью диспетчера имен можно присвоить одно имя разным диапазонам ячеек. К этим именам применимы разные функции, например:
Код
=СЧЁТ(ди1)

но к сожалению, к двнным именам невозможно применение функции СЧЁТЕСЛИ.
конечно же, можно использовать сумму разных СЧЁТЕСЛИ, например:

Код
=СЧЁТЕСЛИ(B2;7)+СЧЁТЕСЛИ(C3;7)+...+СЧЁТЕСЛИ(J10:7)


но это очень неудобно и тогда вообще непонятно, есть ли смысл присваивать этому даипазону разрозненному отдельное имя. может быть, проблему можно решить как-то по-другому, но чтобы остались главные условия: одна функция и наличие внутри этой функции нашего имени - и чтобы результат этой фунцкции был бы конкретным и понятным. Например, функция

Код
=СЧЁТЕСЛИ(ди1;B2)


приведет к результату "#ЗНАЧ#". Подскажите пожалуйста может есть какой-то разумный аналог (чтобы не суммировать СЧЁТЕСЛИ для каждой области, а воспользоваться одной функцией и этим именем. Спасибо за помощь и понимание. и простите что-то не пойму как отформатировать более правильно функции, я старался.

Автор - and708
Дата добавления - 22.07.2020 в 13:28
bmv98rus Дата: Среда, 22.07.2020, 13:54 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 3077
Репутация: 534 ±
Замечаний: 0% ±

Excel 2013/2016
может есть какой-то разумный аналог

Код
=SUMPRODUCT(--(INDEX(B2:J10;N(INDEX(ROW(1:9);));N(INDEX(ROW(1:9);)))=B2))

но никакой связит с диапазоном из нескольких областей.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 22.07.2020, 13:55
 
Ответить
Сообщение
может есть какой-то разумный аналог

Код
=SUMPRODUCT(--(INDEX(B2:J10;N(INDEX(ROW(1:9);));N(INDEX(ROW(1:9);)))=B2))

но никакой связит с диапазоном из нескольких областей.

Автор - bmv98rus
Дата добавления - 22.07.2020 в 13:54
Nic70y Дата: Среда, 22.07.2020, 13:56 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6310
Репутация: 1393 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММПРОИЗВ((СТОЛБЕЦ($B$2:$J$10)=СТРОКА($B$2:$J$10))*($B$2:$J$10=1))
аналог
Код
=СЧЁТЕСЛИ(ди1;1)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((СТОЛБЕЦ($B$2:$J$10)=СТРОКА($B$2:$J$10))*($B$2:$J$10=1))
аналог
Код
=СЧЁТЕСЛИ(ди1;1)

Автор - Nic70y
Дата добавления - 22.07.2020 в 13:56
and708 Дата: Среда, 22.07.2020, 14:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Nic70y, спасибо большое!
 
Ответить
СообщениеNic70y, спасибо большое!

Автор - and708
Дата добавления - 22.07.2020 в 14:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Одно имя - несколько областей. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!