Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт уникальных значений по списку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт уникальных значений по списку (Формулы/Formulas)
Подсчёт уникальных значений по списку
Dirc Дата: Четверг, 06.08.2020, 17:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток.
Стронулся с проблемой, есть список договоров, требуется составить формулу так, чтобы если № договора когда-то встречался в списке, то формула в ячейки на против него ставит 0 если не встречался, то ставит 1.
Пример во вложении.
К сообщению приложен файл: prim.xlsx(12.3 Kb)
 
Ответить
СообщениеДоброго времени суток.
Стронулся с проблемой, есть список договоров, требуется составить формулу так, чтобы если № договора когда-то встречался в списке, то формула в ячейки на против него ставит 0 если не встречался, то ставит 1.
Пример во вложении.

Автор - Dirc
Дата добавления - 06.08.2020 в 17:13
Nic70y Дата: Четверг, 06.08.2020, 17:22 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=--НЕ(СЧЁТЕСЛИ(D$3:D3;D3)-1)
а лучше так
Код
=--(ПОИСКПОЗ(D3;D$1:D3;)=СТРОКА())


ЮMoney(Яндекс Деньги) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 06.08.2020, 17:24
 
Ответить
Сообщение
Код
=--НЕ(СЧЁТЕСЛИ(D$3:D3;D3)-1)
а лучше так
Код
=--(ПОИСКПОЗ(D3;D$1:D3;)=СТРОКА())

Автор - Nic70y
Дата добавления - 06.08.2020 в 17:22
gling Дата: Четверг, 06.08.2020, 21:41 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Здравствуйте.
Не понимаю для чего 0 в таблице? От нулей в глазах рябит, среди них нужно ещё не пропустить ячейку со значением >0. Мой вариант на будущее, если появится необходимость узнать "А где встречался этот номер?". Вариант без нулей
Код
=ЕСЛИОШИБКА("Этот № в ячейке D"&ПОИСКПОЗ(D3;$D$2:D2;)+1;1)


ЯД-41001506838083

Сообщение отредактировал gling - Четверг, 06.08.2020, 21:46
 
Ответить
СообщениеЗдравствуйте.
Не понимаю для чего 0 в таблице? От нулей в глазах рябит, среди них нужно ещё не пропустить ячейку со значением >0. Мой вариант на будущее, если появится необходимость узнать "А где встречался этот номер?". Вариант без нулей
Код
=ЕСЛИОШИБКА("Этот № в ячейке D"&ПОИСКПОЗ(D3;$D$2:D2;)+1;1)

Автор - gling
Дата добавления - 06.08.2020 в 21:41
Dirc Дата: Пятница, 07.08.2020, 09:05 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Огромное спасибо!
 
Ответить
СообщениеОгромное спасибо!

Автор - Dirc
Дата добавления - 07.08.2020 в 09:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт уникальных значений по списку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!