Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значений из предыдущей ячей и следующей - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений из предыдущей ячей и следующей (Формулы/Formulas)
Вывод значений из предыдущей ячей и следующей
Chetvertkoff Дата: Пятница, 14.08.2020, 14:39 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет, вот в чем суть вопроса, не могу правильно понять как это работает, поэтому обращаюсь к вам. Есть массив чисел А1:А20 и есть искомое значение к примеру 11, (массив может быть не по порядку, в примере просто для примера так сделал, могут быть и не числа а буквы в массиве) находим в массиве значение 11 и смотрим какое значение перед ним - выводим, и после. Собственно все. Пример прилагаю.
К сообщению приложен файл: 4701169.xlsx(10.5 Kb)
 
Ответить
СообщениеВсем привет, вот в чем суть вопроса, не могу правильно понять как это работает, поэтому обращаюсь к вам. Есть массив чисел А1:А20 и есть искомое значение к примеру 11, (массив может быть не по порядку, в примере просто для примера так сделал, могут быть и не числа а буквы в массиве) находим в массиве значение 11 и смотрим какое значение перед ним - выводим, и после. Собственно все. Пример прилагаю.

Автор - Chetvertkoff
Дата добавления - 14.08.2020 в 14:39
bigor Дата: Пятница, 14.08.2020, 14:43 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Добрый день. А сами пробовали?
Код
=Index...Match...+/-1
 
Ответить
СообщениеДобрый день. А сами пробовали?
Код
=Index...Match...+/-1

Автор - bigor
Дата добавления - 14.08.2020 в 14:43
Chetvertkoff Дата: Пятница, 14.08.2020, 16:43 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Интересно а для чего тогда этот форум? Прошу прощения за текст не по теме - Прихожу я как то к лору с жалобами на боли в горле и кашель, а мне врач и говорит -"А сам то что думаешь? " .... Так вот Если бы я сам не пробовал я бы сюда не писал бы... Спасибо за безсмысленную формулу, мне это ни о чем не говорит
 
Ответить
СообщениеИнтересно а для чего тогда этот форум? Прошу прощения за текст не по теме - Прихожу я как то к лору с жалобами на боли в горле и кашель, а мне врач и говорит -"А сам то что думаешь? " .... Так вот Если бы я сам не пробовал я бы сюда не писал бы... Спасибо за безсмысленную формулу, мне это ни о чем не говорит

Автор - Chetvertkoff
Дата добавления - 14.08.2020 в 16:43
bigor Дата: Пятница, 14.08.2020, 18:16 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Я думаю, что форум для помощи разобраться с проблемами в Excel. Вот я и поинтересовался, пробовали Вы сами разобраться. Ну раз Вам только готовое решение нужно, то смотрите:
до
Код
=INDEX(A1:A21;MATCH(F6;A1:A21;0)-1)

после
Код
=INDEX(A1:A21;MATCH(F6;A1:A21;0)+1)
 
Ответить
СообщениеЯ думаю, что форум для помощи разобраться с проблемами в Excel. Вот я и поинтересовался, пробовали Вы сами разобраться. Ну раз Вам только готовое решение нужно, то смотрите:
до
Код
=INDEX(A1:A21;MATCH(F6;A1:A21;0)-1)

после
Код
=INDEX(A1:A21;MATCH(F6;A1:A21;0)+1)

Автор - bigor
Дата добавления - 14.08.2020 в 18:16
AlexM Дата: Суббота, 15.08.2020, 19:53 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Код
=ВПР(F6;ЕСЛИ({1;0};A2:A21;A1:A20);2;)
Код
=ВПР(F6;ЕСЛИ({1;0};A1:A20;A2:A21);2;)
Если искомое значение первое или последнее в массиве, то соответственно предыдущее и последующее определяется некорректно в этих формулах, как и предложенных выше.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ВПР(F6;ЕСЛИ({1;0};A2:A21;A1:A20);2;)
Код
=ВПР(F6;ЕСЛИ({1;0};A1:A20;A2:A21);2;)
Если искомое значение первое или последнее в массиве, то соответственно предыдущее и последующее определяется некорректно в этих формулах, как и предложенных выше.

Автор - AlexM
Дата добавления - 15.08.2020 в 19:53
Chetvertkoff Дата: Понедельник, 17.08.2020, 08:04 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, с ИНДЕКСом, все работает. я так же и пробовал, я просто не знал что можно именно номер строки.... я думал там только столбцы указываются ... Спасибо еще раз все работает.
 
Ответить
СообщениеСпасибо, с ИНДЕКСом, все работает. я так же и пробовал, я просто не знал что можно именно номер строки.... я думал там только столбцы указываются ... Спасибо еще раз все работает.

Автор - Chetvertkoff
Дата добавления - 17.08.2020 в 08:04
Юрий_Ф Дата: Понедельник, 17.08.2020, 12:34 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
А можно у вас поинтересоваться: как это применяется? к чему?
(может, и мне такая таблица нужна для моих данных?)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеА можно у вас поинтересоваться: как это применяется? к чему?
(может, и мне такая таблица нужна для моих данных?)

Автор - Юрий_Ф
Дата добавления - 17.08.2020 в 12:34
Nic70y Дата: Понедельник, 17.08.2020, 12:50 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
к чему?
это когда сегодня ищут вчерашний день)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
к чему?
это когда сегодня ищут вчерашний день)

Автор - Nic70y
Дата добавления - 17.08.2020 в 12:50
Юрий_Ф Дата: Понедельник, 17.08.2020, 13:53 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
Нет, ну я же серьёзно спросил! Может, есть в этом смысл и для кого-то другого!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеНет, ну я же серьёзно спросил! Может, есть в этом смысл и для кого-то другого!

Автор - Юрий_Ф
Дата добавления - 17.08.2020 в 13:53
Nic70y Дата: Понедельник, 17.08.2020, 14:33 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
серьёзно
и я серьезно,
это 1 из вариантов - искать вчерашний день.
еще вариант в файле.
К сообщению приложен файл: 0619507.xlsx(8.4 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
серьёзно
и я серьезно,
это 1 из вариантов - искать вчерашний день.
еще вариант в файле.

Автор - Nic70y
Дата добавления - 17.08.2020 в 14:33
Юрий_Ф Дата: Понедельник, 17.08.2020, 18:23 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
Честно говоря, из вашего файла ничего не понял! Что там надо было найти по той 9ке в С1!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Понедельник, 17.08.2020, 19:26
 
Ответить
СообщениеЧестно говоря, из вашего файла ничего не понял! Что там надо было найти по той 9ке в С1!

Автор - Юрий_Ф
Дата добавления - 17.08.2020 в 18:23
Che79 Дата: Понедельник, 17.08.2020, 20:44 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 1626
Репутация: 301 ±
Замечаний: 0% ±

2013 Win, 365 Mac
искать вчерашний день. еще вариант в файле
В E6 пишем
Код
=ИНДЕКС($A:$A;МИН(ЕСЛИ($A:$A=$F$6;СТРОКА(A:A)-1+2*(A1=""))))
в G6 её же просто копипастим.
К сообщению приложен файл: 4701169-2.xlsx(12.5 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
искать вчерашний день. еще вариант в файле
В E6 пишем
Код
=ИНДЕКС($A:$A;МИН(ЕСЛИ($A:$A=$F$6;СТРОКА(A:A)-1+2*(A1=""))))
в G6 её же просто копипастим.

Автор - Che79
Дата добавления - 17.08.2020 в 20:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений из предыдущей ячей и следующей (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!