Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Эксель перенос из одного листа в другой по опред. признаку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Эксель перенос из одного листа в другой по опред. признаку (Формулы/Formulas)
Эксель перенос из одного листа в другой по опред. признаку
Maria1111 Дата: Воскресенье, 16.08.2020, 21:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Прошу помочь, буду объяснять на примере (во вложении)
Есть лист "что есть" там список животных с признаком "да/нет", животные могут повторяться, но меняя возраст/имя.
Необходимо если я проставляю признак животное "да", то он подтягивался на другой лист со своими признаками (как указано на листе "как должно быть")
Проблема с которой я сталкнулась: впр/индекс не помогает, так как он будет подтягивать первого животного, но у меня, например животное "волки" повторяются и надо, чтобы все животные перенеслись, а не только 1 волк.

То есть по факту на листе "как должно быть" я указала итоговый вариант, но вбивала в ручную, а ндо формулами/макросами
Помогите, пожалуйста!
К сообщению приложен файл: 8398421.xlsx(9.3 Kb)


Сообщение отредактировал Maria1111 - Воскресенье, 16.08.2020, 21:32
 
Ответить
СообщениеДобрый день!
Прошу помочь, буду объяснять на примере (во вложении)
Есть лист "что есть" там список животных с признаком "да/нет", животные могут повторяться, но меняя возраст/имя.
Необходимо если я проставляю признак животное "да", то он подтягивался на другой лист со своими признаками (как указано на листе "как должно быть")
Проблема с которой я сталкнулась: впр/индекс не помогает, так как он будет подтягивать первого животного, но у меня, например животное "волки" повторяются и надо, чтобы все животные перенеслись, а не только 1 волк.

То есть по факту на листе "как должно быть" я указала итоговый вариант, но вбивала в ручную, а ндо формулами/макросами
Помогите, пожалуйста!

Автор - Maria1111
Дата добавления - 16.08.2020 в 21:32
прохожий2019 Дата: Воскресенье, 16.08.2020, 21:49 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
старый Excel
Код
=ЕСЛИОШИБКА(ИНДЕКС('что есть'!$A$1:$A$7;НАИМЕНЬШИЙ(ЕСЛИ('что есть'!$E$2:$E$7="Да";СТРОКА('что есть'!$E$2:$E$7);"");СТРОКА(A1)));"")

новый Excel
Код
=ИНДЕКС(ФИЛЬТР('что есть'!$A$2:$C$7;'что есть'!$E$2:$E$7="Да");ПОСЛЕД(СЧЁТЕСЛИ('что есть'!E2:E7;"Да"));{1;3;2})
К сообщению приложен файл: 2848862.xlsx(11.8 Kb)
 
Ответить
Сообщениестарый Excel
Код
=ЕСЛИОШИБКА(ИНДЕКС('что есть'!$A$1:$A$7;НАИМЕНЬШИЙ(ЕСЛИ('что есть'!$E$2:$E$7="Да";СТРОКА('что есть'!$E$2:$E$7);"");СТРОКА(A1)));"")

новый Excel
Код
=ИНДЕКС(ФИЛЬТР('что есть'!$A$2:$C$7;'что есть'!$E$2:$E$7="Да");ПОСЛЕД(СЧЁТЕСЛИ('что есть'!E2:E7;"Да"));{1;3;2})

Автор - прохожий2019
Дата добавления - 16.08.2020 в 21:49
Maria1111 Дата: Воскресенье, 16.08.2020, 21:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
прохожий2019,
Буду тестить, БЛАГОДАРЮ ВАС!
 
Ответить
Сообщениепрохожий2019,
Буду тестить, БЛАГОДАРЮ ВАС!

Автор - Maria1111
Дата добавления - 16.08.2020 в 21:56
Che79 Дата: Воскресенье, 16.08.2020, 21:56 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1626
Репутация: 301 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Здравствуйте. Как вариант, сводная таблица с фильтром
К сообщению приложен файл: 8398421-2.xlsx(106.1 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Как вариант, сводная таблица с фильтром

Автор - Che79
Дата добавления - 16.08.2020 в 21:56
прохожий2019 Дата: Воскресенье, 16.08.2020, 22:11 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
PQ[vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    to = Table.SelectRows(from, each ([животное2] = "Да"))[[Животное],[имя],[возраст]]
in
    to
[/vba]
К сообщению приложен файл: 4615648.xlsx(20.6 Kb)
 
Ответить
СообщениеPQ[vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    to = Table.SelectRows(from, each ([животное2] = "Да"))[[Животное],[имя],[возраст]]
in
    to
[/vba]

Автор - прохожий2019
Дата добавления - 16.08.2020 в 22:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Эксель перенос из одного листа в другой по опред. признаку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!