Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как установить наличие взаимосвязи между столбцами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как установить наличие взаимосвязи между столбцами (Формулы/Formulas)
Как установить наличие взаимосвязи между столбцами
kNNeR Дата: Суббота, 29.08.2020, 16:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
Помогите.

У меня на листе - несколько столбцов.
Два желтых столбца - основные и четыре дополнительных.

В них идет набор нулей (или пустых мест) и единиц.
Как установить - есть ли в появлении единиц в дополнительных столбцах - какая-либо закономерность и вывести эти виды установленных закономерностей - в таблицу W4:Z8 ?

Если закономерность идет в последующих ячейках - то "-1"
Если закономерность проявляется в той же строке - то "1"
Если закономерность идет в последующих ячейках - то "2"
К сообщению приложен файл: 0425774.xlsb(12.1 Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите.

У меня на листе - несколько столбцов.
Два желтых столбца - основные и четыре дополнительных.

В них идет набор нулей (или пустых мест) и единиц.
Как установить - есть ли в появлении единиц в дополнительных столбцах - какая-либо закономерность и вывести эти виды установленных закономерностей - в таблицу W4:Z8 ?

Если закономерность идет в последующих ячейках - то "-1"
Если закономерность проявляется в той же строке - то "1"
Если закономерность идет в последующих ячейках - то "2"

Автор - kNNeR
Дата добавления - 29.08.2020 в 16:45
Pelena Дата: Суббота, 29.08.2020, 18:04 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Что считать закономерностью?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Что считать закономерностью?

Автор - Pelena
Дата добавления - 29.08.2020 в 18:04
kNNeR Дата: Суббота, 29.08.2020, 19:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Закономерность - это когда на каждой 1 желтого столбца - соответствует 1 рыжего столбца (либо на той же строке, либо строкой выше, либо строкой ниже).
Я же присоединил файл пример, где разноцветными квадратами на рыжих столбцах - подсветил место где встречаются эти единицы.
 
Ответить
СообщениеЗакономерность - это когда на каждой 1 желтого столбца - соответствует 1 рыжего столбца (либо на той же строке, либо строкой выше, либо строкой ниже).
Я же присоединил файл пример, где разноцветными квадратами на рыжих столбцах - подсветил место где встречаются эти единицы.

Автор - kNNeR
Дата добавления - 29.08.2020 в 19:25
прохожий2019 Дата: Суббота, 29.08.2020, 20:43 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
в примере последующие идут во второй ячейке и множим на 2 - в этом что ли закономерность?
Код
=(СУММ(ЕСЛИ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=1;--(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=ИНДЕКС($J$5:$P$34;;ПОИСКПОЗ(W$3;$J$3:$P$3;)));""))=СУММ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))))-(СУММ(ЕСЛИ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=1;--(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=ИНДЕКС($J$4:$P$33;;ПОИСКПОЗ(W$3;$J$3:$P$3;)));""))=СУММ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))))+2*(СУММ(ЕСЛИ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=1;--(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=ИНДЕКС($J$7:$P$36;;ПОИСКПОЗ(W$3;$J$3:$P$3;)));""))=СУММ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))))
К сообщению приложен файл: 2160491.xlsb(13.6 Kb)
 
Ответить
Сообщениев примере последующие идут во второй ячейке и множим на 2 - в этом что ли закономерность?
Код
=(СУММ(ЕСЛИ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=1;--(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=ИНДЕКС($J$5:$P$34;;ПОИСКПОЗ(W$3;$J$3:$P$3;)));""))=СУММ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))))-(СУММ(ЕСЛИ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=1;--(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=ИНДЕКС($J$4:$P$33;;ПОИСКПОЗ(W$3;$J$3:$P$3;)));""))=СУММ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))))+2*(СУММ(ЕСЛИ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=1;--(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))=ИНДЕКС($J$7:$P$36;;ПОИСКПОЗ(W$3;$J$3:$P$3;)));""))=СУММ(ИНДЕКС($B$5:$D$34;;ПОИСКПОЗ($V4;$B$3:$D$3;))))

Автор - прохожий2019
Дата добавления - 29.08.2020 в 20:43
kNNeR Дата: Суббота, 29.08.2020, 21:07 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
прохожий2019, ну вообще - да.
Эта формула видит последовательность.
Спасибо.
 
Ответить
Сообщениепрохожий2019, ну вообще - да.
Эта формула видит последовательность.
Спасибо.

Автор - kNNeR
Дата добавления - 29.08.2020 в 21:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как установить наличие взаимосвязи между столбцами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!