Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенести медицинскую формулу в Excel - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести медицинскую формулу в Excel (Формулы/Formulas)
Перенести медицинскую формулу в Excel
pavel124124 Дата: Понедельник, 31.08.2020, 13:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, для упрощения жизни делаю таблицу. Нужно одну формулу перенести правильно.
Формула расчета СКФ CKD-EPI. СКФ = 141 x min (креатинин/ k)^α x max (креатинин / k)^ -1.209 x 0.993^Возраст x 1.018 (у женщин) x 1.159 (для негроидной расы), где k равняется 0,9 у мужчин, 0,7 у слабого пола, α — соответственно -0,411 и -0,329. Сывороточный креатинин измеряют в мг/дл. (у меня в формуле первое число указано в мкмоль/мл поэтому использую второе число)
Есть калькуляторы онлайн, в них проверяю и значения не сходятся. моя формула в файле "формула".
Можете подсказать что делаю не так, у меня ощущение, что формула изначально не правилно прочитал или что то со степенями напутал.
К сообщению приложен файл: 8767575.xls(24.0 Kb)


Сообщение отредактировал pavel124124 - Понедельник, 31.08.2020, 13:42
 
Ответить
СообщениеДобрый день, для упрощения жизни делаю таблицу. Нужно одну формулу перенести правильно.
Формула расчета СКФ CKD-EPI. СКФ = 141 x min (креатинин/ k)^α x max (креатинин / k)^ -1.209 x 0.993^Возраст x 1.018 (у женщин) x 1.159 (для негроидной расы), где k равняется 0,9 у мужчин, 0,7 у слабого пола, α — соответственно -0,411 и -0,329. Сывороточный креатинин измеряют в мг/дл. (у меня в формуле первое число указано в мкмоль/мл поэтому использую второе число)
Есть калькуляторы онлайн, в них проверяю и значения не сходятся. моя формула в файле "формула".
Можете подсказать что делаю не так, у меня ощущение, что формула изначально не правилно прочитал или что то со степенями напутал.

Автор - pavel124124
Дата добавления - 31.08.2020 в 13:16
прохожий2019 Дата: Понедельник, 31.08.2020, 13:25 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
моя формула в файле "формула".
где файл?
 
Ответить
Сообщение
моя формула в файле "формула".
где файл?

Автор - прохожий2019
Дата добавления - 31.08.2020 в 13:25
bigor Дата: Понедельник, 31.08.2020, 15:44 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
Как то так, без негроидной расы
Код
=141*(C3/IF(B1="м";0,9;0,7))^IF(B1="м";-0,411;-0,329)*(C3/IF(B1="м";0,9;0,7))^-1,209*0,993^B2*IF(B1="м";1;1,018)

Проверяйте на своих калькуляторах
 
Ответить
СообщениеДобрый день.
Как то так, без негроидной расы
Код
=141*(C3/IF(B1="м";0,9;0,7))^IF(B1="м";-0,411;-0,329)*(C3/IF(B1="м";0,9;0,7))^-1,209*0,993^B2*IF(B1="м";1;1,018)

Проверяйте на своих калькуляторах

Автор - bigor
Дата добавления - 31.08.2020 в 15:44
pavel124124 Дата: Вторник, 01.09.2020, 09:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день.
Как то так, без негроидной расы

=141*(C3/ЕСЛИ(B1="м";0;9;0;7))^ЕСЛИ(B1="м";-0;411;-0;329)*(C3/ЕСЛИ(B1="м";0;9;0;7))^-1;209*0;993^B2*ЕСЛИ(B1="м";1;1;018)

Проверяйте на своих калькуляторах


На калькуляторе онлайн ответ выходит 65 мл/мин/1,73м2 и вобще понял что у всех калькуляторов числа не много разнятся. Еще есть вот такой файл, из его макросов можно посмотреть формулу которую применяли?
https://yadi.sk/i/IBeZrMK30755dQ
К сообщению приложен файл: calc_2.xls(241.5 Kb)
 
Ответить
Сообщение
Добрый день.
Как то так, без негроидной расы

=141*(C3/ЕСЛИ(B1="м";0;9;0;7))^ЕСЛИ(B1="м";-0;411;-0;329)*(C3/ЕСЛИ(B1="м";0;9;0;7))^-1;209*0;993^B2*ЕСЛИ(B1="м";1;1;018)

Проверяйте на своих калькуляторах


На калькуляторе онлайн ответ выходит 65 мл/мин/1,73м2 и вобще понял что у всех калькуляторов числа не много разнятся. Еще есть вот такой файл, из его макросов можно посмотреть формулу которую применяли?
https://yadi.sk/i/IBeZrMK30755dQ

Автор - pavel124124
Дата добавления - 01.09.2020 в 09:41
bigor Дата: Вторник, 01.09.2020, 15:06 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Там вначале рассчитывается
Код
=IF(X11=1;(F7/79,6);(F7/61,9))
, где х11 пол (1 мужчина); F7 -Сывороточный креатинин
затем
Код
=IF(F7>62;POWER(Z7;-1,209);IF(X11=1;POWER(Z7;-0,411);POWER(Z7;-0,329)))
, где z7 значение предыдущей формулы
и в конце
Код
=IF(X11=1;(Z8*141)*POWER(0,993;F4);(Z8*144)*POWER(0,993;F4))
где Z8 значение второй формулы, F4 - возраст
 
Ответить
СообщениеТам вначале рассчитывается
Код
=IF(X11=1;(F7/79,6);(F7/61,9))
, где х11 пол (1 мужчина); F7 -Сывороточный креатинин
затем
Код
=IF(F7>62;POWER(Z7;-1,209);IF(X11=1;POWER(Z7;-0,411);POWER(Z7;-0,329)))
, где z7 значение предыдущей формулы
и в конце
Код
=IF(X11=1;(Z8*141)*POWER(0,993;F4);(Z8*144)*POWER(0,993;F4))
где Z8 значение второй формулы, F4 - возраст

Автор - bigor
Дата добавления - 01.09.2020 в 15:06
pavel124124 Дата: Вторник, 01.09.2020, 19:17 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Там вначале рассчитывается

=ЕСЛИ(X11=1;(F7/79;6);(F7/61;9))
, где х11 пол (1 мужчина); F7 -Сывороточный креатинин
затем

=ЕСЛИ(F7>62;СТЕПЕНЬ(Z7;-1;209);ЕСЛИ(X11=1;СТЕПЕНЬ(Z7;-0;411);СТЕПЕНЬ(Z7;-0;329)))
, где z7 значение предыдущей формулы
и в конце

=ЕСЛИ(X11=1;(Z8*141)*СТЕПЕНЬ(0;993;F4);(Z8*144)*СТЕПЕНЬ(0;993;F4))
где Z8 значение второй формулы, F4 - возраст


Спасибо! На основании этого нашел формулу оригинальную правильно оформленную. Но не могу ее вторую часть сформировать.
Формула a*(креатинин/b)^c*(0.993)^возраст, где a =144 если Ж и a=141 если м, b=61.9 если Ж и b=79,6 если М, с=-0,329 если это Ж и креатинин <=62, с=-0,411 если это М и креатинин <=62, с=-1,209 если креатинин >62. Вот у меня проблемы с С, приходится делать 2 таблицы для М и для Ж. А формула эта верная.
 
Ответить
Сообщение
Там вначале рассчитывается

=ЕСЛИ(X11=1;(F7/79;6);(F7/61;9))
, где х11 пол (1 мужчина); F7 -Сывороточный креатинин
затем

=ЕСЛИ(F7>62;СТЕПЕНЬ(Z7;-1;209);ЕСЛИ(X11=1;СТЕПЕНЬ(Z7;-0;411);СТЕПЕНЬ(Z7;-0;329)))
, где z7 значение предыдущей формулы
и в конце

=ЕСЛИ(X11=1;(Z8*141)*СТЕПЕНЬ(0;993;F4);(Z8*144)*СТЕПЕНЬ(0;993;F4))
где Z8 значение второй формулы, F4 - возраст


Спасибо! На основании этого нашел формулу оригинальную правильно оформленную. Но не могу ее вторую часть сформировать.
Формула a*(креатинин/b)^c*(0.993)^возраст, где a =144 если Ж и a=141 если м, b=61.9 если Ж и b=79,6 если М, с=-0,329 если это Ж и креатинин <=62, с=-0,411 если это М и креатинин <=62, с=-1,209 если креатинин >62. Вот у меня проблемы с С, приходится делать 2 таблицы для М и для Ж. А формула эта верная.

Автор - pavel124124
Дата добавления - 01.09.2020 в 19:17
bigor Дата: Вторник, 01.09.2020, 19:53 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Проверяйте
Код
=IF(B1="м";141;144)*(B3/IF(B1="м";79,6;61,9))^(IF(B3>62;-1,209;IF(B1="м";-0,411;-0,329)))*0,993^B2


[p.s.]поправьте свои посты, пока модераторы не "поругали" за излишнее цитирование


Сообщение отредактировал bigor - Вторник, 01.09.2020, 19:58
 
Ответить
СообщениеПроверяйте
Код
=IF(B1="м";141;144)*(B3/IF(B1="м";79,6;61,9))^(IF(B3>62;-1,209;IF(B1="м";-0,411;-0,329)))*0,993^B2


[p.s.]поправьте свои посты, пока модераторы не "поругали" за излишнее цитирование

Автор - bigor
Дата добавления - 01.09.2020 в 19:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести медицинскую формулу в Excel (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!