Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/счет строк между повторяющимися значениями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счет строк между повторяющимися значениями (Формулы/Formulas)
счет строк между повторяющимися значениями
Serg_99 Дата: Понедельник, 31.08.2020, 17:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
В столбе В посчитаны строки между повторами одного значения столба А можно ли это как то автоматизировать?
К сообщению приложен файл: 310820.xlsx(14.1 Kb)
 
Ответить
СообщениеВ столбе В посчитаны строки между повторами одного значения столба А можно ли это как то автоматизировать?

Автор - Serg_99
Дата добавления - 31.08.2020 в 17:51
_Boroda_ Дата: Понедельник, 31.08.2020, 18:00 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(A2=6;ЕСЛИОШИБКА(СТРОКА()+ПРОСМОТР(;-СТРОКА(A$1:A1)/(A$1:A1=6));"");"")
К сообщению приложен файл: 310820_1.xlsx(15.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(A2=6;ЕСЛИОШИБКА(СТРОКА()+ПРОСМОТР(;-СТРОКА(A$1:A1)/(A$1:A1=6));"");"")

Автор - _Boroda_
Дата добавления - 31.08.2020 в 18:00
Excelлист Дата: Воскресенье, 06.09.2020, 13:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Немного подсмотрел у _Boroda_ respect
Чуток изменил, теперь считает все промежутки, кроме единичек.
Может и так тоже подойдет:
Код
{=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()-МАКС(СТРОКА($A$1:A1)*($A$1:A1=A2))=1;"";СТРОКА()-МАКС(СТРОКА($A$1:A1)*($A$1:A1=A2)));"")}
К сообщению приложен файл: 6958415.xlsx(17.0 Kb)
 
Ответить
СообщениеНемного подсмотрел у _Boroda_ respect
Чуток изменил, теперь считает все промежутки, кроме единичек.
Может и так тоже подойдет:
Код
{=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()-МАКС(СТРОКА($A$1:A1)*($A$1:A1=A2))=1;"";СТРОКА()-МАКС(СТРОКА($A$1:A1)*($A$1:A1=A2)));"")}

Автор - Excelлист
Дата добавления - 06.09.2020 в 13:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счет строк между повторяющимися значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!