Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значения (ВПР) по трем параметрам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения (ВПР) по трем параметрам (Формулы/Formulas)
поиск значения (ВПР) по трем параметрам
Liof78 Дата: Среда, 02.09.2020, 15:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день, уважаемые гуру Экселя!
В ячейке V2 прописана формула для поиска позиции по 2 переменным одной таблицы. Необходимо составить формулу, чтобы искала во всех 3 таблицах (лист РАСЦЕНКИ на м2) с учетом 3-х переменных в столбцах F, L, Q
К ВПР привязываться не обязательно, главное чтобы была рабочая.
Заранее благодарен.
К сообщению приложен файл: ___31.08.xlsx(57.3 Kb)
 
Ответить
СообщениеДобрый день, уважаемые гуру Экселя!
В ячейке V2 прописана формула для поиска позиции по 2 переменным одной таблицы. Необходимо составить формулу, чтобы искала во всех 3 таблицах (лист РАСЦЕНКИ на м2) с учетом 3-х переменных в столбцах F, L, Q
К ВПР привязываться не обязательно, главное чтобы была рабочая.
Заранее благодарен.

Автор - Liof78
Дата добавления - 02.09.2020 в 15:23
-vp- Дата: Среда, 02.09.2020, 16:29 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Вроде так работает. Но обратите внимание на "красные" ячейки.
К сообщению приложен файл: _31.08-2-.xlsx(158.8 Kb)
 
Ответить
СообщениеВроде так работает. Но обратите внимание на "красные" ячейки.

Автор - -vp-
Дата добавления - 02.09.2020 в 16:29
Pelena Дата: Среда, 02.09.2020, 17:10 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16646
Репутация: 3599 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ещё варианты, немассивные
Код
=ИНДЕКС('РАСЦЕНКИ на м2'!$D$3:$V$62;ПОИСКПОЗ(Q2;'РАСЦЕНКИ на м2'!$A$3:$A$62;0)+ПОИСКПОЗ(F2;'РАСЦЕНКИ на м2'!$B$3:$B$20;0)-1;ПОИСКПОЗ(L2;'РАСЦЕНКИ на м2'!$D$2:$V$2;0))

Код
=СУММПРОИЗВ((F2='РАСЦЕНКИ на м2'!$B$3:$B$62)*(Q2='РАСЦЕНКИ на м2'!$A$3:$A$62)*(L2='РАСЦЕНКИ на м2'!$D$2:$V$2)*'РАСЦЕНКИ на м2'!$D$3:$V$62)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё варианты, немассивные
Код
=ИНДЕКС('РАСЦЕНКИ на м2'!$D$3:$V$62;ПОИСКПОЗ(Q2;'РАСЦЕНКИ на м2'!$A$3:$A$62;0)+ПОИСКПОЗ(F2;'РАСЦЕНКИ на м2'!$B$3:$B$20;0)-1;ПОИСКПОЗ(L2;'РАСЦЕНКИ на м2'!$D$2:$V$2;0))

Код
=СУММПРОИЗВ((F2='РАСЦЕНКИ на м2'!$B$3:$B$62)*(Q2='РАСЦЕНКИ на м2'!$A$3:$A$62)*(L2='РАСЦЕНКИ на м2'!$D$2:$V$2)*'РАСЦЕНКИ на м2'!$D$3:$V$62)

Автор - Pelena
Дата добавления - 02.09.2020 в 17:10
bmv98rus Дата: Среда, 02.09.2020, 20:07 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3219
Репутация: 554 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUMIFS(INDEX('РАСЦЕНКИ на м2'!$D$3:$V$62;;MATCH(ГФУ!L2;'РАСЦЕНКИ на м2'!$D$2:$V$2;));'РАСЦЕНКИ на м2'!$B$3:$B$62;ГФУ!F2;'РАСЦЕНКИ на м2'!$A$3:$A$62;ГФУ!Q2)

ВПР так ВПР
Код
=VLOOKUP(F2;CHOOSE(MATCH(Q2;{"из";"эо";"сп"};);'РАСЦЕНКИ на м2'!$B$3:$V$20;'РАСЦЕНКИ на м2'!$B$24:$V$41;'РАСЦЕНКИ на м2'!$B$45:$V$62);MATCH(ГФУ!L2;'РАСЦЕНКИ на м2'!$B$2:$V$2;))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 02.09.2020, 20:14
 
Ответить
Сообщение
Код
=SUMIFS(INDEX('РАСЦЕНКИ на м2'!$D$3:$V$62;;MATCH(ГФУ!L2;'РАСЦЕНКИ на м2'!$D$2:$V$2;));'РАСЦЕНКИ на м2'!$B$3:$B$62;ГФУ!F2;'РАСЦЕНКИ на м2'!$A$3:$A$62;ГФУ!Q2)

ВПР так ВПР
Код
=VLOOKUP(F2;CHOOSE(MATCH(Q2;{"из";"эо";"сп"};);'РАСЦЕНКИ на м2'!$B$3:$V$20;'РАСЦЕНКИ на м2'!$B$24:$V$41;'РАСЦЕНКИ на м2'!$B$45:$V$62);MATCH(ГФУ!L2;'РАСЦЕНКИ на м2'!$B$2:$V$2;))

Автор - bmv98rus
Дата добавления - 02.09.2020 в 20:07
Liof78 Дата: Четверг, 03.09.2020, 08:28 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Всем спасибо за ответы! Все работает
 
Ответить
СообщениеВсем спасибо за ответы! Все работает

Автор - Liof78
Дата добавления - 03.09.2020 в 08:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения (ВПР) по трем параметрам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!