Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения по 1 критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения по 1 критерию (Формулы/Formulas)
Выбор значения по 1 критерию
liskaya Дата: Четверг, 03.09.2020, 14:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте! Помогите, пожалуйста. В голове у меня все легко, а в экселе никак не получается(
Есть 3 столбца со значениями. В первом столбце наименование продукции - в других - тип корпуса и тип упаковки.
Нужно при вбивании продукции - получить наименование корпуса и упаковки. Для знающих это очень легко, а я всю голову сломала...
К сообщению приложен файл: 1699393.xlsx(9.5 Kb)
 
Ответить
СообщениеЗдравствуйте! Помогите, пожалуйста. В голове у меня все легко, а в экселе никак не получается(
Есть 3 столбца со значениями. В первом столбце наименование продукции - в других - тип корпуса и тип упаковки.
Нужно при вбивании продукции - получить наименование корпуса и упаковки. Для знающих это очень легко, а я всю голову сломала...

Автор - liskaya
Дата добавления - 03.09.2020 в 14:08
bigor Дата: Четверг, 03.09.2020, 14:17 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Добрый день

Для корпусов
Код
=IFERROR(VLOOKUP(C15;$B$2:$D$11;2;0);"")
, для упаковки 2 поменять на 3
 
Ответить
СообщениеДобрый день

Для корпусов
Код
=IFERROR(VLOOKUP(C15;$B$2:$D$11;2;0);"")
, для упаковки 2 поменять на 3

Автор - bigor
Дата добавления - 03.09.2020 в 14:17
liskaya Дата: Четверг, 03.09.2020, 14:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
bigor, Спасибо ВАМ огромное! hands hands hands
 
Ответить
Сообщениеbigor, Спасибо ВАМ огромное! hands hands hands

Автор - liskaya
Дата добавления - 03.09.2020 в 14:26
_Boroda_ Дата: Четверг, 03.09.2020, 15:23 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Чтобы не менять 2 на 3, можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$11;ПОИСКПОЗ($C15;$B$2:$B$11;));"")

Или, при произвольном расположении столбцов, так
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$D$11;ПОИСКПОЗ($C15;$B$2:$B$11;);ПОИСКПОЗ(D$14;$C$1:$D$1;));"")
К сообщению приложен файл: 1699393_1.xlsx(10.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧтобы не менять 2 на 3, можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$11;ПОИСКПОЗ($C15;$B$2:$B$11;));"")

Или, при произвольном расположении столбцов, так
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$D$11;ПОИСКПОЗ($C15;$B$2:$B$11;);ПОИСКПОЗ(D$14;$C$1:$D$1;));"")

Автор - _Boroda_
Дата добавления - 03.09.2020 в 15:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения по 1 критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!