Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ по условию/ям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ по условию/ям (Формулы/Formulas)
СУММПРОИЗВ по условию/ям
Anis625 Дата: Четверг, 10.09.2020, 12:25 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 435
Репутация: 14 ±
Замечаний: 0% ±

Excel 2013
Добрый день, всем участникам форума!

Очередная стена в Excel и прошу помочь:
Как правильно прописать условия в СУММПРОИЗВ, чтобы он не весь диапазон захватывал а только необходимые.
Этот вариант не работает:
Код
{=СУММПРОИЗВ(ЕСЛИ($A$9:$A$20;A2;$B$9:$B$20);ЕСЛИ($A$9:$A$20;A2;$C$9:$C$20))}
К сообщению приложен файл: 6426583.xlsx(10.1 Kb)
 
Ответить
СообщениеДобрый день, всем участникам форума!

Очередная стена в Excel и прошу помочь:
Как правильно прописать условия в СУММПРОИЗВ, чтобы он не весь диапазон захватывал а только необходимые.
Этот вариант не работает:
Код
{=СУММПРОИЗВ(ЕСЛИ($A$9:$A$20;A2;$B$9:$B$20);ЕСЛИ($A$9:$A$20;A2;$C$9:$C$20))}

Автор - Anis625
Дата добавления - 10.09.2020 в 12:25
Pelena Дата: Четверг, 10.09.2020, 12:43 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(($A$9:$A$20=A2)*$B$9:$B$20*$C$9:$C$20)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(($A$9:$A$20=A2)*$B$9:$B$20*$C$9:$C$20)

Автор - Pelena
Дата добавления - 10.09.2020 в 12:43
Anis625 Дата: Четверг, 10.09.2020, 12:51 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 435
Репутация: 14 ±
Замечаний: 0% ±

Excel 2013
Pelena,
Крутяяяяяяк. Спасибо Вам огромное. Реально не знал =)
 
Ответить
СообщениеPelena,
Крутяяяяяяк. Спасибо Вам огромное. Реально не знал =)

Автор - Anis625
Дата добавления - 10.09.2020 в 12:51
Anis625 Дата: Четверг, 10.09.2020, 12:59 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 435
Репутация: 14 ±
Замечаний: 0% ±

Excel 2013
Pelena,
Все летит (выдает ЗНАЧ) если количество (хотя бы в одной строке) указано "-".
Так не срабатывает:
Код
=СУММПРОИЗВ(($A$9:$A$20=A2)*$B$9:$B$20*($C$9:$C$20<>"-"))


Этот вариант тоже не сработал:
Код
=СУММПРОИЗВ((($A$9:$A$20=A2)+($C$9:$C$20<>"-"))*$B$9:$B$20*$C$9:$C$20)


Сообщение отредактировал Anis625 - Четверг, 10.09.2020, 13:06
 
Ответить
СообщениеPelena,
Все летит (выдает ЗНАЧ) если количество (хотя бы в одной строке) указано "-".
Так не срабатывает:
Код
=СУММПРОИЗВ(($A$9:$A$20=A2)*$B$9:$B$20*($C$9:$C$20<>"-"))


Этот вариант тоже не сработал:
Код
=СУММПРОИЗВ((($A$9:$A$20=A2)+($C$9:$C$20<>"-"))*$B$9:$B$20*$C$9:$C$20)

Автор - Anis625
Дата добавления - 10.09.2020 в 12:59
Pelena Дата: Четверг, 10.09.2020, 13:13 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Попробуйте так
Код
=СУММПРОИЗВ(($A$9:$A$20=A2)*$B$9:$B$20;$C$9:$C$20)

А вообще надо не "-" ставить, а 0, а "-" выводить форматом при необходимости


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте так
Код
=СУММПРОИЗВ(($A$9:$A$20=A2)*$B$9:$B$20;$C$9:$C$20)

А вообще надо не "-" ставить, а 0, а "-" выводить форматом при необходимости

Автор - Pelena
Дата добавления - 10.09.2020 в 13:13
Anis625 Дата: Четверг, 10.09.2020, 13:20 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 435
Репутация: 14 ±
Замечаний: 0% ±

Excel 2013
Pelena,
Все перепробовал, а эту нет =) Все получилось. Спасибо Вам.
 
Ответить
СообщениеPelena,
Все перепробовал, а эту нет =) Все получилось. Спасибо Вам.

Автор - Anis625
Дата добавления - 10.09.2020 в 13:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ по условию/ям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!