Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение нескольких вложенных условий в одну формулу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение нескольких вложенных условий в одну формулу (Формулы/Formulas)
Объединение нескольких вложенных условий в одну формулу
arxon Дата: Среда, 16.09.2020, 13:13 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, господа. Не получается объединить формулы в одну, прошу помочь.
Все формулы тут напишу, а в файле-примере все подробно.

Код

=ЕСЛИ(A3<26001;((МИН(МАКС((A3*1,2);(A3+5000));9999999))))
=ЕСЛИ(И(A3>26000;A3<40001);((МИН(МАКС((A3*1,2);(A3+5000));9999999))))
=ЕСЛИ(И(A3>40000;A3<100001);((МИН(МАКС((A3*1,15);(A3+8000));9999999))))
=ЕСЛИ(И(A3>100000;A3<150001);((МИН(МАКС((A3*1,13);(A3+15000));9999999))))
=ЕСЛИ(И(A3>150000;A3<200001);((МИН(МАКС((A3*1,11);(A3+19500));9999999))))
=ЕСЛИ(И(A3>200000;A3<500001);((МИН(МАКС((A3*1,1);(A3+22000));9999999))))


Обязательно делать при помощи ЕСЛИМН ? просто не во всех excel есть эта формула...
К сообщению приложен файл: 6655918.xlsx(12.6 Kb)
 
Ответить
СообщениеДобрый день, господа. Не получается объединить формулы в одну, прошу помочь.
Все формулы тут напишу, а в файле-примере все подробно.

Код

=ЕСЛИ(A3<26001;((МИН(МАКС((A3*1,2);(A3+5000));9999999))))
=ЕСЛИ(И(A3>26000;A3<40001);((МИН(МАКС((A3*1,2);(A3+5000));9999999))))
=ЕСЛИ(И(A3>40000;A3<100001);((МИН(МАКС((A3*1,15);(A3+8000));9999999))))
=ЕСЛИ(И(A3>100000;A3<150001);((МИН(МАКС((A3*1,13);(A3+15000));9999999))))
=ЕСЛИ(И(A3>150000;A3<200001);((МИН(МАКС((A3*1,11);(A3+19500));9999999))))
=ЕСЛИ(И(A3>200000;A3<500001);((МИН(МАКС((A3*1,1);(A3+22000));9999999))))


Обязательно делать при помощи ЕСЛИМН ? просто не во всех excel есть эта формула...

Автор - arxon
Дата добавления - 16.09.2020 в 13:13
Pelena Дата: Среда, 16.09.2020, 16:36 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16659
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Не особо вникала в суть формул
Код
=ВЫБОР(ПОИСКПОЗ(A3;{0;40000;100000;150000;200000;500000});МИН(МАКС(A3*1,2;A3+5000);9999999);МИН(МАКС(A3*1,15;A3+8000);9999999);МИН(МАКС(A3*1,13;A3+15000);9999999);МИН(МАКС(A3*1,11;A3+19500);999999);МИН(МАКС(A3*1,1;A3+22000);9999999))
К сообщению приложен файл: 3144675.xlsx(13.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Не особо вникала в суть формул
Код
=ВЫБОР(ПОИСКПОЗ(A3;{0;40000;100000;150000;200000;500000});МИН(МАКС(A3*1,2;A3+5000);9999999);МИН(МАКС(A3*1,15;A3+8000);9999999);МИН(МАКС(A3*1,13;A3+15000);9999999);МИН(МАКС(A3*1,11;A3+19500);999999);МИН(МАКС(A3*1,1;A3+22000);9999999))

Автор - Pelena
Дата добавления - 16.09.2020 в 16:36
arxon Дата: Среда, 16.09.2020, 18:37 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Большое спасибо не знал о такой формуле вообще! выглядит лаконично
 
Ответить
СообщениеБольшое спасибо не знал о такой формуле вообще! выглядит лаконично

Автор - arxon
Дата добавления - 16.09.2020 в 18:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение нескольких вложенных условий в одну формулу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!