Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как подтянуть информацию из таблицы в таблицу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подтянуть информацию из таблицы в таблицу (Формулы/Formulas)
Как подтянуть информацию из таблицы в таблицу
DIMXLS Дата: Среда, 16.09.2020, 21:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем привет.
Нужна помощь, какую функцию применить для того чтобы подтянуть информацию с таблицы одного листа в таблицу на другой лист. Общая связь это наименование сайта. Задача: нужно в таблицу на первом листе подтянуть телефоны из таблицы второго листа, только в те строки где совпадает наименование сайта. Понимаю, что это ВПР, но как сделать, пока не получается.
К сообщению приложен файл: all_v1__.xls(22.5 Kb)
 
Ответить
СообщениеВсем привет.
Нужна помощь, какую функцию применить для того чтобы подтянуть информацию с таблицы одного листа в таблицу на другой лист. Общая связь это наименование сайта. Задача: нужно в таблицу на первом листе подтянуть телефоны из таблицы второго листа, только в те строки где совпадает наименование сайта. Понимаю, что это ВПР, но как сделать, пока не получается.

Автор - DIMXLS
Дата добавления - 16.09.2020 в 21:31
-vp- Дата: Среда, 16.09.2020, 22:02 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте. Просто ВПР у Вас не получится, так как номера телефонов в таблице левее адресов сайта, по которым должен производится поиск. Поэтому используем ИНДЕКС + ПОИСКПОЗ.
Код
=ЕСЛИОШИБКА(ИНДЕКС('Combine Sheet'!$C$2:$C$9;ПОИСКПОЗ(B2;'Combine Sheet'!$E$2:$E$9;0));"Телефон не указан! ...")
К сообщению приложен файл: all_v1_.xls(31.5 Kb)


Сообщение отредактировал -vp- - Среда, 16.09.2020, 22:38
 
Ответить
СообщениеЗдравствуйте. Просто ВПР у Вас не получится, так как номера телефонов в таблице левее адресов сайта, по которым должен производится поиск. Поэтому используем ИНДЕКС + ПОИСКПОЗ.
Код
=ЕСЛИОШИБКА(ИНДЕКС('Combine Sheet'!$C$2:$C$9;ПОИСКПОЗ(B2;'Combine Sheet'!$E$2:$E$9;0));"Телефон не указан! ...")

Автор - -vp-
Дата добавления - 16.09.2020 в 22:02
gling Дата: Среда, 16.09.2020, 22:04 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2184
Репутация: 544 ±
Замечаний: 0% ±

2010
Здравствуйте.
Почти ВПР, попробуйте
Код
=ИНДЕКС('Combine Sheet'!C:C;ПОИСКПОЗ(Лист3!B2&"*";'Combine Sheet'!E:E;0))

Цитата
номера телефонов в таблице левее
А ещё названия сайтов могут быть без слеша в конце и с ним.


ЯД-41001506838083

Сообщение отредактировал gling - Среда, 16.09.2020, 22:07
 
Ответить
СообщениеЗдравствуйте.
Почти ВПР, попробуйте
Код
=ИНДЕКС('Combine Sheet'!C:C;ПОИСКПОЗ(Лист3!B2&"*";'Combine Sheet'!E:E;0))

Цитата
номера телефонов в таблице левее
А ещё названия сайтов могут быть без слеша в конце и с ним.

Автор - gling
Дата добавления - 16.09.2020 в 22:04
Che79 Дата: Четверг, 17.09.2020, 00:39 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1629
Репутация: 301 ±
Замечаний: 0% ±

2013 Win, 365 Mac
ВПР у Вас не получится
а если получится? :D
Код
=ЕСЛИОШИБКА(ВПР(B2&"*";ЕСЛИ({1;0};'Combine Sheet'!$F$2:$F$1000;'Combine Sheet'!$C$2:$C$1000);2;);"--")
см. зеленые ячейки (в темно-зеленой ручная проверка)
К сообщению приложен файл: all_v1_001.xls(34.0 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
ВПР у Вас не получится
а если получится? :D
Код
=ЕСЛИОШИБКА(ВПР(B2&"*";ЕСЛИ({1;0};'Combine Sheet'!$F$2:$F$1000;'Combine Sheet'!$C$2:$C$1000);2;);"--")
см. зеленые ячейки (в темно-зеленой ручная проверка)

Автор - Che79
Дата добавления - 17.09.2020 в 00:39
-vp- Дата: Четверг, 17.09.2020, 06:47 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
а если получится?


ПРОСТО удивительно ! :'( yes hands
 
Ответить
Сообщение
а если получится?


ПРОСТО удивительно ! :'( yes hands

Автор - -vp-
Дата добавления - 17.09.2020 в 06:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подтянуть информацию из таблицы в таблицу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!