Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как исправить ошибку? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как исправить ошибку? (Формулы/Formulas)
как исправить ошибку?
CODLOVER Дата: Понедельник, 21.09.2020, 20:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Доброго времени суток! Есть диапазон [0, 1] в ячейке С2 и 4 одинаковых по длине полуинтервалов [0, 0.25), [0.25, 0,5), [0.5, 0.75),[0.75, 1]
значениям которых будут соответствовать значения 2, 3, 4, 5, соответственно. Нужно вывести результат в F2.
Вот то что я смог сделать, должно все работать ,но почему то всегда выдает ложное значение. Помогите исправить пожалуйста!
Код
=ЕСЛИ(И(C2<=0;C2<=0,25);2;ЕСЛИ(И(C2=0,25;C2<=0,5);3;ЕСЛИ(И(C 2=0,5;C2<=0,75);4;ЕСЛИ(И(C2=0,75;C2<=1);5))))
 
Ответить
СообщениеДоброго времени суток! Есть диапазон [0, 1] в ячейке С2 и 4 одинаковых по длине полуинтервалов [0, 0.25), [0.25, 0,5), [0.5, 0.75),[0.75, 1]
значениям которых будут соответствовать значения 2, 3, 4, 5, соответственно. Нужно вывести результат в F2.
Вот то что я смог сделать, должно все работать ,но почему то всегда выдает ложное значение. Помогите исправить пожалуйста!
Код
=ЕСЛИ(И(C2<=0;C2<=0,25);2;ЕСЛИ(И(C2=0,25;C2<=0,5);3;ЕСЛИ(И(C 2=0,5;C2<=0,75);4;ЕСЛИ(И(C2=0,75;C2<=1);5))))

Автор - CODLOVER
Дата добавления - 21.09.2020 в 20:00
bigor Дата: Понедельник, 21.09.2020, 20:46 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 681
Репутация: 139 ±
Замечаний: 0% ±

нет
Добрый вечер.
Во первых название темы скорее всего придется менять
Во вторых хотелось бы пример в xls файле
В третьих
AND(C2<=0,C2<=0.25)
должно быть
Код
AND(C2>=0,C2<0.25)


AND(C2=0.25,C2<=0.5)
Код
AND(C2>=0.25,C2<=0.5)
ну итд
 
Ответить
СообщениеДобрый вечер.
Во первых название темы скорее всего придется менять
Во вторых хотелось бы пример в xls файле
В третьих
AND(C2<=0,C2<=0.25)
должно быть
Код
AND(C2>=0,C2<0.25)


AND(C2=0.25,C2<=0.5)
Код
AND(C2>=0.25,C2<=0.5)
ну итд

Автор - bigor
Дата добавления - 21.09.2020 в 20:46
Hugo Дата: Понедельник, 21.09.2020, 20:48 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3140
Репутация: 670 ±
Замечаний: 0% ±

2010, теперь уже с PQ
Достаточно ВПР с нечётким поиском. Если правильно понял из описания...


excel@nxt.ru
webmoney: R418926282008 Z422237915069
 
Ответить
СообщениеДостаточно ВПР с нечётким поиском. Если правильно понял из описания...

Автор - Hugo
Дата добавления - 21.09.2020 в 20:48
прохожий2019 Дата: Понедельник, 21.09.2020, 20:49 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 908
Репутация: 250 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ПРОСМОТР(A1;{0;0,25;0,5;0,75};{2;3;4;5})
Код
=ГПР(A1;{0;0,25;0,5;0,75:2;3;4;5};2;1)
Код
=МИН(ОТБР(A1/25%)+2;5)


Сообщение отредактировал прохожий2019 - Понедельник, 21.09.2020, 21:32
 
Ответить
Сообщение
Код
=ПРОСМОТР(A1;{0;0,25;0,5;0,75};{2;3;4;5})
Код
=ГПР(A1;{0;0,25;0,5;0,75:2;3;4;5};2;1)
Код
=МИН(ОТБР(A1/25%)+2;5)

Автор - прохожий2019
Дата добавления - 21.09.2020 в 20:49
Pelena Дата: Понедельник, 21.09.2020, 21:02 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
CODLOVER, дайте теме более конкретное название, отражающее суть задачи в соответствии с Правилами форума


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеCODLOVER, дайте теме более конкретное название, отражающее суть задачи в соответствии с Правилами форума

Автор - Pelena
Дата добавления - 21.09.2020 в 21:02
CODLOVER Дата: Вторник, 22.09.2020, 13:29 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
bigor, то что нужно! Спасибо большое!
 
Ответить
Сообщениеbigor, то что нужно! Спасибо большое!

Автор - CODLOVER
Дата добавления - 22.09.2020 в 13:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как исправить ошибку? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!