Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование значений массива по столбцам (строкам) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений массива по столбцам (строкам) (Формулы/Formulas)
Суммирование значений массива по столбцам (строкам)
-vp- Дата: Вторник, 22.09.2020, 16:15 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте

Подскажите, пожалуйста, есть ли возможность одной формулой суммировать по столбцам (строкам) все значения массива данных, который изменяется в разные стороны?
К сообщению приложен файл: _1.xlsx(8.9 Kb)
 
Ответить
СообщениеЗдравствуйте

Подскажите, пожалуйста, есть ли возможность одной формулой суммировать по столбцам (строкам) все значения массива данных, который изменяется в разные стороны?

Автор - -vp-
Дата добавления - 22.09.2020 в 16:15
AlexM Дата: Вторник, 22.09.2020, 16:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
в строке 12 значения можно получить формулой
Код
=СУММ(B4:B8)

формула для В12. Протянуть в право.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениев строке 12 значения можно получить формулой
Код
=СУММ(B4:B8)

формула для В12. Протянуть в право.

Автор - AlexM
Дата добавления - 22.09.2020 в 16:21
Nic70y Дата: Вторник, 22.09.2020, 16:24 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
непонятный вопрос,
Код
=СУММ($A$1:ИНДЕКС($1:$1048576;СТРОКА()-1;))
вдруг правильно
К сообщению приложен файл: 9268299.xlsx(9.3 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениенепонятный вопрос,
Код
=СУММ($A$1:ИНДЕКС($1:$1048576;СТРОКА()-1;))
вдруг правильно

Автор - Nic70y
Дата добавления - 22.09.2020 в 16:24
-vp- Дата: Вторник, 22.09.2020, 16:25 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
да нет, интересует что-то типа сумм(индекс(диапазон;0;столбец)), но здесь только по одному столбцу. А как одной формулой суммировать каждый столбец (или строчку)?


Сообщение отредактировал -vp- - Вторник, 22.09.2020, 16:30
 
Ответить
Сообщениеда нет, интересует что-то типа сумм(индекс(диапазон;0;столбец)), но здесь только по одному столбцу. А как одной формулой суммировать каждый столбец (или строчку)?

Автор - -vp-
Дата добавления - 22.09.2020 в 16:25
Nic70y Дата: Вторник, 22.09.2020, 16:33 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
-vp-, стало еще не понятней.


Яндекс Деньги 41001841029809
 
Ответить
Сообщение-vp-, стало еще не понятней.

Автор - Nic70y
Дата добавления - 22.09.2020 в 16:33
-vp- Дата: Вторник, 22.09.2020, 16:47 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
стало еще не понятней


???
Есть массив. Задачка: подбить итого по столбцам. Одной формулой.
 
Ответить
Сообщение
стало еще не понятней


???
Есть массив. Задачка: подбить итого по столбцам. Одной формулой.

Автор - -vp-
Дата добавления - 22.09.2020 в 16:47
AlexM Дата: Вторник, 22.09.2020, 17:08 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММ(ИНДЕКС($B$4:$F$8;СЧЁТЕСЛИ(B$3:B8;"Итого:")*СТРОКА($A6);СЧЁТЕСЛИ($A9:$A9;"Итого:")*СТОЛБЕЦ(A$1)))
К сообщению приложен файл: _1_01.xlsx(8.7 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС($B$4:$F$8;СЧЁТЕСЛИ(B$3:B8;"Итого:")*СТРОКА($A6);СЧЁТЕСЛИ($A9:$A9;"Итого:")*СТОЛБЕЦ(A$1)))

Автор - AlexM
Дата добавления - 22.09.2020 в 17:08
Nic70y Дата: Вторник, 22.09.2020, 17:08 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММ(ИНДЕКС($1:$1048576;1;СТОЛБЕЦ()):ИНДЕКС($1:$1048576;СТРОКА()-1;СТОЛБЕЦ()))
чем
=СУММ(B4:B8)
не нравится?


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС($1:$1048576;1;СТОЛБЕЦ()):ИНДЕКС($1:$1048576;СТРОКА()-1;СТОЛБЕЦ()))
чем
=СУММ(B4:B8)
не нравится?

Автор - Nic70y
Дата добавления - 22.09.2020 в 17:08
-vp- Дата: Вторник, 22.09.2020, 17:42 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
не нравится?


Ребята, дело не в том, нравится/не нравится, а в том что у Вас получается количество формул равно количеству столбцов. А вопрос был про ОДНУ формулу. Т.е. такую, результат которой сам расширится вправо в зависимости от кол-ва столбцов массива. Или это из области фантастики?


Сообщение отредактировал -vp- - Среда, 23.09.2020, 06:55
 
Ответить
Сообщение
не нравится?


Ребята, дело не в том, нравится/не нравится, а в том что у Вас получается количество формул равно количеству столбцов. А вопрос был про ОДНУ формулу. Т.е. такую, результат которой сам расширится вправо в зависимости от кол-ва столбцов массива. Или это из области фантастики?

Автор - -vp-
Дата добавления - 22.09.2020 в 17:42
AlexM Дата: Среда, 23.09.2020, 08:50 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Смотри Лист2. Может быть так нужно?
К сообщению приложен файл: _1_02.xlsx(9.7 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеСмотри Лист2. Может быть так нужно?

Автор - AlexM
Дата добавления - 23.09.2020 в 08:50
-vp- Дата: Среда, 23.09.2020, 10:38 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Ответа на вопрос сдесь не нашел. В Справке по функциям, которые возвращают массивы нет суммирующих, будь-то СУММ, СУММПРОИЗВ, СУММЕСЛИ и т.п. Надеялся, что есть другой подход к этому вопросу...
 
Ответить
СообщениеОтвета на вопрос сдесь не нашел. В Справке по функциям, которые возвращают массивы нет суммирующих, будь-то СУММ, СУММПРОИЗВ, СУММЕСЛИ и т.п. Надеялся, что есть другой подход к этому вопросу...

Автор - -vp-
Дата добавления - 23.09.2020 в 10:38
Nic70y Дата: Среда, 23.09.2020, 11:44 | Сообщение № 12
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
-vp-, чем тогда формула из сооб.№3 не подходит?


Яндекс Деньги 41001841029809
 
Ответить
Сообщение-vp-, чем тогда формула из сооб.№3 не подходит?

Автор - Nic70y
Дата добавления - 23.09.2020 в 11:44
-vp- Дата: Среда, 23.09.2020, 12:12 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Nic70y, потому что Ваша формула возвращает сумму всех значений диапазона. А меня интересует на выходе МАССИВ из сумм диапазона ПО СТОЛБЦАМ.
К примеру, Вам надо вывести номера столбцов диапазона. Формула СТОЛБЕЦ(ДИАПАЗОН) выдает МАССИВ из номеров столбцов диапазона. Интересно получить то же, только с суммами ПО СТОЛБЦАХ!


Сообщение отредактировал -vp- - Среда, 23.09.2020, 12:17
 
Ответить
СообщениеNic70y, потому что Ваша формула возвращает сумму всех значений диапазона. А меня интересует на выходе МАССИВ из сумм диапазона ПО СТОЛБЦАМ.
К примеру, Вам надо вывести номера столбцов диапазона. Формула СТОЛБЕЦ(ДИАПАЗОН) выдает МАССИВ из номеров столбцов диапазона. Интересно получить то же, только с суммами ПО СТОЛБЦАХ!

Автор - -vp-
Дата добавления - 23.09.2020 в 12:12
Nic70y Дата: Среда, 23.09.2020, 12:31 | Сообщение № 14
Группа: Друзья
Ранг: Экселист
Сообщений: 6504
Репутация: 1429 ±
Замечаний: 0% ±

ru13;10;03
Интересно
только ради этого?
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(B4;;СТОЛБЕЦ(A4:E8)-1;5;))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Интересно
только ради этого?
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(B4;;СТОЛБЕЦ(A4:E8)-1;5;))

Автор - Nic70y
Дата добавления - 23.09.2020 в 12:31
-vp- Дата: Среда, 23.09.2020, 12:36 | Сообщение № 15
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Nic70y, ну вот же! Есть оказывается решение. Спасибо!!!
 
Ответить
Сообщение Nic70y, ну вот же! Есть оказывается решение. Спасибо!!!

Автор - -vp-
Дата добавления - 23.09.2020 в 12:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений массива по столбцам (строкам) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!