Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сравнить колонки и вычислить расхождения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сравнить колонки и вычислить расхождения (Формулы/Formulas)
сравнить колонки и вычислить расхождения
Lov Дата: Четверг, 24.09.2020, 13:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте! Подскажите пожалуйста! У меня есть 2 таблицы в формате excel, там что в одной что во второй колонки такие, наименование,цена,инв.номер. Там 6500 позиций. Можно как то сравнить эти колонки и вычислить расхождения, т.к. наименование в этих колонках занесены по разному, допустим если в одной таблице стоит шкаф морозильный с инв.№4998 на 1478 позиции, а во второй таблице на 15 позиции. Помогите пожалуйста :( :shy:
К сообщению приложен файл: file2.xlsx(467.3 Kb)


Сообщение отредактировал Lov - Четверг, 24.09.2020, 13:49
 
Ответить
СообщениеЗдравствуйте! Подскажите пожалуйста! У меня есть 2 таблицы в формате excel, там что в одной что во второй колонки такие, наименование,цена,инв.номер. Там 6500 позиций. Можно как то сравнить эти колонки и вычислить расхождения, т.к. наименование в этих колонках занесены по разному, допустим если в одной таблице стоит шкаф морозильный с инв.№4998 на 1478 позиции, а во второй таблице на 15 позиции. Помогите пожалуйста :( :shy:

Автор - Lov
Дата добавления - 24.09.2020 в 13:33
-vp- Дата: Четверг, 24.09.2020, 16:45 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте

Номер позиции из Первого списка во Втором вот:
Код
=ЕСЛИОШИБКА(ИНДЕКС($I$2:$I$6506;ПОИСКПОЗ(1;(НЕ(ЕОШ(НАЙТИ(D2;$L$2:$L$6506))))*((B2&C2)=($J$2:$J$6506&$K$2:$K$6506));0));"")


После ввода формулы Ctr+Shift+Enter !


Сообщение отредактировал -vp- - Пятница, 25.09.2020, 06:33
 
Ответить
СообщениеЗдравствуйте

Номер позиции из Первого списка во Втором вот:
Код
=ЕСЛИОШИБКА(ИНДЕКС($I$2:$I$6506;ПОИСКПОЗ(1;(НЕ(ЕОШ(НАЙТИ(D2;$L$2:$L$6506))))*((B2&C2)=($J$2:$J$6506&$K$2:$K$6506));0));"")


После ввода формулы Ctr+Shift+Enter !

Автор - -vp-
Дата добавления - 24.09.2020 в 16:45
bigor Дата: Четверг, 24.09.2020, 18:03 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 48 ±
Замечаний: 0% ±

Excel 2016
Еще вариант с учетом наименования и инвентарного номера в H2
Код
=IFERROR(MATCH(J2&VALUE(SUBSTITUTE(L2;".";""));$B$2:$B$6506&VALUE(D$2:D$6506);0);"")

и тянуть вниз
 
Ответить
СообщениеЕще вариант с учетом наименования и инвентарного номера в H2
Код
=IFERROR(MATCH(J2&VALUE(SUBSTITUTE(L2;".";""));$B$2:$B$6506&VALUE(D$2:D$6506);0);"")

и тянуть вниз

Автор - bigor
Дата добавления - 24.09.2020 в 18:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сравнить колонки и вычислить расхождения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!