Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как формулой выбрать случайный адрес из диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как формулой выбрать случайный адрес из диапазона (Формулы/Formulas)
Как формулой выбрать случайный адрес из диапазона
kNNeR Дата: Четверг, 01.10.2020, 12:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте, дорогие друзья.

Скажите - как формулой (не макросом, а формулой) - выбрать случайный адрес ячейки из диапазона между A1 и M25 ?
(То есть как СЛУЧМЕЖДУ, только не для для чисел, а для адресов ячеек)
 
Ответить
СообщениеЗдравствуйте, дорогие друзья.

Скажите - как формулой (не макросом, а формулой) - выбрать случайный адрес ячейки из диапазона между A1 и M25 ?
(То есть как СЛУЧМЕЖДУ, только не для для чисел, а для адресов ячеек)

Автор - kNNeR
Дата добавления - 01.10.2020 в 12:53
ShAM Дата: Четверг, 01.10.2020, 13:04 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 223 ±
Замечаний: 0% ±

Excel 2010
Может так:
Код
=АДРЕС(СЛУЧМЕЖДУ(1;25);СЛУЧМЕЖДУ(1;13))
 
Ответить
СообщениеМожет так:
Код
=АДРЕС(СЛУЧМЕЖДУ(1;25);СЛУЧМЕЖДУ(1;13))

Автор - ShAM
Дата добавления - 01.10.2020 в 13:04
Nic70y Дата: Четверг, 01.10.2020, 13:04 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6509
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(A1:M25;СЛУЧМЕЖДУ(1;25);СЛУЧМЕЖДУ(1;13))
невнимательно прочел


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Четверг, 01.10.2020, 13:08
 
Ответить
Сообщение
Код
=ИНДЕКС(A1:M25;СЛУЧМЕЖДУ(1;25);СЛУЧМЕЖДУ(1;13))
невнимательно прочел

Автор - Nic70y
Дата добавления - 01.10.2020 в 13:04
kNNeR Дата: Четверг, 01.10.2020, 13:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
ShAM, диапазон строк понятен 1-25
А как проставлять буквы адресов ?
1-13 это совершенно непонятное обозначение. Я же не помню наизусть какие по номеру - столбцы разных букв.

Как записать в формулу записать именно вот эти две ячейки A1 и M25 (именно в так буквенно-числовом виде) - и по ним сформировать случайный выбор ?
 
Ответить
СообщениеShAM, диапазон строк понятен 1-25
А как проставлять буквы адресов ?
1-13 это совершенно непонятное обозначение. Я же не помню наизусть какие по номеру - столбцы разных букв.

Как записать в формулу записать именно вот эти две ячейки A1 и M25 (именно в так буквенно-числовом виде) - и по ним сформировать случайный выбор ?

Автор - kNNeR
Дата добавления - 01.10.2020 в 13:18
Nic70y Дата: Четверг, 01.10.2020, 13:47 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6509
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
Код
=АДРЕС(СЛУЧМЕЖДУ(СТРОКА(A1);СТРОКА(M25));СЛУЧМЕЖДУ(СТОЛБЕЦ(A1);СТОЛБЕЦ(M25));4)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=АДРЕС(СЛУЧМЕЖДУ(СТРОКА(A1);СТРОКА(M25));СЛУЧМЕЖДУ(СТОЛБЕЦ(A1);СТОЛБЕЦ(M25));4)

Автор - Nic70y
Дата добавления - 01.10.2020 в 13:47
kNNeR Дата: Четверг, 01.10.2020, 13:56 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y, то что нужно.
Спасибо.
 
Ответить
СообщениеNic70y, то что нужно.
Спасибо.

Автор - kNNeR
Дата добавления - 01.10.2020 в 13:56
bmv98rus Дата: Четверг, 01.10.2020, 18:50 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3219
Репутация: 554 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант
Код
=CELL("address";INDEX(A1:M25;RANDBETWEEN(1;ROWS(A1:M25));RANDBETWEEN(1;COLUMNS(A1:M25))))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 01.10.2020, 18:50
 
Ответить
СообщениеВариант
Код
=CELL("address";INDEX(A1:M25;RANDBETWEEN(1;ROWS(A1:M25));RANDBETWEEN(1;COLUMNS(A1:M25))))

Автор - bmv98rus
Дата добавления - 01.10.2020 в 18:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как формулой выбрать случайный адрес из диапазона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!