Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление пустых ячеек и смещение таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление пустых ячеек и смещение таблицы (Формулы/Formulas)
Удаление пустых ячеек и смещение таблицы
Shibal Дата: Пятница, 02.10.2020, 11:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день у меня есть 2 таблицы ( 1я в нее вносятся данные "лист 1", 2я только для распечатывания "лист2")

В первой таблице на "листе 1" есть выпадающее меню из определенного списка "аренда" "продажа"
Во второй таблице должны появляться только те позиции которые соответствую правилу первого листа то есть "аренда".
Пример:

Лист 1

А1 - аренда
А2 - продажа
А3 - аренда

то на листе 2 будет отображаться

А1 - аренда
А2 - пусто
А3 - аренда

Как избежать пустых строк?
К сообщению приложен файл: Test.xlsx(13.5 Kb)
 
Ответить
СообщениеДобрый день у меня есть 2 таблицы ( 1я в нее вносятся данные "лист 1", 2я только для распечатывания "лист2")

В первой таблице на "листе 1" есть выпадающее меню из определенного списка "аренда" "продажа"
Во второй таблице должны появляться только те позиции которые соответствую правилу первого листа то есть "аренда".
Пример:

Лист 1

А1 - аренда
А2 - продажа
А3 - аренда

то на листе 2 будет отображаться

А1 - аренда
А2 - пусто
А3 - аренда

Как избежать пустых строк?

Автор - Shibal
Дата добавления - 02.10.2020 в 11:27
Nic70y Дата: Пятница, 02.10.2020, 11:39 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6522
Репутация: 1436 ±
Замечаний: 0% ±

ru13;10;03
в A7
Код
=ЕСЛИОШИБКА(СТРОКА(A1)+ПОИСКПОЗ("Аренда";Лист1!D:D;)/10000;"")
A8 и далее
Код
=ЕСЛИОШИБКА(СТРОКА(A2)+(ПОИСКПОЗ("Аренда";ИНДЕКС(Лист1!D:D;ОКРУГЛ(ОСТАТ(A7;1)*10000;)+1):Лист1!D$1048576;)+ОКРУГЛ(ОСТАТ(A7;1)*10000;))/10000;"")
в B7 и далее
Код
=ЕСЛИ(A7="";"";ИНДЕКС(Лист1!A:A;ОКРУГЛ(ОСТАТ(A7;1)*10000;)))
К сообщению приложен файл: 9677974.xlsx(14.2 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениев A7
Код
=ЕСЛИОШИБКА(СТРОКА(A1)+ПОИСКПОЗ("Аренда";Лист1!D:D;)/10000;"")
A8 и далее
Код
=ЕСЛИОШИБКА(СТРОКА(A2)+(ПОИСКПОЗ("Аренда";ИНДЕКС(Лист1!D:D;ОКРУГЛ(ОСТАТ(A7;1)*10000;)+1):Лист1!D$1048576;)+ОКРУГЛ(ОСТАТ(A7;1)*10000;))/10000;"")
в B7 и далее
Код
=ЕСЛИ(A7="";"";ИНДЕКС(Лист1!A:A;ОКРУГЛ(ОСТАТ(A7;1)*10000;)))

Автор - Nic70y
Дата добавления - 02.10.2020 в 11:39
alexa1965 Дата: Пятница, 02.10.2020, 11:45 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 11 ±
Замечаний: 0% ±

2003> 2010> 2016
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$1:A$100;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!D$7:D$100="аренда";СТРОКА(Лист1!A$7:A$100);500);СТРОКА(A1)));"")

формула массивная


Главное не быть балабастиком
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$1:A$100;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!D$7:D$100="аренда";СТРОКА(Лист1!A$7:A$100);500);СТРОКА(A1)));"")

формула массивная

Автор - alexa1965
Дата добавления - 02.10.2020 в 11:45
Shibal Дата: Понедельник, 05.10.2020, 07:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
Спасибо огромное помогло


Сообщение отредактировал китин - Понедельник, 05.10.2020, 09:09
 
Ответить
СообщениеNic70y,
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
Спасибо огромное помогло

Автор - Shibal
Дата добавления - 05.10.2020 в 07:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление пустых ячеек и смещение таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!