Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сравнить значение каждой ячейки с диапазоном? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сравнить значение каждой ячейки с диапазоном? (Формулы/Formulas)
Как сравнить значение каждой ячейки с диапазоном?
sumork Дата: Воскресенье, 04.10.2020, 14:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго времени суток!

Не знаю куда написать в Excel или в VBA, склоняюсь больше ко второму. В общем задача такая, есть книга, в ней 2 листа, в первом листе есть колонка A с числами(обозначающими категорию товаров, порядка нет),
во втором листе 2 колонки A(наименования категорий товаров) и B(соответствующие категориям числа, порядок тоже никакой). Нужно сравнить каждое значение из колонки A первого листа со всеми значениями колонки B второго листа,
при полном совпадении выдернуть из той строки где было совпадение текстовое значение ячейки из колонки A и присвоить его ячейке в первом листе соответственно искомому значению. Файл с примером прилагаю. Не напрашиваюсь на готовый код/формулу, может нужное направление или какой-то пример подкинете, спасибо!
К сообщению приложен файл: __price-list-te.xls(94.5 Kb)


Сообщение отредактировал sumork - Воскресенье, 04.10.2020, 14:46
 
Ответить
СообщениеДоброго времени суток!

Не знаю куда написать в Excel или в VBA, склоняюсь больше ко второму. В общем задача такая, есть книга, в ней 2 листа, в первом листе есть колонка A с числами(обозначающими категорию товаров, порядка нет),
во втором листе 2 колонки A(наименования категорий товаров) и B(соответствующие категориям числа, порядок тоже никакой). Нужно сравнить каждое значение из колонки A первого листа со всеми значениями колонки B второго листа,
при полном совпадении выдернуть из той строки где было совпадение текстовое значение ячейки из колонки A и присвоить его ячейке в первом листе соответственно искомому значению. Файл с примером прилагаю. Не напрашиваюсь на готовый код/формулу, может нужное направление или какой-то пример подкинете, спасибо!

Автор - sumork
Дата добавления - 04.10.2020 в 14:23
bmv98rus Дата: Воскресенье, 04.10.2020, 14:41 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3219
Репутация: 554 ±
Замечаний: 0% ±

Excel 2013/2016
или какой-то пример подкинете
нет уж , сперва Вы. И это независимо от ветки форума.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
или какой-то пример подкинете
нет уж , сперва Вы. И это независимо от ветки форума.

Автор - bmv98rus
Дата добавления - 04.10.2020 в 14:41
Pelena Дата: Воскресенье, 04.10.2020, 14:41 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Файл не приложился.
Теоретически, должна помочь функция ВПР()


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Файл не приложился.
Теоретически, должна помочь функция ВПР()

Автор - Pelena
Дата добавления - 04.10.2020 в 14:41
sumork Дата: Воскресенье, 04.10.2020, 14:47 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Файл не приложился.


Доброго времени Вам, исправил сообщение, файл прикрепился
 
Ответить
Сообщение
Файл не приложился.


Доброго времени Вам, исправил сообщение, файл прикрепился

Автор - sumork
Дата добавления - 04.10.2020 в 14:47
sumork Дата: Воскресенье, 04.10.2020, 14:58 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Попробовал разобраться в функции ВПР: =ВПР(A1;Sheet2!B1:Sheet2!B230;Sheet2!A1) , но вместо нужного значение появляется ошибка #ССЫЛКА!
 
Ответить
СообщениеПопробовал разобраться в функции ВПР: =ВПР(A1;Sheet2!B1:Sheet2!B230;Sheet2!A1) , но вместо нужного значение появляется ошибка #ССЫЛКА!

Автор - sumork
Дата добавления - 04.10.2020 в 14:58
Pelena Дата: Воскресенье, 04.10.2020, 15:00 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС(Sheet2!$A$1:$A$230;ПОИСКПОЗ(A1;Sheet2!$B$1:$B$230;0))
К сообщению приложен файл: _price-list-te.xls(99.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС(Sheet2!$A$1:$A$230;ПОИСКПОЗ(A1;Sheet2!$B$1:$B$230;0))

Автор - Pelena
Дата добавления - 04.10.2020 в 15:00
sumork Дата: Воскресенье, 04.10.2020, 15:07 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, огромное спасибо, пойду разбираться
 
Ответить
СообщениеPelena, огромное спасибо, пойду разбираться

Автор - sumork
Дата добавления - 04.10.2020 в 15:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сравнить значение каждой ячейки с диапазоном? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!