Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление с заданными параметрами - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление с заданными параметрами (Формулы/Formulas)
Округление с заданными параметрами
excelman Дата: Среда, 07.10.2020, 07:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Уважаемые знатоки. Подскажите формулу:

Нужно округлить значения, если до 40 округляем вниз, если больше 40 округляем вверх. Округление до сотых. Пример:
1234 = 1200
1245 = 1300
 
Ответить
СообщениеУважаемые знатоки. Подскажите формулу:

Нужно округлить значения, если до 40 округляем вниз, если больше 40 округляем вверх. Округление до сотых. Пример:
1234 = 1200
1245 = 1300

Автор - excelman
Дата добавления - 07.10.2020 в 07:19
китин Дата: Среда, 07.10.2020, 07:46 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
так?
Код
=ЕСЛИ(--ПРАВБ(A1;2)<40;ОКРВНИЗ(A1;100);ОКРВВЕРХ(A1;100))


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(--ПРАВБ(A1;2)<40;ОКРВНИЗ(A1;100);ОКРВВЕРХ(A1;100))

Автор - китин
Дата добавления - 07.10.2020 в 07:46
Pelena Дата: Среда, 07.10.2020, 08:37 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Можно ещё попробовать
Код
=ОКРУГЛТ(A1+10;100)

Код
=ОКРУГЛ(A1+10;-2)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеМожно ещё попробовать
Код
=ОКРУГЛТ(A1+10;100)

Код
=ОКРУГЛ(A1+10;-2)

Автор - Pelena
Дата добавления - 07.10.2020 в 08:37
Nic70y Дата: Среда, 07.10.2020, 08:41 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
наверное +9
если больше 40 округляем вверх


ЮMoney 41001841029809
 
Ответить
Сообщениенаверное +9
если больше 40 округляем вверх

Автор - Nic70y
Дата добавления - 07.10.2020 в 08:41
Pelena Дата: Среда, 07.10.2020, 08:52 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
наверное +9

зависит от того, куда округлять 40. По условию не понятно


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
наверное +9

зависит от того, куда округлять 40. По условию не понятно

Автор - Pelena
Дата добавления - 07.10.2020 в 08:52
excelman Дата: Среда, 07.10.2020, 09:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
=ЕСЛИ(--ПРАВБ(A1;2)<40;ОКРВНИЗ(A1;100);ОКРВВЕРХ(A1;100))


Отличная формула, подошла мне. Спасибо!
 
Ответить
Сообщение
=ЕСЛИ(--ПРАВБ(A1;2)<40;ОКРВНИЗ(A1;100);ОКРВВЕРХ(A1;100))


Отличная формула, подошла мне. Спасибо!

Автор - excelman
Дата добавления - 07.10.2020 в 09:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление с заданными параметрами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!