Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Обращение к ячейки по номеру - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обращение к ячейки по номеру (Формулы/Formulas)
Обращение к ячейки по номеру
Halget Дата: Четверг, 08.10.2020, 16:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
допустим есть большой столбец данных с числами от 0 д 100. Рядом есть второй столбец с числами от 1 до 1000000 разбросанных в случайном порядке. Можно ли как то используя номер, записанный во втором столбце, вывести ячейку с этим номером?
Например: в ячейке B1 число 999 и мне нужно, чтобы в значение C1 попало значение ячейки A999; в ячейке B2 число 200 - в ячейку C2 число A200
 
Ответить
СообщениеДобрый день!
допустим есть большой столбец данных с числами от 0 д 100. Рядом есть второй столбец с числами от 1 до 1000000 разбросанных в случайном порядке. Можно ли как то используя номер, записанный во втором столбце, вывести ячейку с этим номером?
Например: в ячейке B1 число 999 и мне нужно, чтобы в значение C1 попало значение ячейки A999; в ячейке B2 число 200 - в ячейку C2 число A200

Автор - Halget
Дата добавления - 08.10.2020 в 16:36
Che79 Дата: Четверг, 08.10.2020, 16:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1629
Репутация: 301 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Добрый и Вам. Попробуйте связку ИНДЕКС+ПОИСКПОЗ, точнее при наличии файла-примера.


Делай нормально и будет нормально!
 
Ответить
СообщениеДобрый и Вам. Попробуйте связку ИНДЕКС+ПОИСКПОЗ, точнее при наличии файла-примера.

Автор - Che79
Дата добавления - 08.10.2020 в 16:40
Michael_S Дата: Четверг, 08.10.2020, 16:45 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2005
Репутация: 372 ±
Замечаний: 0% ±

Excel2016
В С1 формула:
Код
=ДВССЫЛ("A"&B1)
или
Код
=ИНДЕКС(A:A;B1)


Сообщение отредактировал Michael_S - Четверг, 08.10.2020, 16:47
 
Ответить
СообщениеВ С1 формула:
Код
=ДВССЫЛ("A"&B1)
или
Код
=ИНДЕКС(A:A;B1)

Автор - Michael_S
Дата добавления - 08.10.2020 в 16:45
Hugo Дата: Четверг, 08.10.2020, 16:50 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3097
Репутация: 665 ±
Замечаний: 0% ±

Достаточно
Код
=ИНДЕКС($A$1:$A$10;B1;1)

http://prntscr.com/uviahk


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
СообщениеДостаточно
Код
=ИНДЕКС($A$1:$A$10;B1;1)

http://prntscr.com/uviahk

Автор - Hugo
Дата добавления - 08.10.2020 в 16:50
Halget Дата: Четверг, 08.10.2020, 16:52 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо всем большое!
 
Ответить
СообщениеСпасибо всем большое!

Автор - Halget
Дата добавления - 08.10.2020 в 16:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обращение к ячейки по номеру (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!