Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выделение ячеек в столбце по сумме формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выделение ячеек в столбце по сумме формулой (Формулы/Formulas)
Выделение ячеек в столбце по сумме формулой
Raiw Дата: Среда, 14.10.2020, 10:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Помогите пожалуйста с вопросом, можно ли это сделать формулой?

Есть Массив данных(недопоставка поставщиками материалов на склад), необходимо в рамках каждого поставщика выделить первые ячейки в столбце, где сумма недопоставки составляет не менее 20%, т.е. если 3 ячейки в сумме дают 21%, а 4 ячейки дают 24%, то должно быть выделено 3 первые ячейки в столбце в рамках отдельно взятого поставщика
К сообщению приложен файл: _Excel.xlsx(9.1 Kb)


Сообщение отредактировал Raiw - Среда, 14.10.2020, 16:17
 
Ответить
СообщениеДобрый день!
Помогите пожалуйста с вопросом, можно ли это сделать формулой?

Есть Массив данных(недопоставка поставщиками материалов на склад), необходимо в рамках каждого поставщика выделить первые ячейки в столбце, где сумма недопоставки составляет не менее 20%, т.е. если 3 ячейки в сумме дают 21%, а 4 ячейки дают 24%, то должно быть выделено 3 первые ячейки в столбце в рамках отдельно взятого поставщика

Автор - Raiw
Дата добавления - 14.10.2020 в 10:36
igrtsk Дата: Среда, 14.10.2020, 13:49 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 257
Репутация: 34 ±
Замечаний: 0% ±

Excel 2016
Внимательно ознакомьтесь
http://www.excelworld.ru/forum/2-20-1
и приведите пост в соответствие


Инструктор по применению лосей в кавалерийских частях РККА
 
Ответить
СообщениеВнимательно ознакомьтесь
http://www.excelworld.ru/forum/2-20-1
и приведите пост в соответствие

Автор - igrtsk
Дата добавления - 14.10.2020 в 13:49
Pelena Дата: Среда, 14.10.2020, 16:23 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16668
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула для УФ
Код
=СУММЕСЛИ($A$2:$A2;$A2;$C$2:$C2)<=20%+$C2

или даже так
Код
=СУММЕСЛИ($A$1:$A1;$A2;$C$1:$C1)<20%
К сообщению приложен файл: 3538145.xlsx(9.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула для УФ
Код
=СУММЕСЛИ($A$2:$A2;$A2;$C$2:$C2)<=20%+$C2

или даже так
Код
=СУММЕСЛИ($A$1:$A1;$A2;$C$1:$C1)<20%

Автор - Pelena
Дата добавления - 14.10.2020 в 16:23
Raiw Дата: Пятница, 16.10.2020, 09:18 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Спасибо большое! А если между столбцами будет добавлено определенное кол-во столбцов, в формуле можно будет поменять данные буков столбцов?
 
Ответить
СообщениеPelena, Спасибо большое! А если между столбцами будет добавлено определенное кол-во столбцов, в формуле можно будет поменять данные буков столбцов?

Автор - Raiw
Дата добавления - 16.10.2020 в 09:18
Pelena Дата: Пятница, 16.10.2020, 09:22 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16668
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
А проверить?)
Думаю, можно


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА проверить?)
Думаю, можно

Автор - Pelena
Дата добавления - 16.10.2020 в 09:22
Raiw Дата: Понедельник, 19.10.2020, 12:57 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Спасибо большое)
 
Ответить
СообщениеPelena, Спасибо большое)

Автор - Raiw
Дата добавления - 19.10.2020 в 12:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выделение ячеек в столбце по сумме формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!