Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка даты (Формулы/Formulas)
Вставка даты
nekto Дата: Суббота, 14.11.2020, 00:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Имеется таблица сотрудников и промежуток дат начальная дата и конечная дата контроля. список околок 5000 фамилии часто повторяются. так же есть таблица контроля с датами когда проводилась проверка. околок 80000 строк. Помогите как выгрузить из 2 таблицы дату в первую при условии что бы дата была >= началу контроля в первой таблице. есть ньюансы 1. в промежутке начальной и конечной даты он может сделать два три контроля, вставляться должен первый. 2. он может контроль сделать позже и тогда дата будет больше чем конечная дата контроля. и так как фамилии повторяются привязка должна быть к начальной дате контроля. пример в приложенном файле как должно быть
К сообщению приложен файл: 6887029.xlsx(9.4 Kb)


Сообщение отредактировал nekto - Суббота, 14.11.2020, 00:23
 
Ответить
СообщениеИмеется таблица сотрудников и промежуток дат начальная дата и конечная дата контроля. список околок 5000 фамилии часто повторяются. так же есть таблица контроля с датами когда проводилась проверка. околок 80000 строк. Помогите как выгрузить из 2 таблицы дату в первую при условии что бы дата была >= началу контроля в первой таблице. есть ньюансы 1. в промежутке начальной и конечной даты он может сделать два три контроля, вставляться должен первый. 2. он может контроль сделать позже и тогда дата будет больше чем конечная дата контроля. и так как фамилии повторяются привязка должна быть к начальной дате контроля. пример в приложенном файле как должно быть

Автор - nekto
Дата добавления - 14.11.2020 в 00:22
Pelena Дата: Суббота, 14.11.2020, 06:48 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16795
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Как вариант
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;$J$2:$J$80000/(A2=$I$2:$I$80000)/(B2<=$J$2:$J$80000);1);"")
К сообщению приложен файл: 2752659.xlsx(10.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Как вариант
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;$J$2:$J$80000/(A2=$I$2:$I$80000)/(B2<=$J$2:$J$80000);1);"")

Автор - Pelena
Дата добавления - 14.11.2020 в 06:48
nekto Дата: Суббота, 14.11.2020, 21:16 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Спасибо большое, но есть одно но, когда вставил в таблицу, получилось так, что вставляется дата которая была до контроля, там где должны быть пустые ячейки, пример обновил и добавил как получается
К сообщению приложен файл: 9601342.xlsx(10.2 Kb)


Сообщение отредактировал nekto - Суббота, 14.11.2020, 21:18
 
Ответить
СообщениеPelena, Спасибо большое, но есть одно но, когда вставил в таблицу, получилось так, что вставляется дата которая была до контроля, там где должны быть пустые ячейки, пример обновил и добавил как получается

Автор - nekto
Дата добавления - 14.11.2020 в 21:16
Pelena Дата: Суббота, 14.11.2020, 21:26 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16795
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
У Вильнова дата сохранена как текст. Двойной клик по ячейке J14 -- Enter


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ Вильнова дата сохранена как текст. Двойной клик по ячейке J14 -- Enter

Автор - Pelena
Дата добавления - 14.11.2020 в 21:26
nekto Дата: Суббота, 14.11.2020, 23:58 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Спасибо Вам большое
 
Ответить
СообщениеPelena, Спасибо Вам большое

Автор - nekto
Дата добавления - 14.11.2020 в 23:58
nekto Дата: Воскресенье, 15.11.2020, 19:44 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Я извиняюсь, не подскажите как можно сделать по двум критериям дат, примерно тоже самое, первый конторль делается отлично, а вот второй критерии 2 даты: 1.больше или равно конца первого контроля 2. больше исполнения. пример в файле.
К сообщению приложен файл: 6770875.xlsx(9.5 Kb)
 
Ответить
СообщениеPelena, Я извиняюсь, не подскажите как можно сделать по двум критериям дат, примерно тоже самое, первый конторль делается отлично, а вот второй критерии 2 даты: 1.больше или равно конца первого контроля 2. больше исполнения. пример в файле.

Автор - nekto
Дата добавления - 15.11.2020 в 19:44
Pelena Дата: Воскресенье, 15.11.2020, 21:31 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16795
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Я не поняла задачу, приведите больше примеров с пояснением полученных результатов


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЯ не поняла задачу, приведите больше примеров с пояснением полученных результатов

Автор - Pelena
Дата добавления - 15.11.2020 в 21:31
nekto Дата: Воскресенье, 15.11.2020, 22:20 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Вроде разобрался, похоже дата сохранена как текст, 2 раз на те же грабли,. И как я понял, что бы столбец сделать не как текст, надо выделить столбец -данные- текст по столбцам- готово. Извините и спасибо Огромное еще раз.
 
Ответить
СообщениеPelena, Вроде разобрался, похоже дата сохранена как текст, 2 раз на те же грабли,. И как я понял, что бы столбец сделать не как текст, надо выделить столбец -данные- текст по столбцам- готово. Извините и спасибо Огромное еще раз.

Автор - nekto
Дата добавления - 15.11.2020 в 22:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!