Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений исходя из порядкового номера группы стр - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений исходя из порядкового номера группы стр (Формулы/Formulas)
Подстановка значений исходя из порядкового номера группы стр
yaroslavpo Дата: Понедельник, 16.11.2020, 19:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Приветствую, уважаемые мастера. Стоит задача следующего рода - есть пул запросов от нескольких единиц, до нескольких десятков, которые объединены под порядковым номер для каждой группы. Каждой группе запросов соответствует словесный идентификатор. Проблема в том, что в таких группах встречаются запросы с неприсвоенным идентификатором.

Задача стоит следующего рода, каким образом прописать формулу (я так понимаю это делается через =ЕСЛИ), чтобы словесный идентификатор подтягивался исходя из числового. Пример файла прикрепляю

На скрине указан пример - там где отмечено красным, вместо 1111 нужно чтобы выводились "кинологи"
К сообщению приложен файл: 1139095.xlsx(9.4 Kb)


Сообщение отредактировал yaroslavpo - Понедельник, 16.11.2020, 19:48
 
Ответить
СообщениеПриветствую, уважаемые мастера. Стоит задача следующего рода - есть пул запросов от нескольких единиц, до нескольких десятков, которые объединены под порядковым номер для каждой группы. Каждой группе запросов соответствует словесный идентификатор. Проблема в том, что в таких группах встречаются запросы с неприсвоенным идентификатором.

Задача стоит следующего рода, каким образом прописать формулу (я так понимаю это делается через =ЕСЛИ), чтобы словесный идентификатор подтягивался исходя из числового. Пример файла прикрепляю

На скрине указан пример - там где отмечено красным, вместо 1111 нужно чтобы выводились "кинологи"

Автор - yaroslavpo
Дата добавления - 16.11.2020 в 19:24
bmv98rus Дата: Понедельник, 16.11.2020, 20:03 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3247
Репутация: 558 ±
Замечаний: 0% ±

Excel 2013/2016


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениекросс

Автор - bmv98rus
Дата добавления - 16.11.2020 в 20:03
Serge_007 Дата: Вторник, 17.11.2020, 00:25 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13355
Репутация: ±
Замечаний: ±

Excel 2010
Здравствуйте

там где отмечено красным, вместо 1111 нужно чтобы выводились "кинологи"
Заменить цифровой идентификатор на текстовый формулой не получится, т.к. формулу, по таким условиям, надо прописать в той же ячейке, что и уже имеющееся в ней значение

Самое простое решение - это допстолбец, таблица соответствий и ВПР


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

там где отмечено красным, вместо 1111 нужно чтобы выводились "кинологи"
Заменить цифровой идентификатор на текстовый формулой не получится, т.к. формулу, по таким условиям, надо прописать в той же ячейке, что и уже имеющееся в ней значение

Самое простое решение - это допстолбец, таблица соответствий и ВПР

Автор - Serge_007
Дата добавления - 17.11.2020 в 00:25
-vp- Дата: Вторник, 17.11.2020, 18:03 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 57
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте,
формула массива:
Код
=ЕСЛИ(ЕТЕКСТ(E2:E20);(E2:E20);ИНДЕКС(E2:E20;ПОИСКПОЗ(A2:A20;ЕСЛИ(ЕТЕКСТ(E2:E20);(A2:A20));0)))
К сообщению приложен файл: yaroslavpo.xlsx(10.5 Kb)
 
Ответить
СообщениеЗдравствуйте,
формула массива:
Код
=ЕСЛИ(ЕТЕКСТ(E2:E20);(E2:E20);ИНДЕКС(E2:E20;ПОИСКПОЗ(A2:A20;ЕСЛИ(ЕТЕКСТ(E2:E20);(A2:A20));0)))

Автор - -vp-
Дата добавления - 17.11.2020 в 18:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений исходя из порядкового номера группы стр (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!