Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для подсчета времени в табеле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчета времени в табеле (Формулы/Formulas)
Формула для подсчета времени в табеле
Shcaf1234 Дата: Вторник, 17.11.2020, 16:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Коллеги, добрый день, возникла необходимость в изменении формулы для подсчета времени в табеле, Обьясню суть:
Есть сотрудники со статусом Адаптация и статусом Входящие, во статусе адаптация они находятся на стадии обучения, которая длится 14 дней, после того, как проходит 14 дней, они попадают в статус Входящие, смысл в том, что до момента, когда они попадают в статус Входящие их часы в табеле не учитываются, а после того, как попадают в статус входящие, их часы распределяются не с того дня, когда у них наступил статус Входящие, а с начала месяца, грубо говоря, это выглядит так, как будто они работали в общем сегменте весь месяц, смысл в том, что нужно сделать формулу, благодаря которой, часы распределялись только с того дня, когда они перешли во статус Входящие.
Формулы:
Код
=ЕСЛИ(И(СЕГОДНЯ()-I4>7;СЕГОДНЯ()-I4<15);"Адаптация";ЕСЛИ(СЕГОДНЯ()-I4>=15;"Входящие";))
для опеределения статуса сотрудника по дням.
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕСЛИ($CB5="0,5.1";S5-R5;S5-R5-1)-R4<=0;;ЕСЛИ($CB5="0,5.1";S5-R5;S5-R5-1)-R4);ЕСЛИ(ЕСЛИОШИБКА(ЛЕВСИМВ(S5;2)-ЕСЛИОШИБКА(ЛЕВСИМВ(R5;ПОИСК("п";R5)-1);ЛЕВСИМВ(R5;ПОИСК("д";R5)-1)))<5;ЕСЛИОШИБКА(ЛЕВСИМВ(S5;2)-ЕСЛИОШИБКА(ЛЕВСИМВ(R5;ПОИСК("п";R5)-1);ЛЕВСИМВ(R5;ПОИСК("д";R5)-1)));ЕСЛИОШИБКА(ЛЕВСИМВ(S5;2)-ЕСЛИОШИБКА(ЛЕВСИМВ(R5;ПОИСК("п";R5)-1);ЛЕВСИМВ(R5;ПОИСК("д";R5)-1)))-1))
, а вот формула ячеек, которая рассчитывает часы.


ПШШ

Сообщение отредактировал Shcaf1234 - Вторник, 17.11.2020, 16:56
 
Ответить
СообщениеКоллеги, добрый день, возникла необходимость в изменении формулы для подсчета времени в табеле, Обьясню суть:
Есть сотрудники со статусом Адаптация и статусом Входящие, во статусе адаптация они находятся на стадии обучения, которая длится 14 дней, после того, как проходит 14 дней, они попадают в статус Входящие, смысл в том, что до момента, когда они попадают в статус Входящие их часы в табеле не учитываются, а после того, как попадают в статус входящие, их часы распределяются не с того дня, когда у них наступил статус Входящие, а с начала месяца, грубо говоря, это выглядит так, как будто они работали в общем сегменте весь месяц, смысл в том, что нужно сделать формулу, благодаря которой, часы распределялись только с того дня, когда они перешли во статус Входящие.
Формулы:
Код
=ЕСЛИ(И(СЕГОДНЯ()-I4>7;СЕГОДНЯ()-I4<15);"Адаптация";ЕСЛИ(СЕГОДНЯ()-I4>=15;"Входящие";))
для опеределения статуса сотрудника по дням.
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕСЛИ($CB5="0,5.1";S5-R5;S5-R5-1)-R4<=0;;ЕСЛИ($CB5="0,5.1";S5-R5;S5-R5-1)-R4);ЕСЛИ(ЕСЛИОШИБКА(ЛЕВСИМВ(S5;2)-ЕСЛИОШИБКА(ЛЕВСИМВ(R5;ПОИСК("п";R5)-1);ЛЕВСИМВ(R5;ПОИСК("д";R5)-1)))<5;ЕСЛИОШИБКА(ЛЕВСИМВ(S5;2)-ЕСЛИОШИБКА(ЛЕВСИМВ(R5;ПОИСК("п";R5)-1);ЛЕВСИМВ(R5;ПОИСК("д";R5)-1)));ЕСЛИОШИБКА(ЛЕВСИМВ(S5;2)-ЕСЛИОШИБКА(ЛЕВСИМВ(R5;ПОИСК("п";R5)-1);ЛЕВСИМВ(R5;ПОИСК("д";R5)-1)))-1))
, а вот формула ячеек, которая рассчитывает часы.

Автор - Shcaf1234
Дата добавления - 17.11.2020 в 16:26
Pelena Дата: Вторник, 17.11.2020, 16:30 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Shcaf1234, оформите, плз, формулы тегами с помощью кнопки fx в режиме правки поста. И файл с небольшим примером помог бы в понимании проблемы.

==================
С формулами получилось, а что насчёт файла с примером?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеShcaf1234, оформите, плз, формулы тегами с помощью кнопки fx в режиме правки поста. И файл с небольшим примером помог бы в понимании проблемы.

==================
С формулами получилось, а что насчёт файла с примером?

Автор - Pelena
Дата добавления - 17.11.2020 в 16:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчета времени в табеле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!